Noise Figure Measurements (R&S FSW-K30)
Contents
  • Welcome to the Noise Figure Measurement Application
  • Measurements and Result Displays
  • Measurement Basics
  • Configuration
  • Analysis
  • Remote Control Commands for Noise Measurements
  • List of Commands
Top


Welcome to the Noise Figure Measurement Application

Noise Figure Measurements (R&S FSW-K30) > Welcome to the Noise Figure Measurement Application
Welcome to the Noise Figure Measurement Application

The R&S FSW-K30 is a firmware application that adds functionality to perform noise figure measurements to the R&S FSW.

This user manual contains a description of the functionality that the application provides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are described in the R&S FSW User Manual. The latest version is available for download at the product homepage

http://www2.rohde-schwarz.com/product/FSW.html.

Installation

Find detailed installing instructions in the Getting Started or the release notes of the R&S FSW.

Contents
  • Starting the Application
  • Understanding the Display Information


Starting the Application

Noise Figure Measurements (R&S FSW-K30) > Welcome to the Noise Figure Measurement Application > Starting the Application
Starting the Application

The noise figure measurement application adds a new type of measurement to the R&S FSW.

To activate the the Noise Figure application

  1. Press the MODE key on the front panel of the R&S FSW.

    A dialog box opens that contains all operating modes and applications currently available on your R&S FSW.

  2. Select the "Noise" item.

    The R&S FSW opens a new measurement channel for the noise figure measurement application.

    All settings specific to noise figure measurements are in their default state.

For details see "Operating Modes" .

Multiple Measurement Channels and Sequencer Function

When you enter an application, a new measurement channel is created which determines the measurement settings for that application. The same application can be activated with different measurement settings by creating several channels for the same application.

The number of channels that can be configured at the same time depends on the available memory on the instrument.

Only one measurement can be performed at any time, namely the one in the currently active channel. However, in order to perform the configured measurements consecutively, a Sequencer function is provided.

If activated, the measurements configured in the currently active channels are performed one after the other in the order of the tabs. The currently active measurement is indicated by a [image] symbol in the tab label. The result displays of the individual channels are updated in the tabs (as well as the "MultiView") as the measurements are performed. Sequential operation itself is independent of the currently displayed tab.

For details on the Sequencer function see "Running a Sequence of Measurements" .


Understanding the Display Information

Noise Figure Measurements (R&S FSW-K30) > Welcome to the Noise Figure Measurement Application > Understanding the Display Information
Understanding the Display Information

The following figure shows the display as it looks for noise figure measurements. All different information areas are labeled. They are explained in more detail in the following sections.

Screen layout of the noise figure measurement application
1 = Toolbar
2 = Channel bar
3 = Diagram header
4 = Result display
5 = Softkey bar
6 = Status bar
Channel bar information

The channel bar contains information about the current measurement setup, progress and results.

Channel bar of the Noise Figure application
Ref Level | Reference level of the R&S FSW.
Att | Attenuation of the R&S FSW.
RBW | Resolution bandwidth
SWT | Sweep time
AVG | Number of averages
ENR | Excess noise ratio
2nd Stage Corr | State of the 2nd stage correction.
Calibration Data | Date and time of the current calibration data.
Mode | Currently selected measurement mode.
Window title bar information

For each diagram, the header provides the following information:

Window title bar information for the Noise Figure application
1 = Window number
2 = Window type
3 = Trace color and number
4 = Trace mode
Status bar information

Global instrument settings, the instrument status and any irregularities are indicated in the status bar beneath the diagram. Furthermore, the progress of the current operation is displayed in the status bar.

Risk of damaging the instrument

Make sure not to overload the input mixer during calibration and the measurement. An overload condition may damage or destroy the input mixer.

If an ocerload condition occurs, the R&S FSW shows a corresponding message in the status line ("RF OVLD" or "IF OVLD").

To avoid an overload during calibration or measurement
  • check and adjust the DUT gain settings,
  • check and adjust the ENR settings
    or
  • increase the reference level.


Measurements and Result Displays

Noise Figure Measurements (R&S FSW-K30) > Measurements and Result Displays
Measurements and Result Displays

The R&S FSW-K30 measures the noise figure of a DUT and displays the results graphically and numerically. Each graphical result display shows the noise figure from a different perspective that may be relevant. In the default configuration, the application shows the Noise Figure of the DUT, the Gain of the DUT and the corresponding Y-Factor. In addition it shows the numerical results of the measurement.

The scale of the horizontal axis depends on the tuning mode.

Frequency list and swept measurements

In all graphical result displays, the horizontal axis represents the frequency. The displayed frequency is either the RF (radio frequency) or the IF (intermediate frequency). The range depends on the frequency set you have currently defined. Because the application only measures selected frequencies, it connects the results to draw a trace.

Negative noise figure and noise temperature

From a physical point of view, the noise figure and the noise temperature levels have a positive range (including zero).

Because of the mathematical operations the application performs, it may also show negative values in some cases. This may be due to incorrect calibration or variance of measurement values.

Single frequency measurements

In all graphical result displays, the horizontal axis represents a chronological order of measurement results for the frequency you are testing. The axis has no unit, but is made up out of several index values that represent time. Each index value represents one measurement point and therefore one measurement on the single frequency you are analyzing. The size of the index (and thus number of results) depends on the number of (Measurement) Points that you have defined. Because the application only measures at certain points in time, it connects the results to draw a trace.

The right diagram border represents the present (index = 0), values to the left represent past measurement results (index = -<x>). As soon as the application finishes a single measurement, the measurement points are moved to the left, the new result is added on the right. All other measurement points are moved down one position with the most obsolete result falling out of the diagram (like in the roll mode of an oscilloscope).

Selecting the result display
►

Select the [image] icon in the toolbar or press the MEAS key.

The application enters the SmartGrid configuration mode.

For more information on the SmartGrid functionality see the R&S FSW Getting Started.

└ Noise Figure
└ Gain
└ Noise Temperature
└ Y-Factor
└ Power (Hot)
└ Power (Cold)
└ Result Table
└ Current
└ Marker Table


Noise Figure

Noise Figure Measurements (R&S FSW-K30) > Measurements and Result Displays > Noise Figure
Noise Figure

Shows the noise figure of the DUT.

The noise figure is the ratio of the signal-to-noise ratio at the DUT input to that at the DUT output.

The vertical axis shows the level of the noise figure in dB. The scale depends on the settings in the "Display Configuration" dialog box.

Remote command:

TRACe<t>[:DATA] NFIGure


Gain

Noise Figure Measurements (R&S FSW-K30) > Measurements and Result Displays > Gain
Gain

Shows the gain characteristics of the DUT.

The vertical axis shows the level of the gain in dB. The scale depends on the settings in the "Display Configuration" dialog box.

Remote command:

TRACe<t>[:DATA] GAIN


Noise Temperature

Noise Figure Measurements (R&S FSW-K30) > Measurements and Result Displays > Noise Temperature
Noise Temperature

Shows the noise temperature characteristics of the DUT.

The vertical axis shows the noise temperature in Kelvin. The scale depends on the settings in the "Display Configuration" dialog box.

Remote command:

TRACe<t>[:DATA] TEMPerature


Y-Factor

Noise Figure Measurements (R&S FSW-K30) > Measurements and Result Displays > Y-Factor
Y-Factor

Shows the ratio of the hot and the cold power of the DUT.

The Y-factor indicates the quality of measurement tolerances and uncertainties. To get the result, the application measures the DUT power with the noise source turned on (hot power) and the noise source turned off (cold power).

The vertical axis shows the linear relation. The scale depends on the settings in the "Display Configuration" dialog box.

Remote command:

TRACe<t>[:DATA] YFACtor


Power (Hot)

Noise Figure Measurements (R&S FSW-K30) > Measurements and Result Displays > Power (Hot)
Power (Hot)

Shows the absolute power characteristics at the instrument input. The noise source is turned on.

The vertical axis shows the power in dBm. The scale depends on the settings in the "Display Configuration" dialog box.

Remote command:

TRACe<t>[:DATA] PHOT


Power (Cold)

Noise Figure Measurements (R&S FSW-K30) > Measurements and Result Displays > Power (Cold)
Power (Cold)

Shows the absolute power characteristics at the instrument input. The noise source is turned off.

The vertical axis shows the power in dBm. The scale depends on the settings in the "Display Configuration" dialog box.

Remote command:

TRACe<t>[:DATA] PCOLd


Result Table

Noise Figure Measurements (R&S FSW-K30) > Measurements and Result Displays > Result Table
Result Table

Shows the measurement results in numerical form in a table.

The contents of the table depend on the "Display Settings". By default it shows the results for the Noise Figure, Gain and Y-Factor result type. Each row represents one measurement point. Each column represents one result type. The first column shows the measurement frequency.

If you display the uncertainty result, it is displayed in the Noise column next to the Noise Figure result. Note that the uncertainty is displayed only after you have turned on the uncertainty calculation and also include the result in the display.

The result table shows either the RF or the IF, depending on you selection.

For more information see "Configuring Numerical Results".

Remote command:

TRACe<n>[:​DATA]?


Current

Noise Figure Measurements (R&S FSW-K30) > Measurements and Result Displays > Current
Current

Shows the result at the current measurement point.

The contents of the "Current" result display are updated as soon as a new measurement point is analyzed.

The result types shown in the table depend on the "Display Settings". By default it shows the results for the Noise Figure, Gain and Y-Factor result type. Each row represents one result type. The first column shows the result type, the second column shows the result.

For more information see "Configuring Numerical Results".


Marker Table

Noise Figure Measurements (R&S FSW-K30) > Measurements and Result Displays > Marker Table
Marker Table

Shows the marker characteristics in numerical form in a table.

The size of the table depends on the number of active markers and the way you have configured the table in the "Result Config" dialog box. For more information see "Using Markers" and "Configuring Numerical Results".

The first four columns of the table are fix.

  • Type
    Shows the marker type. 'M' represents a normal marker, 'D' represents a delta marker.
  • Ref
    Shows the reference marker for relative delta markers.
  • Trc
    Shows the trace the marker is positioned on.
  • X-value
    Shows the horizontal position (frequency) of the marker.
    In case of normal markers, the position is an absolute value. The position of delta markers are relative to another marker.
  • <Result>
    Shows the measurement result at the marker position.
    In case of normal markers, the result is an absolute value. Results for delta markers are relative to another marker.
Remote command:

CALCulate<n>:​MARKer<m>:​Y?

CALCulate<n>:​DELTamarker<m>:​Y?


Measurement Basics

Noise Figure Measurements (R&S FSW-K30) > Measurement Basics
Measurement Basics

The measurement basics contain background information on the terminology and principles of noise measurements.

Noise figure measurements determine the noise that a device under test (DUT) adds to a signal as that signal passes through the DUT.

Contents
  • Tuning Modes
  • DUT Types
  • External Generator Control
  • Image Frequency Rejection
  • Calibration (2nd Stage Correction)
  • Separating Signals by Selecting an Appropriate Resolution Bandwidth
  • Analyzing Several Traces - Trace Mode
  • Using Markers


Tuning Modes

Noise Figure Measurements (R&S FSW-K30) > Measurement Basics > Tuning Modes
Tuning Modes

Basically, the application calculates the noise figure of a DUT based on the characteristics of the DUT that have been measured and a noise source whose properties are known.

In addition to the noise characteristics of a DUT, the application is also able to determine several more DUT characteristics like its gain or its noise temperature characteristics.

The application provides several measurement modes or tuning modes.

Contents
  • Swept Measurements
  • Frequency Table Measurements
  • Single Frequency Measurements


Swept Measurements

Noise Figure Measurements (R&S FSW-K30) > Measurement Basics > Tuning Modes > Swept Measurements
Swept Measurements

The sweep tuning mode performs measurements on a set of discrete frequencies based on the frequency parameters. Each measurement analyzes the noise characteristics of the corresponding frequency or measurement point.

For swept measurements, the application automatically determines the measurement frequencies and combines them in a frequency list.

Such a frequency set is the result of the frequency and span information that you have provided. The frequency and span information is made up out of the center frequency, the span, the start and the stop frequency. In combination with the measurement points or the frequency table step size, the application calculates the contents of the frequency table.

The center frequency is the frequency in the center of the frequency band you are measuring. Thus, it is defined either by the span or the start and stop frequencies.

The measurement points is the number of entries in a frequency list and thus the number of measurements that the application performs during a noise figure measurement.

The stepsize defines the distance between two measurement points. It is constant for all measurement points.

If the stepsize is larger than the distance between start and stop frequency, the frequency table consists of the start and stop frequencies only.


Frequency Table Measurements

Noise Figure Measurements (R&S FSW-K30) > Measurement Basics > Tuning Modes > Frequency Table Measurements
Frequency Table Measurements

The frequency table tuning mode also performs measurements on a set of frequencies based on the contents of a frequency list. Each measurement analyzes the noise characteristics of the corresponding frequency.

Compared to a swept measurement, you can customize the contents of the frequency list. Thus, you can add frequencies that are independent of the frequency stepsize and the number of measurement points.


Single Frequency Measurements

Noise Figure Measurements (R&S FSW-K30) > Measurement Basics > Tuning Modes > Single Frequency Measurements
Single Frequency Measurements

The single frequency tuning mode performs one or several consecutive measurements on a single frequency. You can perform the measurement on any frequency that is supported by the hardware you are using.

Single frequency measurements are a way to facilitate manual adjustments for noise figure measurements. They also allow you to get an idea about how the noise figure at a particular frequency change over time.

Note that sweep lists or frequency tables are not considered in this measurement mode.

Single frequency measurement results

For single frequency measurements, the same set of graphical result displays is available as for frequency list measurements (Noise Figure, Gain etc.). Note, however, that the x-axis has no unit, but shows a series of results taken for a single frequency. The number of displayed results depends on the number of measurement points you have defined.

For more information see "Measurements and Result Displays".

In addition, you can also view the results in the Result Table in numerical form.


DUT Types

Noise Figure Measurements (R&S FSW-K30) > Measurement Basics > DUT Types
DUT Types

Noise figure measurements are possible on DUTs with a wide variety of characteristics. The DUT characteristics are important to know because they not only have an effect on the test setup, but also determine the way the application populates the frequency list in case of swept measurements.

The R&S FSW-K30 supports measurements on DUTs that work on a fixed frequency as well as measurements on frequency-converting DUTs.

Contents
  • Measurements on Linear DUTs
  • Measurements on Frequency Converting DUTs


Measurements on Linear DUTs

Noise Figure Measurements (R&S FSW-K30) > Measurement Basics > DUT Types > Measurements on Linear DUTs
Measurements on Linear DUTs

In case of a linear DUT, the RF frequency remains the same between its input and output. For measurements on such DUTs, it is sufficient to measure the signal's RF frequency without any additional equipment (like a local oscillator). A typical linear DUT is, for example, an amplifier.

The test setup for measurements on such DUTs usually consists of the noise source, the DUT and an analyzer. If necessary, the measurement also considers loss that might occur somewhere in the measurement path.

If you are measuring linear DUTs, the contents and layout of the "Overview" dialog box represents the configuration of a typical test setup.


Measurements on Frequency Converting DUTs

Noise Figure Measurements (R&S FSW-K30) > Measurement Basics > DUT Types > Measurements on Frequency Converting DUTs
Measurements on Frequency Converting DUTs

A frequency converting DUT converts the RF frequency to an intermediate frequency (IF) using the local oscillator (LO). A frequency-converting DUT either converts the RF frequency to a lower IF (down-conversion) or a higher IF (up-conversion).

The conversion process requires a local oscillator in the test setup. You can generate the LO signal in two ways.

  • An external generator controlled by the analyzer via IEC bus.
  • A VCO controlled by a voltage source.

If you have selected a frequency-converting DUT measurement mode, the layout of the "Overview" dialog box adds the local oscillator to the test setup.

The local oscillator can have a fixed or a variable frequency. If the LO frequency is fixed, the intermediate frequency (IF) resulting from the conversion process is variable (depending on the input signal). If the LO frequency is variable, the IF has to be fixed. The application provides measurement for both measurement scenarios.

Fixed intermediate frequency

If you select one of the fixed IF measurement modes, the IF is the same for all entries in the frequency list. The LO frequency for each entry is variable and is the result of the equation the selected mode is based on.

  • fRF - fIF for up-converters
  • fRF + fIF for down-converters

The fixed IF measurement modes are, for example, useful for measurements on mixers.

Note that fixed IF measurements are only possible if the R&S FSW is equipped with option R&S FSW-B10. For more information see "External Generator Control".

Fixed LO frequency

If you select one of the fixed LO measurement modes, the LO frequency is the same for all entries in the frequency list. The IF frequency for each entry is variable and is the result of the equation the selected mode is based on.

  • fRF + fLO for up-converters
  • fRF - fLO for down-converters

The fixed LO measurement modes are, for example, required for measurements on satellite converters.


External Generator Control

Noise Figure Measurements (R&S FSW-K30) > Measurement Basics > External Generator Control
External Generator Control

To perform fixed IF measurements with the Noise Figure application, you have to install option R&S FSW-B10 (External Generator Control). This option allows you to control an external generator and the type of signal it generates.

The typical measurement setup for such measurements includes the R&S FSW with option R&S FSW-K30, a signal generator and the DUT. The signal generator is controlled either via the the LAN connection or the GPIB interface. The GPIB interface is part of the R&S FSW-B10.

To enhance the measurement accuracy, it is recommended to use a common reference frequency for both R&S FSW and signal generator in the measurement setup.

If you have no 10 MHz reference frequency on hand, you can use the internal reference signal of the R&S FSW or signal generator. For more information see the documentation of the R&S FSW or the signal generator.

Signal generator support

The R&S FSW-B10 supports various signal generators. A list is available in the user interface (see Generator Type) and in the documentation of the R&S FSW.

Note that you have to specifically select the generator for the R&S FSW-K30. It does not inherit the generator settings from other applications.

It is also possible to add new signal generators to that list. To do so, you have to copy a custom signal generator setup file with the file extension .gen to the R&S FSW. The setup file defines the frequency and power ranges supported by the generator, as well as information required for communication. You can use a setup file of the signal generators already supported as a template. After you copy it to the R&S FSW, the new generator model is added to the dropdown menu.

The existing setup files can be displayed in an editor in read-only mode directly from the Interface Configuration dialog box.

Make sure to adhere to the required syntax and commands and only change the values of the parameters. Errors are only detected and displayed when you try to use the custom generator.

Error and status messages

The following status and error messages may occur during external generator control.

Message | Description
"Ext. Generator GPIB Handshake Error!" / "Ext. Generator TCPIP Handshake Error!" / "Ext. Generator TTL Handshake Error!" | Connection to the generator is not possible, e.g. due to a cable damage or loose connection or wrong address.
"Ext. Generator Limits Exceeded!" | The allowed frequency or power ranges for the generator were exceeded.
"Reverse Sweep via min. Ext. Generator Frequency!" | Reverse sweep is performed; frequencies are reduced to the minimum frequency, then increased again.
"Ext. Generator File Syntax Error!" | Syntax error in the generator setup file.
"Ext. Generator Command Error!" | Missing or wrong command in the generator setup file.
"Ext. Generator Visa Error!!" | Error with Visa driver provided with installation (very unlikely).
Risk of damage to the instrument

For yielding highest sensitivity during the measurement, the R&S FSW-K30 automatically sets the input attenuation to 0 dB.

Because this configuration minimizes the overrange reserve, make sure that the signal you have applied does not cause to an overload condition (pay attention to the LO feedthough). An overload condition may damage or destroy the input mixer.

The R&S FSW shows a corresponding message in the status line if an overload occurs ("RF OVLD" or "IF OVLD").

To avoid an overload
  • reduce the LO feedthrough of the mixer device
    or
  • increase the reference level.


Image Frequency Rejection

Noise Figure Measurements (R&S FSW-K30) > Measurement Basics > Image Frequency Rejection
Image Frequency Rejection

Frequency converting DUTs convert a radio frequency (RF) to an intermediate frequency (IF). The IF is lower than the RF in case of down-converting DUTs and higher than the RF in case of up-converting DUTs.

In a basic test setup, the image frequency of the RF signal is also converted to the IF. Depending on the DUT, this effect may be wanted or even necessary, or not. To avoid measurement errors of the noise figure and gain of up to 3 dB, make sure to use the appropriate measurement configuration.

Basically, you can distinguish between single sideband (SSB) mixers and double sideband (DSB) mixers or those that partly suppress a sideband. If a sideband is not needed or only partly needed, you can reject the image frequency. If you do so, the application activates a filter that suppresses the image frequency to a certain extent.

The following illustrations help you to configure the measurement in order to measure correctly.

For more information on how to configure image rejection see "Image Rejection".

Double sideband measurements

Double sideband mixers use both sidebands to the same extent. Both RF and image frequency should be converted. In that case, you have to turn image rejection off.

fLO = frequency of the local oscillator
fIF = intermediate frequency = fRF ± fLO
fRF = lower sideband = fLO - fIF
fimage = upper sideband = fLO + fIF

If image rejection is on, the results have a 3 dB error - noise figure results are 3 dB lower than they should be, gain results are 3 dB higher than in reality.

Single sideband measurements

Single sideband mixers use a single sideband only. In that case, you have to suppress the sideband that is not required. If you do so, the measurement is pretty straightforward and works like a measurement on an amplifier.

To suppress a sideband completely, it is best to set the image rejection to the maximum amount possible (999.99 dB).

Partial sideband suppression

For measurements on mixers with a low image frequency rejection, there are two test scenarios.

  • Mixers whose image rejection is known.
  • Mixers whose image rejection is unknown.

In case of mixers whose image rejection is known, define the magnitude of image rejection in dB as accurate as possible. Else, measurement results (noise figure and gain) will deviate between 0 dB to 3 dB.

For accurate measurements on mixers whose image rejection characteristics are unkown a custom test setup including an additional filter is required. You also have to know the gain characteristics of the DUT.

(1) = Test setup for calibration
(2) = Test setup for noise measurement

In the test setup shown above, a lowpass filter prevents unwanted noise from being fed in at the image frequency.

Depending on the position of the frequency bands, a highpass or bandpass filter may also be necessary for the RF frequency instead of the lowpass filter. The important point is that unwanted noise is not converted by a further receive path of the mixer. The unwanted noise at the receive frequency must not be reduced. The insertion loss must be considered, if applicable.

With this test setup, the measurement on a mixer without sideband suppression is the same as SSB measurements.

To take the characteristics of the filter into account, include the insertion loss of the filter at the RF. To consider the actual filter suppression at the image frequency, include the actual attenuation for the image rejection.

Harmonics mixer measurement

For a harmonics mixer, the input signals are not only converted to the IF by the wanted harmonic, but also by the harmonic of the LO signal produced in the mixer. In many cases, the mixer even features a lower conversion loss in the case of unwanted harmonics. For measurements on this type of mixer, you have to use a bandpass filter to make sure that that there is only noise at the desired input frequency at the input of the DUT. This measurement is similar to measurements on a mixer with an average sideband suppression.


Calibration (2nd Stage Correction)

Noise Figure Measurements (R&S FSW-K30) > Measurement Basics > Calibration (2nd Stage Correction)
Calibration (2nd Stage Correction)

The calibration procedure of the application measures the inherent noise of the R&S FSW you are using. Performing calibration therefore is recommended as it increases the accuracy of measurement results. The results get more accurate because the application takes the inherent noise of the analyzer into account while it calculates the results.

Calibration for noise figure measurements is also known as 2nd stage correction. This term is used because in a typical noise figure test setup, the DUT represents the first stage and the analyzer the second stage in the test setup.

The 2nd stage correction is a calibration that is specific to noise figure measurements. It is independent of the overall calibration state of the analyzer and does not calibrate the analyzer.

For successful calibration, you need additional equipment.
  • Noise source
    The noise source is like a calibration standard. It provides a reference with known noise characteristics that allows the application to determine the inherent noise of the analyzer you are using.

During the calibration, the application measures the inherent noise characteristics of the analyzer at the set of measurement frequencies.

Thus, the 2nd stage correction is valid for a particular instrument configuration, the room temperature and the instrument temperature. As long as this configuration stays the same, calibration data remains valid.

Calibrating single frequency measurements

Like all other measurements of the Noise Figure application, single frequency measurements should be performed in a calibrated state for increased accuracy.

Note that there is an easy way to calibrate single frequency measurements, if you have calibrated the application for swept or list measurements and the single frequency is part of the frequency list. In that case the measurement is already calibrated for that frequency and no more steps are necessary. The application recalls the last calibration values when you switch back to sweep mode or frequency table mode.

Only if you use a single frequency that is not part of the frequency list (or use a completely different frequency outside the calibrated range) will calibration become invalid and you should calibrate this frequency point.

  • Interpolation
    If you change the frequency and the frequency span stays the same or gets smaller, the application interpolates the correction data for the new measurement points instead of requesting a new calibration.
    Measurements based on interpolated data might result in an increased measurement uncertainty. Highly accurate measurements that are conform to the values specified in the data sheet are only possible at calibrated measurement points.
    Note that useful interpolation is possible only if essential calibration parameters (e.g. impedance or attenuation) change only slightly. This is the case if the distance between the original calibration points has been sufficiently small.
    If the span increases compared to the span during calibration, a new calibration is necessary.
    If the application interpolates the caibration data, it shows a corresponding label in the channel bar and a warning message in the status bar.
  • Invalid calibration
    If you change one of the amplitude parameters (e.g. the attenuation), calibration is labeled invalid. In that case, calibration is not accurate, because the settings are not in line with the settings at the time the R&S FSW has been calibrated. If calibration is invalid, repeat the calibration or restore the settings as they were during the calibration.
Saving calibration data

If you save the current configuration or measurement results to a data set, calibration data is part of that data set.

For more information on saving and restoring data sets see chapter "Storing and Recalling Instrument Settings and Measurement Data" in the user manual of the R&S FSW.

The picture below shows a typical calibration setup that includes a noise source.

Noise figure calibration setup

  1. Connect the noise source directly and without a cable to the RF input of the analyzer.

  2. Connect the noise source to the +28 V voltage supply (Noise Source interface) on the back of the R&S FSW.

    To connect the noise source to the voltage supply, you need a coaxial cable.

After you have set up calibration, there are several ways to start calibration.

  • In the "Noise Overview" dialog box, press the "Calibrate" button.
  • In the "Sweep" menu, press the "Calibrate" softkey.


Separating Signals by Selecting an Appropriate Resolution Bandwidth

Noise Figure Measurements (R&S FSW-K30) > Measurement Basics > Separating Signals by Selecting an Appropriate Resolution Bandwidth
Separating Signals by Selecting an Appropriate Resolution Bandwidth

The resolution bandwidth defines the 3 dB bandwidth of the resolution filter to be used. An RF sinusoidal signal is displayed according to the passband characteristic of the resolution filter (RBW), i.e. the signal display reflects the shape of the filter.

The highest sensitivity is obtained at the smallest bandwidth (1 Hz). If the bandwidth is increased, the reduction in sensitivity is proportional to the change in bandwidth. Increasing the bandwidth by a factor of 3 increases the displayed noise by approx. 5 dB (4.77 dB precisely). If the bandwidth is increased by a factor of 10, the displayed noise increases by a factor of 10, i.e. 10 dB.

The higher spectral resolution with smaller bandwidths is won by longer sweep times for the same span. The sweep time has to allow the resolution filters to settle during a sweep at all signal levels and frequencies to be displayed.

If the RBW is too large, signal parts that are very far away (e.g. from a different signal) are considered in the measurement and distort the results. The displayed noise increases.

If the RBW is too small, the measurement time increases.


Analyzing Several Traces - Trace Mode

Noise Figure Measurements (R&S FSW-K30) > Measurement Basics > Analyzing Several Traces - Trace Mode
Analyzing Several Traces - Trace Mode

The trace mode determines the way the data is processed and displayed. The application provides the following trace modes.

Overview of available trace modes
Trace Mode | Description
Blank | Hides the selected trace.
Clear Write | Overwrite mode: the trace is overwritten by each sweep. This is the default setting.
View | The current contents of the trace memory are frozen and displayed.

Each time the trace mode is changed, the selected trace memory is cleared.

The default trace mode for the first trace is Clear/Write. For trace 2-4, the deafult trace mode is Blank. If you require another mode, you have to set it manually.

As you can have up to four traces simultaneously, you can compare the results with different measurement configurations, e.g. if you freeze a trace and use it as a memory trace.

If a trace is frozen ("View" mode), the instrument settings, apart from level range and reference level, can be changed without impact on the displayed trace. The fact that the displayed trace no longer matches the current instrument setting is indicated by the [image] icon on the tab label.

If you change the scaling of the y-axis, the R&S FSW automatically adapts the trace data to the changed display range. This allows an amplitude zoom to be made after the measurement in order to show details of the trace.


Using Markers

Noise Figure Measurements (R&S FSW-K30) > Measurement Basics > Using Markers
Using Markers

Markers are used to mark points on traces, to read out the results of a particular measurement point or compare results of different traces. The noise application provides four markers.

When you activate a marker, the application automatically positions it on the first measurement point (left border of the diagram) of trace 1, regardless of how many traces are active. A marker is always positioned on the same horizontal position in all active measurement windows. If you change the position of a marker in one window, the application adjusts the position of that marker in all other measurement windows. Thus, the marker results for a specific marker are always for the same frequency, which makes it easier to compare results.

Markers in single frequency mode

When you use a marker for single frequency measurements, the marker is positioned on a particular index value and not a particular measurement point. This means that during continuous measurements, the marker remains on the index value you have put it on and will not move down the line with the results.

To move a marker, you can use several methods.

  • Enter a particular measurement frequency in the input field that opens when you activate a marker.
  • Move the marker around with the rotary knob or the cursor keys.
  • Drag the marker around using the touchscreen.

All markers can be used either as normal markers or delta markers. A normal marker indicates the absolute signal value at the defined position in the diagram. A delta marker indicates the value of the marker relative to the specified reference marker (by default marker 1).

The application always positions the marker on the trace with the lowest number that is in Clear/Write trace mode. To set the marker on another trace, use the Marker to Trace function. With this function, you can also position a marker on a trace that is in View trace mode, e.g. to compare measurement results. Note that at least one active marker has to be a normal marker.

The application shows the results at the marker position directly in the diagram area (up to two markers) or in the marker table (if you use more than two markers).

Marker information in diagram area

By default, the results of the last two markers or delta markers that were activated are displayed in the diagram area.

The following information is displayed there:

  • The marker type (M for normal, D for delta, or special function name)
  • The marker number (1 to 4)
  • The assigned trace number in square brackets [ ]
  • The marker value on the y-axis
  • The marker position on the x-axis
Marker information in marker table

In addition to the marker information displayed within the diagram area, a separate marker table may be displayed in a separate window. For more information on the contents of the marker table see "Marker Table".


Configuration

Noise Figure Measurements (R&S FSW-K30) > Configuration
Configuration

Noise figure measurements require a special application on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Applications and Operating Modes" .

When you activate a measurement channel in the Noise application, a measurement for the input signal is started automatically with the default configuration. The "Noise Figure" menu is displayed and provides access to the most important configuration functions.

For a description see
  • "Configuring the Noise Source"
  • "Configuring Additional Loss"
  • "Configuring the Analyzer"
  • "Using the Uncertainty Calculator"
Automatic refresh of preview and visualization in dialog boxes after configuration changes

The R&S FSW supports you in finding the correct measurement settings quickly and easily - after each change in settings in dialog boxes, the preview and visualization areas are updated immediately and automatically to reflect the changes. Thus, you can see if the setting is appropriate or not before accepting the changes.

Unavailable hardkeys

Note that the AMPT, AUTO SET, BW, TRIG and MKR FUNC keys have no contents and no function in the Noise Figure application.

Contents
  • Configuration Overview
  • Default Settings for Noise Measurements
  • Defining the Measurement Frequency
  • Selecting DUT Characteristics
  • Configuring the Noise Source
  • Configuring Additional Loss
  • Configuring the Analyzer
  • Using the Uncertainty Calculator
  • Performing Measurements
  • Configuring Inputs and Outputs of the R&S FSW


Configuration Overview

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuration Overview
Configuration Overview

Throughout the measurement channel configuration, an overview of the most important currently defined settings is provided in the "Overview". The "Overview" is displayed when you select the "Overview" icon, which is available at the bottom of all softkey menus.

In addition to the main measurement settings, the "Overview" provides quick access to the main settings dialog boxes. The individual configuration steps are displayed in the order of the data flow. Thus, you can easily configure an entire measurement channel from input over processing to output and analysis by stepping through the dialog boxes as indicated in the "Overview".

In particular, the "Overview" provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

  1. Noise Source

    See "Configuring the Noise Source".

  2. Spectrum Analyzer

    See "Configuring the Analyzer".

  3. Input and Output Losses

    See "Configuring Additional Loss".

To configure settings
►

Select any button in the "Overview" to open the corresponding dialog box.

Select a setting in the channel bar (at the top of the measurement channel tab) to change a specific setting.

└ Preset Channel
└ Specifics for


Preset Channel

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuration Overview > Preset Channel
Preset Channel

Select the "Preset Channel" button in the lower lefthand corner of the "Overview" to restore all measurement settings in the current channel to their default values.

Note that the PRESET key on the front panel restores the entire instrument to its default values and thus closes all measurement channels on the R&S FSW (except for the default Spectrum application channel)!

For details see "Default Settings for Noise Measurements".

Remote command:

SYSTem:​PRESet:​CHANnel[:​EXECute]


Specifics for

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuration Overview > Specifics for
Specifics for

The measurement channel may contain several windows for different results. Thus, the settings indicated in the "Overview" and configured in the dialog boxes vary depending on the selected window.

Select an active window from the "Specifics for" selection list that is displayed in the "Overview" and in all window-specific configuration dialog boxes.

The "Overview" and dialog boxes are updated to indicate the settings for the selected window.


Default Settings for Noise Measurements

Noise Figure Measurements (R&S FSW-K30) > Configuration > Default Settings for Noise Measurements
Default Settings for Noise Measurements

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

Apart from these settings, the following default settings are activated directly after a measurement channel has been set to the Noise Figure application, or after a channel preset:

Default settings for phase noise measurement channels
Parameter | Value
Center frequency | fmax/2
Span | fmax
RBW | 1 MHz
Reference level | Auto
Attenuation | 0 dB
Sweep time | 30 ms
Averages | 1
ENR | Constant (15 dB)
2nd stage correction | On
Mode | Direct
Temperature | 20 °C
Loss (input & output) | Constant (0 dB)
Settling time | 50 ms
Preamplifier | On (30 dB)


Defining the Measurement Frequency

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency
Defining the Measurement Frequency

The "DUT" button or the "Frequency Settings" softkey open a dialog to configure the measurement frequencies.

Contents
  • Defining a Frequency Set
  • Configuring Single Frequency Measurements
  • Using a Frequency Table


Defining a Frequency Set

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency > Defining a Frequency Set
Defining a Frequency Set

The "Frequency Config" tab in the "Frequency Settings" dialog box contains settings that define the frequency characteristics for the measurement.

The information in this tab is also the basis for an automatic population of the frequency table. All parameters of this dialog are interdependent. If you change one parameter, at least one other parameter will be changed by the application.

In order to get accurate results, changing a frequency set may require a new calibration.

└ Tuning Mode
└ Center
└ Span
└ Start and Stop Frequency
└ (Measurement) Points
└ Step


Tuning Mode

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency > Defining a Frequency Set > Tuning Mode
Tuning Mode

Selects the tuning or measurement mode.

For more information see "Tuning Modes".

"Sweep" | The measurement is based on an automatically generated frequency set.
"Frequency Table" | The measurement is based on a customized frequency table. For more information see "Using a Frequency Table".
"Single Frequency" | The measurement measures a single frequency only. For more information see "Configuring Single Frequency Measurements".
Remote command:

Frequency list measurement:

CONFigure:​LIST:​CONTinuous

CONFigure:​LIST:​SINGLe

Single frequency measurement:

CONFigure:​FREQuency:​CONTinuous

CONFigure:​FREQuency:​SINGle


Center

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency > Defining a Frequency Set > Center
Center

Defines the center of the measurement frequency range.

If you change the center frequency, the application will change the start and stop frequency according to the span you have set.

Remote command:

Frequency list measurement:

[SENSe:​]FREQuency:​CENter

Single frequency measurement:

[SENSe:​]FREQuency:​SINGle


Span

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency > Defining a Frequency Set > Span
Span

Defines the measurement span.

If you change the span, the application will change the start frequency, the stop frequency and the stepsize according to the center frequency and the measurement points.

Remote command:

[SENSe:​]FREQuency:​SPAN


Start and Stop Frequency

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency > Defining a Frequency Set > Start and Stop Frequency
Start and Stop Frequency

Defines the start and stop frequencies.

If you change the start or stop frequency, the application will change the center frequency, the span and the measurement points according to the stop or start frequency and the stepsize.

Remote command:

Start frequency:

[SENSe:​]FREQuency:​STARt

Stopf frequency:

[SENSe:​]FREQuency:​STOP


(Measurement) Points

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency > Defining a Frequency Set > (Measurement) Points
(Measurement) Points

Defines the measurement points.

In case of frequency list measurements, the number of measurement points corresponds to the number of entries in the frequency table and therefore the number of measurements displayed in the graphical results.

If you change the measurement points, the application will change the stepsize according to the span.

Remote command:

[SENSe:​]SWEep:​POINts


Step

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency > Defining a Frequency Set > Step
Step

Defines the frequency step size in the frequency table.

The stepsize corresponds to the distance between two consecutive measurement points.

If you change the stepsize, the application will change the measurement point according to the span.

Remote command:

[SENSe:​]FREQuency:​STEP


Configuring Single Frequency Measurements

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency > Configuring Single Frequency Measurements
Configuring Single Frequency Measurements

The "Frequency Config" tab in the "Frequency Settings" dialog box contains settings that define the frequency characteristics for the measurement.

In order to get accurate results, changing the frequency may require a new calibration.

└ Single (Frequency)
└ Coupled to Sweep List
└ (Measurement) Points


Single (Frequency)

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency > Configuring Single Frequency Measurements > Single (Frequency)
Single (Frequency)

Defines the frequency that the single frequency measurement is performed on.

Remote command:

[SENSe:​]FREQuency:​SINGle


Coupled to Sweep List

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency > Configuring Single Frequency Measurements > Coupled to Sweep List
Coupled to Sweep List

Couples or decouples frequency selection to the contents of a sweep list.

If you couple the frequency to the sweep list, the application allows you to select only the frequencies currently part of the frequency list. If you enter another frequency, the application automatically selects the nearest frequency of the frequency list. If the frequency list has been calibrated previously, calibration remains valid for those frequencies when you change the tuning mode.

If you turn the coupling off, you can define any frequency for single frequency measurements. Note however, that it may become necessary to calibrate the measurement for that frequency.

Remote command:

[SENSe:​]FREQuency:​SINGle:​COUPling


(Measurement) Points

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency > Configuring Single Frequency Measurements > (Measurement) Points
(Measurement) Points

Defines the number of measurement points for single frequency measurements.

In case of single frequency measurements, the number of measurement points corresponds to the number of measurements (index values) performed on a single frequency.

For more information see "Single frequency measurements".

Remote command:

[SENSe:​]SWEep:​POINts


Using a Frequency Table

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency > Using a Frequency Table
Using a Frequency Table

The "Frequency Table" tab in the "Frequency Settings" dialog box contains functionality to manage the measurement frequencies.

The application populates the table according to the information you have entered in the "Frequency Config" tab if you press the "Populate Table" button.

Note that changes to the frequency table take effect only if you have selected the "Frequency Table" tuning mode.

└ Frequency Table
└ Clear Table
└ Populate Table
└ Insert
└ Delete
└ Import / Export


Frequency Table

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency > Using a Frequency Table > Frequency Table
Frequency Table

Shows the current measurement points.

The table is made up of one column that represents the measurement frequency. Each frequency corresponds to one measurement point. The length of the table is variable.

When you perform measurements in "Sweep" or "Single Frequency" tuning mode, the contents of the table have no effect on the measurement.

When you select a table entry in "Frequency Table" tuning mode, you can edit it or add a new frequency below the selected frequency. A new frequency has to be greater than the last table entry and smaller than the next table entry.


Clear Table

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency > Using a Frequency Table > Clear Table
Clear Table

Deletes the contents of the table.


Populate Table

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency > Using a Frequency Table > Populate Table
Populate Table

Populates or restores the measurement frequencies based on the center frequency, the start and stop frequencies, the span, the stepsize and the number of measurement points.

Remote command:

[SENSe:​]FREQuency:​LIST:​DATA


Insert

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency > Using a Frequency Table > Insert
Insert

Inserts a new measurement point above the one you have selected.


Delete

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency > Using a Frequency Table > Delete
Delete

Deletes the currently selected measurement point.


Import / Export

Noise Figure Measurements (R&S FSW-K30) > Configuration > Defining the Measurement Frequency > Using a Frequency Table > Import / Export
Import / Export

Opens a dialog box to select an ENR table to import or export.

An import copies the ENR table into the default ENR table directory. An export copies the table to a location outside the default ENR table directory, e.g. a memory stick. The file extension has to be *.freq.


Selecting DUT Characteristics

Noise Figure Measurements (R&S FSW-K30) > Configuration > Selecting DUT Characteristics
Selecting DUT Characteristics

The "DUT" button opens a dialog box to configure the characteristics of the DUT you are testing. The dialog box contains a schematic overview of the DUT input and output characteristics and the way it is integrated into the test setup.

└ Mode
└ LO Fixed
└ IF Fixed
└ Image Rejection


Mode

Noise Figure Measurements (R&S FSW-K30) > Configuration > Selecting DUT Characteristics > Mode
Mode

Selects the measurement mode.

The measurement mode you should use depends on the type of DUT you are testing. For more information see "DUT Types".

Remote command:

[SENSe:​]CONFigure:​MODE:​DUT


LO Fixed

Noise Figure Measurements (R&S FSW-K30) > Configuration > Selecting DUT Characteristics > LO Fixed
LO Fixed

Defines a fixed LO frequency for measurements on frequency-converting DUTs with a fixed LO.

After you have defined the LO frequency, the application updates the frequency list accordingly.

Remote command:

[SENSe:​]CONFigure:​MODE:​SYSTem:​LO:​FREQuency


IF Fixed

Noise Figure Measurements (R&S FSW-K30) > Configuration > Selecting DUT Characteristics > IF Fixed
IF Fixed

Defines a fixed intermediary frequency (IF) for measurements on frequency-converting DUTs with a fixed IF.

After you have defined the intermediary frequency, the application updates the frequency list accordingly.

Remote command:

[SENSe:​]CONFigure:​MODE:​SYSTem:​IF:​FREQuency


Image Rejection

Noise Figure Measurements (R&S FSW-K30) > Configuration > Selecting DUT Characteristics > Image Rejection
Image Rejection

Turns image rejection of the DUT on and off.

If you set an image rejection of 0 dB, the image frequency passes completely. If you set a high image rejection (up to 999.99 dB), the image frequency is suppressed completely. For DUTs that have a partial image rejection, define the amount of suppression.

For more information see "Image Frequency Rejection".

Remote command:

[SENSe:​]CORRection:​IREJection


Configuring the Noise Source

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Noise Source
Configuring the Noise Source

The "Noise Source" button or the "ENR Settings" softkey open a dialog to configure the characteristics of the noise source.

It is necessary to specify characteristics of the noise source you are using as close as possible in order to get accurate measurement results. The noise source characteristics are used to calculate the effective noise temperature of the noise source. The noise source characteristics should be supplied by its manufacturer.

Contents
  • Defining the Excess Noise Ratio (ENR)
  • Using an ENR Table


Defining the Excess Noise Ratio (ENR)

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Noise Source > Defining the Excess Noise Ratio (ENR)
Defining the Excess Noise Ratio (ENR)

The "ENR Settings" tab in the "ENR Settings" dialog box contains settings to characterize the noise source.

The noise source may have different ENR values during the calibration and the measurement stage.

└ Measurement
└ Common ENR
└ Calibration
└ Temperature


Measurement

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Noise Source > Defining the Excess Noise Ratio (ENR) > Measurement
Measurement

Selects the source of the ENR values.

The ENR may be approximated by a constant or be based on a ENR table.

If the ENR is a constant, the same ENR is used for all frequencies in the frequency table. If you have selected a constant ENR, you have to define its magnitude in the input field next to the radio button.

If the ENR is based on a table, the ENR level typically depends on the measurement frequency. You can select an existing table from the dropdown menu next to the radio button, if it is active. For more information on ENR tables see "Using an ENR Table".

If the "Common ENR" is on, the ENR is used for both measurement and calibration.

Remote command:

ENR mode:

[SENSe:​]CORRection:​ENR[:​MEASurement]:​MODE

Constant ENR:

[SENSe:​]CORRection:​ENR[:​MEASurement]:​SPOT

Select ENR table:

[SENSe:​]CORRection:​ENR[:​MEASurement]:​TABLe:​SELect


Common ENR

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Noise Source > Defining the Excess Noise Ratio (ENR) > Common ENR
Common ENR

Turns the use of a common ENR on and off.

Common ENRs have the same characteristics for the measurement and calibration. If you turn common ENR off, you can define an additional ENR to be used during calibration.

This is recommended in case of measurements on frequency converting DUTs, if one noise source does not cover the frequency range at the DUT input (RF) and the frequency range for calibration (IF).

Remote command:

[SENSe:​]CORRection:​ENR:​COMMon


Calibration

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Noise Source > Defining the Excess Noise Ratio (ENR) > Calibration
Calibration

Selects the source of the ENR values used during calibration.

The ENR may be a constant or be based on a ENR table.

If the ENR is a constant, the same ENR value is used for all frequencies in the frequency table. If you have selected a constant ENR, you can also define its value in the input field next to the radio button.

If the ENR is based on a table, the ENR level depends on the measurement frequency. In that case, ENR values are interpolated to the measurement points. You can select a table from the dropdown menu next to the radio button, if it is active. For more information on ENR tables see "Using an ENR Table".

The calibration settings are available if the "Common ENR" is off.


Temperature

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Noise Source > Defining the Excess Noise Ratio (ENR) > Temperature
Temperature

Defines the absolute room temperature in degree Celsius or Fahrenheit.

The room temperature is required for the calculation of the real ENR of the noise source, because an ENR table is based on a temperature of 290K.

To change the unit of the temperature from Celsius to Fahrenheit, change the date format from "DE" to "US" in the "General" display settings.

  • Press the SETUP key.
  • Press the "Display" softkey.
  • Select the "General" tab.
  • Select "DE" for Celsius or "US" for Fahrenheit.

Note: If you define the temperature via remote control, the unit is degree Kelvin.

Remote command:

[SENSe:​]CORRection:​TEMPerature


Using an ENR Table

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Noise Source > Using an ENR Table
Using an ENR Table

The "Table Settings" tab in the "ENR Settings" dialog box contains the functionality to create and edit ENR tables.

ENR tables contain the noise source characteristics for particular frequencies. If the table does not contain an ENR for one of the measurement frequencies, the application will interpolate between ENR values.

The "Table Settings" tab contains a list of ENR tables currently available on the R&S FSW and shows the table currently in use if the "ENR Settings" are enabled.

In addition, the tab contains functionality to create new tables and modify existing ones.

└ New
└ Edit
└ Copy To
└ Delete
└ Import / Export Table
└ Edit Table


New

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Noise Source > Using an ENR Table > New
New

Opens the "Edit Table" dialog box to create a new ENR table.

The contents of the dialog box are empty.

Remote command:

[SENSe:​]CORRection:​ENR[:​MEASurement]:​TABLe:​DATA


Edit

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Noise Source > Using an ENR Table > Edit
Edit

Opens the "Edit Table" dialog box to modify the selected table.

Remote command:

[SENSe:​]CORRection:​ENR[:​MEASurement]:​TABLe:​DATA


Copy To

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Noise Source > Using an ENR Table > Copy To
Copy To

Opens the "Edit Table" dialog box to modify the selected table and save it under a new name.


Delete

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Noise Source > Using an ENR Table > Delete
Delete

Deletes the selected table.

Remote command:

[SENSe:​]CORRection:​ENR[:​MEASurement]:​TABLe:​DELete


Import / Export Table

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Noise Source > Using an ENR Table > Import / Export Table
Import / Export Table

Opens a dialog box to select an ENR table to import or export.

An import copies the ENR table into the default ENR table directory. An export copies the table to a location outside the default ENR table directory, e.g. a memory stick. The file extension has to be *.enr.


Edit Table

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Noise Source > Using an ENR Table > Edit Table
Edit Table

Defines the ENR characteristics of a irregular noise source or the loss characteristics of additional measurement equipment.

The ENR and loss tables are made up of up to 500 data points. A data point consists of a frequency and its corresponding ENR or loss value. The ENR values should be supplied by the manufacturer of the noise source. The loss characterictics of measurement equipment should also be supplied by the manufacturer.

"Name" | Name of the ENR or loss table.
"Comment" | Comment for the ENR or loss table.
"Frequency" | Frequency of a particular ENR or loss value.
"Value" | ENR value or loss in dB.
"Clear Table" | Deletes the contents of the ENR table (frequencies and ENR values) or the loss table.
"Insert" | Inserts a new data point above the selected one.
"Delete" | Deletes the selected data point.
"Save" | Saves the ENR or loss table.
"Cancel" | Exits the "Edit Table" dialog box and returns to the result diagram.
Remote command:

Edit ENR table:

[SENSe:​]CORRection:​ENR[:​MEASurement]:​TABLe:​DATA

Edit input loss table:

[SENSe:​]CORRection:​LOSS:​INPut:​TABLe

Edit output loss table:

[SENSe:​]CORRection:​LOSS:​OUTPut:​TABLe


Configuring Additional Loss

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Additional Loss
Configuring Additional Loss

The "Loss Input"/"Loss Output" buttons or the "Loss Settings" softkey open a dialog to configure the loss characteristics of additional equipment in the test setup like cables or attenuators at the DUT input or output. The characteristics of these should be supplied by the manufacturer.

Note that loss is only taken into account during the measurement and not during calibration because the noise source is connected directly to the analyzer input.

Contents
  • Defining Loss
  • Using a Loss Table


Defining Loss

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Additional Loss > Defining Loss
Defining Loss

The "Loss Settings" tab in the "Loss Settings" dialog box contains settings to define the loss characteristics of miscellaneous equipment in the test setup.

You can define the loss characteristics of the signal path to the DUT input and the signal path from the DUT output to the analyzer.

└ Input Loss
└ Output Loss


Input Loss

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Additional Loss > Defining Loss > Input Loss
Input Loss

Selects the source of losses between the noise source and the DUT input.

The input loss is the sum of all losses caused by the measurement equipment. The loss may be constant or be based on a loss table.

If the loss is constant, the same loss is used for all frequencies in the frequency table. If you have selected a constant loss, you can also define its value in the input field next to the radio button.

If the loss is based on a table, the loss values are interpolated to the measurement frequencies. You can select a table from the dropdown menu next to the radio button, if it is active. For more information on loss tables see "Using a Loss Table".

Remote command:

Loss mode:

[SENSe:​]CORRection:​LOSS:​INPut:​MODE

Constant loss:

[SENSe:​]CORRection:​LOSS:​INPut:​SPOT

Select loss table:

[SENSe:​]CORRection:​LOSS:​INPut:​TABLe:​SELect


Output Loss

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Additional Loss > Defining Loss > Output Loss
Output Loss

Selects the source of loss between the DUT output and the RF input of the analyzer.

The output loss is the sum of all losses caused by the measurement equipment (e.g. connectors, cables or attenuators). The loss may be constant or be based on a loss table.

If the loss is constant, the same loss is used for all frequencies in the frequency table. If you have selected a constant loss, you can also define its value in the input field next to the radio button.

If the loss is based on a table, the loss values are interpolated to the measurement frequencies. You can select a table from the dropdown menu next to the radio button, if it is active. For more information on loss tables see "Using a Loss Table".

Remote command:

Loss mode:

[SENSe:​]CORRection:​LOSS:​OUTPut:​MODE

Constant loss:

[SENSe:​]CORRection:​LOSS:​OUTPut:​SPOT

Select loss table:

[SENSe:​]CORRection:​LOSS:​OUTPut:​TABLe:​SELect


Using a Loss Table

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Additional Loss > Using a Loss Table
Using a Loss Table

The "Table Settings" tab in the "Loss Settings" dialog box contains the functionality to create and edit loss tables.

Loss table contain the loss characteristics of additional frequency dependent equipment in the test setup. If you are using a loss table, the loss values may be different on each frequency that is measured. If the table does not contain a loss for one of the measurement frequencies, the application will interpolate between values.

The "Table Settings" tab contains a list of loss tables currently available on the R&S FSW and shows the tables you are currently using if you have selected one in the "Loss Settings" tab.

In addition, the tab contains functionality to create new tables and modify existing ones.

└ New
└ Edit
└ Copy To
└ Delete
└ Import / Export Table


New

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Additional Loss > Using a Loss Table > New
New

Opens the "Edit Table" dialog box to create a new loss table.

The contents of the dialog box are empty.

Remote command:

Create input loss table:

[SENSe:​]CORRection:​LOSS:​INPut:​TABLe

Create output loss table:

[SENSe:​]CORRection:​LOSS:​OUTPut:​TABLe


Edit

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Additional Loss > Using a Loss Table > Edit
Edit

Opens the "Edit Table" dialog box to modify the selected table.

Remote command:

Edit input loss table:

[SENSe:​]CORRection:​LOSS:​INPut:​TABLe

Edit output loss table:

[SENSe:​]CORRection:​LOSS:​OUTPut:​TABLe


Copy To

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Additional Loss > Using a Loss Table > Copy To
Copy To

Opens the "Edit Table" dialog box to modify the selected table and save it under a new name.


Delete

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Additional Loss > Using a Loss Table > Delete
Delete

Deletes the selected table.

Remote command:

Delete input loss table:

[SENSe:​]CORRection:​LOSS:​INPut:​TABLe:​DELete

Delete output loss table:

[SENSe:​]CORRection:​LOSS:​OUTPut:​TABLe:​DELete


Import / Export Table

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Additional Loss > Using a Loss Table > Import / Export Table
Import / Export Table

Opens a dialog box to select a loss table to import or export.

An import copies the loss table into the default loss table directory. An export copies the table to a location outside the default loss table directory, e.g. a memory stick. The file extension has to be *.loss.


Configuring the Analyzer

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Analyzer
Configuring the Analyzer

The "Spectrum Analyzer" button or the "Meas Settings" softkey open the "Measurement Settings" dialog box to set up general measurement characteristics.

Contents
  • Configuring the Measurement
  • Configuring Level Characteristics


Configuring the Measurement

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Analyzer > Configuring the Measurement
Configuring the Measurement

The measurement settings include parameters directly related to the measurement itself.

└ 2nd Stage Correction
└ Resolution Bandwidth (RBW)
└ Sweep Time
└ Settling Time
└ Average


2nd Stage Correction

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Analyzer > Configuring the Measurement > 2nd Stage Correction
2nd Stage Correction

Turns 2nd stage correction on and off.

If 2nd stage correction is on, the application excludes the inherent noise of the analyzer from the measurement results.

If 2nd stage correction is off, the application does not correct the measurement results, even if a valid calibration has been performed. Note that correction data does not get lost if you turn off the 2nd stage correction.

For more information see "Calibration (2nd Stage Correction)".

Remote command:

CONFigure:​CORRection


Resolution Bandwidth (RBW)

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Analyzer > Configuring the Measurement > Resolution Bandwidth (RBW)
Resolution Bandwidth (RBW)

Defines the resolution bandwidth for the measurement.

For more information on the resolution bandwidth see "Separating Signals by Selecting an Appropriate Resolution Bandwidth".

Remote command:

[SENSe:​]BANDwidth|BWIDth[:​RESolution]


Sweep Time

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Analyzer > Configuring the Measurement > Sweep Time
Sweep Time

Defines the sweep time for the measurement.

The sweep time is the time it takes the analyzer to perform a measurement at one measurement frequency.

Note that noise measurements perform two measurements during one sweep. One with the noise source turned on, one with the noise source turned off.

Remote command:

[SENSe:​]SWEep:​TIME


Settling Time

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Analyzer > Configuring the Measurement > Settling Time
Settling Time

Defines the settling time of the DUT and the noise source.

Most noise sources need a certain amount of time to settle after you turn them on. Low-frequency DUTs may require a certain time until its coupling capacitators have been charged or discharged. Both are defined as the settling time. For details on the settling time refer to the datasheet of the noise source.

Remote command:

SYSTem:​CONFigure:​DUT:​STIMe


Average

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Analyzer > Configuring the Measurement > Average
Average

Defines the number of measurements that are used to average the results.

The more measurements you include in the averaging, the more accurate and stable the results will be. However, accuracy and stability comes at the price of measurement speed.

Remote command:

[SENSe:​]SWEep:​COUNt


Configuring Level Characteristics

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Analyzer > Configuring Level Characteristics
Configuring Level Characteristics

The level and range settings configure all parameters related to the vertical diagram axis.

└ Ref Level
└ Auto Level Range
└ RF Attenuation
└ Preamplifier


Ref Level

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Analyzer > Configuring Level Characteristics > Ref Level
Ref Level

Turns automatic determination of the reference level on and off.

The reference level is the power level the R&S FSW expects at the RF input. Keep in mind that the noise signal has a high crest factor. Thus, the reference level has to be set at the peak envelope power of the noise signal, not the mean power in order to avoid an instrument overload.

The reference level should be about 5 to 15 dB above the noise display that occurs with the DUT connected and the noise source activated.

To get the best dynamic range, you have to set the reference level as low as possible. At the same time, make sure that the maximum signal level does not exceed the reference level. If it does, it may overload the RF and IF stages of the analyzer, regardless of the signal power. Measurement results may deteriorate.

Note that the signal level at the A/D converter may be stronger than the level the R&S FSW displays, depending on the current resolution bandwidth. This is because the resolution bandwidths are implemented digitally after the A/D converter.

If automatic detection of the reference level is on, the application performs a measurement to determine the ideal reference level. The time of this measurement depends on the state of the "2nd Stage Correction".

  • 2nd Stage Correction is on
    The application determines the reference level before the calibration starts. The reference level is based on several test measurements on the start frequency.
    For more information see "Auto Level Range".
  • 2nd Stage Correction is off
    The application determines the reference level before the measurement begins. The reference level is based on the measurement of the first frequency that is measured. After this measurement is done, the application resumes the measurement.

If manual selection of the reference level is on, you can define the reference level in the corresponding input field.

Note: Reference level. Even for DUTs with a high-ripple frequency response it might be useful to enter the reference level manually, because determining the reference level automatically might not always result in optimal settings.

Remote command:

Manual reference level:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel

Automatic reference level:

DISPlay[:​WINDow<n>]:​TRACe<t>:​Y[:​SCALe]:​RLEVel:​AUTO


Auto Level Range

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Analyzer > Configuring Level Characteristics > Auto Level Range
Auto Level Range

Defines the maximum expected gain of the DUT.

The application uses the auto level range to determine the reference level automatically if the 2nd stage correction is on.

Note that the range should not exceed the actual gain of the DUT by more than 10 dB.

Remote command:

SYSTem:​CONFigure:​DUT:​GAIN


RF Attenuation

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Analyzer > Configuring Level Characteristics > RF Attenuation
RF Attenuation

Defines the RF attenuation of the analyzer.

The attenuation is applied to the signal at the RF input.

Attenuation affects the quality of the noise measurement results. For a low noise figure of the analyzer (and thus more accurate measurement results), you should keep the attenuation as low as possible. No attenuation is best. However, some high power DUTs require attenuation to avoid an overload of the analyzer. An attenuation of 10 dB will give better input VSWR of the analyzer, but will result in a deteriorating noise figure.

Remote command:

INPut:​ATTenuation


Preamplifier

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring the Analyzer > Configuring Level Characteristics > Preamplifier
Preamplifier

Turns the preamplifier on and off.

The preamplifier should be turned on for a low inherent noise of the analyzer.

The preamplification level is 30 dB for R&S FSW model .26.

For R&S FSW models .08 or .13, preamplification levels of 15 dB or 30 dB are available.

Remote command:

INPut:​GAIN:​STATe


Using the Uncertainty Calculator

Noise Figure Measurements (R&S FSW-K30) > Configuration > Using the Uncertainty Calculator
Using the Uncertainty Calculator

Noise figure measurements are subject to uncertainty. This measurement uncertainty has to be considered when making a noise figure measurement. The noise figure measurement will be meaningless if the measurement uncertainty is too large. Knowing the uncertainty of the noise figure measurement adds value especially when comparing measurement results.

Uncertainty values and systematic error recognition

Note that the uncertainty calculation only takes systematic measurement inaccuracies into account.

The most significant inaccuracies are:
  • uncertainties of the noise source and the analyzer
  • input and output matching
  • noise figure and gain of the DUT
  • noise figure of the analyzer

The accuracy of the measurement may be additionally affected by insufficient repeatability during calibration or measurement.

The repeatability is mainly affected by:
  • signal-to-noise ratio during calibration and measurement
  • measurement time (if it is too short)
  • environmental conditions (e.g. a change in the temperature between measurements)
  • mechanical stability of the test setup

For more background information on noise figure measurement uncertainty refer to the application note "The Y-Factor Technique for Noise Figure Measurement" available for download on the Rohde & Schwarz homepage (http://www2.rohde-schwarz.com/en/service_and_support/Downloads/Application_Notes?type=20&downid=7162).

In addition to the parameters described here, the application also considers several parameters from the general measurement configuration when calculating the uncertainty.
  • Measurement mode
  • "2nd Stage Correction"
    If 2nd stage correction is on, but no calibration data is available, uncertainty is calculated without the 2nd stage correction data.
  • Internal preamplification
  • "RF Attenuation"
  • "Temperature"
  • ENR values
Contents
  • Configuring Noise Source Characteristics
  • Configuring DUT Characteristics
  • Configuring Analyzer Characteristics
  • Guidelines and Results


Configuring Noise Source Characteristics

Noise Figure Measurements (R&S FSW-K30) > Configuration > Using the Uncertainty Calculator > Configuring Noise Source Characteristics
Configuring Noise Source Characteristics

The Uncertainty Calculator supports individual characteristics for a noise source used during calibration and the measurement.

If you are using a Common ENR, the application assumes that the Output Match and ENR Uncert(ainty) are the same during calibration and measurement. Only the "Measurement Noise Source" parameters are displayed.

If you are using a different noise source during calibration and measurement, the Uncertainty Calculator adds an additional Output Match and ENR Uncert(ainty) required for uncertainty calculation during calibration.

Note that you have to turn off the Common ENR if you have to define the values of the noise source used during calibration.

└ Common Source for Meas and Cal
└ Output Match
└ ENR Uncert(ainty)


Common Source for Meas and Cal

Noise Figure Measurements (R&S FSW-K30) > Configuration > Using the Uncertainty Calculator > Configuring Noise Source Characteristics > Common Source for Meas and Cal
Common Source for Meas and Cal

Controls the way the application calculates the uncertainty for the noise source.

Turn on the switch when you use the same noise source during calibration and measurement. Only one set of fields to define the noise source characteristics is available. The application calculates the uncertainty according to the values you have entered in there.

Turn the switch off when you use different noise sources during calibration and measurement. The application shows an additional set of fields to define the noise source characteristics. The uncertainty calculation also includes these values.

The switch is available if you have turned on Common ENR.

Remote command:

CALCulate:​UNCertainty:​COMMon


Output Match

Noise Figure Measurements (R&S FSW-K30) > Configuration > Using the Uncertainty Calculator > Configuring Noise Source Characteristics > Output Match
Output Match

Defines the output match of the noise source you are using.

You can define the output match either as the VSWR or as the return loss (RL).

Refer to the datasheet of the noise source for these values.

Remote command:

CALCulate:​UNCertainty:​MATCh:​SOURce[:​VSWR]

CALCulate:​UNCertainty:​MATCh:​SOURce:​RL

CALCulate:​UNCertainty:​MATCh:​SOURce:​CALibration[:​VSWR]

CALCulate:​UNCertainty:​MATCh:​SOURce:​CALibration:​RL


ENR Uncert(ainty)

Noise Figure Measurements (R&S FSW-K30) > Configuration > Using the Uncertainty Calculator > Configuring Noise Source Characteristics > ENR Uncert(ainty)
ENR Uncert(ainty)

Defines the uncertainty of the excess noise ratio of the noise source you are using.

Refer to the datasheet of the noise source for this value.

Remote command:

CALCulate:​UNCertainty:​ENR:​UNCertainty

CALCulate:​UNCertainty:​ENR:​CALibration:​UNCertainty


Configuring DUT Characteristics

Noise Figure Measurements (R&S FSW-K30) > Configuration > Using the Uncertainty Calculator > Configuring DUT Characteristics
Configuring DUT Characteristics
└ Input / Output Match
└ Use Measurement Values


Input / Output Match

Noise Figure Measurements (R&S FSW-K30) > Configuration > Using the Uncertainty Calculator > Configuring DUT Characteristics > Input / Output Match
Input / Output Match

Defines the match at the DUT input and output.

You can define the match either as the VSWR or as the return loss (RL). If you define the VSWR or the return loss, the application automatically calculates the other.

If these values are not defined in the DUT datasheet, determine these values, for example, with a network analyzer.

Remote command:

CALCulate:​UNCertainty:​MATCh:​DUT:​IN:​[VSWR]

CALCulate:​UNCertainty:​MATCh:​DUT:​IN:​RL

CALCulate:​UNCertainty:​MATCh:​DUT:​OUT:​[VSWR]

CALCulate:​UNCertainty:​MATCh:​DUT:​OUT:​RL


Use Measurement Values

Noise Figure Measurements (R&S FSW-K30) > Configuration > Using the Uncertainty Calculator > Configuring DUT Characteristics > Use Measurement Values
Use Measurement Values

Turns automatic determination of the DUT characteristics used for the uncertainty calculation on and off.

If on, the application calculates the uncertainty with the DUT characteristics (noise figure, gain and frequency) resulting from the noise figure measurement. In case of this method, the application calculates the uncertainty for each measurement point (or frequency) based on the noise figure and gain results of the last measurement.

If you have selected automatic determination of the DUT characterictics, the application does not show a result in the "NF Uncertainty +/-" field in the dialog box. Instead, to view the uncertainty at all measurement points, use the "Result Table".

If off, define the gain, noise figure and frequency of the DUT manually for a single frequency. With this manual determination of the DUT characteristics, the application only calculates the uncertainty for that frequency and shows the result in the "NF Uncertainty +/-" field in the dialog box.

  • Noise Figure of the DUT
  • Gain of the DUT
  • Frequency of the DUT
Remote command:

Control automatic DUT characteristics determination:

CALCulate:​UNCertainty:​DATA:​RESults

Manual definition of DUT characteristics:

CALCulate:​UNCertainty:​DATA:​NOISe

CALCulate:​UNCertainty:​DATA:​GAIN

CALCulate:​UNCertainty:​DATA:​FREQuency


Configuring Analyzer Characteristics

Noise Figure Measurements (R&S FSW-K30) > Configuration > Using the Uncertainty Calculator > Configuring Analyzer Characteristics
Configuring Analyzer Characteristics

For the analyzer characteristics, the application always uses the data specified in the datasheet of the R&S FSW model you are using. Thus, it is not possible to change or adjust the analyzer characteristics in any way. The uncertainty calculation takes several analyzer characteristics into account. Of those, it shows the following as read only fields in the user interface.

  • Input match (VSWR and return loss)
  • Gain uncertainty
  • Noise figure uncertainty
  • Noise figure of the analyzer

However, if you are using an external preamplifier in the test setup, you have to specify its characteristics in order to get a valid uncertainty result. If you specify an external preamplifier, the application automatically calculates and updates the analyzer characteristics based on the characteristics of the preamplifier.

SCPI command:

CALCulate:​UNCertainty:​PREamp:​STATe

Refer to the datasheet of the preamplifier you are using for the values you have to enter.

If you are using a preamplifier, you have to define the following characteristics.

Preamplifier noise figure (PA NF)

Defines the noise figure of the preamplifier.

SCPI command:

CALCulate:​UNCertainty:​PREamp:​NOISe

Preamplifier Gain (PA Gain)

Defines the gain of the preamplifier.

SCPI command:

CALCulate:​UNCertainty:​PREamp:​GAIN

Net spectrum analyzer noise figure

Shows the noise figure of the analyzer.

If you are using an external preamplifier, the application calculates the noise figure of the analyzer including the noise figure of the preamplfier and shows the result here.

If you do not use an external preamplifier, this value is the same as the noise figure of the analyzer shown in the "SA NF" field.

SCPI commands:

CALCulate:​UNCertainty:​SANalyzer:​GAIN:​UNCertainty?

CALCulate:​UNCertainty:​SANalyzer:​NOISe:​UNCertainty?


Guidelines and Results

Noise Figure Measurements (R&S FSW-K30) > Configuration > Using the Uncertainty Calculator > Guidelines and Results
Guidelines and Results

The lower part of the dialog box contains measurement guidelines that provide information on the quality of measurement and the actual noise figure uncertainty.

Guidelines

The guidelines are an indicator of the quality of the measurement and an indicator the repeatability of the measurement.

The three guidelines are:

  • Make sure that the noise figure of the DUT and the gain of the DUT is greater than the noise figure of the analyzer plus 1 dB.
  • Make sure that the ENR of the noise source is greater than the noise figure of the DUT plus 5 dB.
  • Make sure that the ENR of the noise source is greater than the noise figure of the analyzer plus 3 dB.

A short form of these guidelines is indicated in the "Uncertainty Calculation" dialog box. The dialog box also indicates if the guidelines have been met or not by a colored dot.

  • Green light [image]: guideline condition met.
  • Yellow light [image]: guideline condition not met, but within 1 dB of being met.
  • Red light [image]: guideline condition not met.

Note that the guidelines have no effect on the actual uncertainty that has been calculated and that they are only considered for measurements with 2nd Stage Correction.

Uncertainty

The "Uncertainty" result is shown only if you define the noise figure and gain characteristics of the DUT manually on a single frequency. In that case, the uncertainty shown in the "Uncertainty Calculation" dialog box is valid only for the DUT frequency you have defined.

The "Measurement Offset" evaluates the internal noise of the R&S FSW that is added to the noise figure results. The measurement offset result is displayed when 2nd stage correction is turned off. When you turn on 2nd stage correction, the internal noise is automatically removed from the uncertainty results, so the measurement offset is not shown.

If you are using the noise figure and gain that has been determined during a measurement, the uncertainty is displayed only in the result table.

For more information see "Use Measurement Values".

SCPI command:

CALCulate:​UNCertainty[:​RESult]?


Performing Measurements

Noise Figure Measurements (R&S FSW-K30) > Configuration > Performing Measurements
Performing Measurements

This chapter contains all functionality necessary to control and perform noise figure measurements.

The contents of this chapter correspond to the contents of the "Sweep" menu. You can access the "Sweep" menu with the SWEEP key.

└ Continuous Sweep/RUN CONT
└ Single Sweep/ RUN SINGLE
└ Calibrate
└ Sweep Time


Continuous Sweep/RUN CONT

Noise Figure Measurements (R&S FSW-K30) > Configuration > Performing Measurements > Continuous Sweep/RUN CONT
Continuous Sweep/RUN CONT

Initiates a measurement and repeats it continuously until stopped. If necessary, the application automatically determines the reference level before starting the actual measurement.

While the measurement is running, the "Continuous Sweep" softkey and the RUN CONT key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again. The results are not deleted until a new measurement is started.

Note: Sequencer. Furthermore, the RUN CONT key controls the Sequencer, not individual sweeps. RUN CONT starts the Sequencer in continuous mode.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate:​CONTinuous


Single Sweep/ RUN SINGLE

Noise Figure Measurements (R&S FSW-K30) > Configuration > Performing Measurements > Single Sweep/ RUN SINGLE
Single Sweep/ RUN SINGLE

Initiates a single measurement. The measurement is finished after all frequencies in the frequency list have been measured. If necessary, the application automatically determines the reference level before starting the actual measurement.

While the measurement is running, the "Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Note: Sequencer. Furthermore, the RUN SINGLE key controls the Sequencer, not individual sweeps. RUN SINGLE starts the Sequencer in single mode.
If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate[:​IMMediate]


Calibrate

Noise Figure Measurements (R&S FSW-K30) > Configuration > Performing Measurements > Calibrate
Calibrate

Initiates a calibration measurement.

For more information see "Calibration (2nd Stage Correction)".

Remote command:

INITiate[:​IMMediate]

when CONFigure:​CORRection is on.


Sweep Time

Noise Figure Measurements (R&S FSW-K30) > Configuration > Performing Measurements > Sweep Time
Sweep Time

Defines the sweep time.

For more information see "Sweep Time".


Configuring Inputs and Outputs of the R&S FSW

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW
Configuring Inputs and Outputs of the R&S FSW

The application supports several input sources and outputs. These are the same as in Spectrum mode.

For a comprehensive description of the supported input sources (including the Digital Baseband In- and Output), please refer to the documentation of the R&S FSW.

Contents
  • Radio Frequency (RF) Input
  • External Mixer Settings
  • External Generator


Radio Frequency (RF) Input

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > Radio Frequency (RF) Input
Radio Frequency (RF) Input

The RF input is the default input of the R&S FSW.

└ Input Coupling
└ Impedance
└ High-Pass Filter 1...3 GHz
└ YIG-Preselector


Input Coupling

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > Radio Frequency (RF) Input > Input Coupling
Input Coupling

The RF input of the R&S FSW can be coupled by alternating current (AC) or direct current (DC).

AC coupling blocks any DC voltage from the input signal. This is the default setting to prevent damage to the instrument. Very low frequencies in the input signal may be distorted.

However, some specifications require DC coupling. In this case, you must protect the instrument from damaging DC input voltages manually. For details, refer to the data sheet.

Remote command:

INPut:​COUPling


Impedance

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > Radio Frequency (RF) Input > Impedance
Impedance

The reference impedance for the measured levels of the R&S FSW can be set to 50 Ω or 75 Ω.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a 75 Ω adapter of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

Remote command:

INPut:​IMPedance


High-Pass Filter 1...3 GHz

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > Radio Frequency (RF) Input > High-Pass Filter 1...3 GHz
High-Pass Filter 1...3 GHz

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Remote command:

INPut:​FILTer:​HPASs[:​STATe]


YIG-Preselector

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > Radio Frequency (RF) Input > YIG-Preselector
YIG-Preselector

Activates or deactivates the YIG-preselector.

An internal YIG-preselector at the input of the R&S FSW ensures that image frequencies are rejected. However, this is only possible for a restricted bandwidth. In order to use the maximum bandwidth for signal analysis you can deactivate the YIG-preselector at the input of the R&S FSW, which may lead to image-frequency display.

Note that the YIG-preselector is active only on frequencies greater than 8 GHz. Therefore, switching the YIG-preselector on or off has no effect if the frequency is below that value.

Remote command:

INPut:​FILTer:​YIG[:​STATe]


External Mixer Settings

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings
External Mixer Settings

The external mixer is configured in the "External Mixer" tab of the "Input" dialog box which is available when you do one of the following, if the R&S FSW-B21 option is installed:

  • Press the INPUT/OUTPUT key, then select the "External Mixer Config" softkey.
  • From the "Overview", select "Input", then switch to the "External Mixer" tab under "Input Source".

Note that external mixers are not supported in MSRA/MSRT mode.

Contents
  • Mixer Settings
  • Basic Settings
  • Managing Conversion Loss Tables
  • Creating and Editing Conversion Loss Tables


Mixer Settings

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Mixer Settings
Mixer Settings

In this tab you configure the band and specific mixer settings.

└ External Mixer State
└ RF Start / RF Stop
└ Handover Freq.
└ Band
└ RF Overrange
└ Preset Band
└ Mixer Type
└ Mixer Settings (Harmonics Configuration)
└ Harmonic Type
└ Range 1/2
└ Harmonic Order
└ Conversion loss


External Mixer State

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Mixer Settings > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


RF Start / RF Stop

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Mixer Settings > RF Start / RF Stop
RF Start / RF Stop

Displays the start and stop frequency of the selected band (read-only).

The frequency range for the user-defined band is defined via the harmonics configuration (see "Range 1/2").

For details see "Frequency Ranges" .

For details on available frequency ranges see table " Frequency ranges for pre-defined bands".

Remote command:

[SENSe:​]MIXer:​FREQuency:​STARt?

[SENSe:​]MIXer:​FREQuency:​STOP?


Handover Freq.

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Mixer Settings > Handover Freq.
Handover Freq.

Defines the frequency at which the mixer switches from one range to the next (if two different ranges are selected). The handover frequency can be selected freely within the overlapping frequency range.

For details see "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​FREQuency:​HANDover


Band

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Mixer Settings > Band
Band

Defines the waveguide band or user-defined band to be used by the mixer.

The start and stop frequencies of the selected band are displayed in the "RF Start" and "RF Stop" fields.

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

The mixer settings for the user-defined band can be selected freely. The frequency range for the user-defined band is defined via the harmonics configuration (see "Range 1/2").

For details see "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic:​BAND[:​VALue]


RF Overrange

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Mixer Settings > RF Overrange
RF Overrange

If enabled, the frequency range is not restricted by the band limits ("RF Start" and "RF Stop"). In this case, the full LO range of the selected harmonics is used.

For details see "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​RFOVerrange[:​STATe]


Preset Band

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Mixer Settings > Preset Band
Preset Band

Restores the presettings for the selected band.

Note: changes to the band and mixer settings are maintained even after using the PRESET function. This function allows you to restore the original band settings.

Remote command:

[SENSe:​]MIXer:​HARMonic:​BAND:​PRESet


Mixer Type

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Mixer Settings > Mixer Type
Mixer Type

The R&S FSW option B21 supports the following external mixer types:

(See also "Two-port and Three-port Mixers" )

"2 Port" | LO and IF data use the same port
"3 Port" | LO and IF data use separate ports
Remote command:

[SENSe:​]MIXer:​PORTs


Mixer Settings (Harmonics Configuration)

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration)
Mixer Settings (Harmonics Configuration)

The harmonics configuration determines the frequency range for user-defined bands (see "Band").

See also "Frequency Ranges" .

└ Harmonic Type
└ Range 1/2
└ Harmonic Order
└ Conversion loss


Harmonic Type

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Harmonic Type
Harmonic Type

Defines if only even, only odd, or even and odd harmonics can be used for conversion. Depending on this selection, the order of harmonic to be used for conversion changes (see "Harmonic Order"). Which harmonics are supported depends on the mixer type.

See also "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic:​TYPE


Range 1/2

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Range 1/2
Range 1/2

Enables the use of a second harmonic to cover the band's frequency range.

For each range you can define which harmonic to use and how the "Conversion loss" is handled.

See also "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic:​HIGH:​STATe


Harmonic Order

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Harmonic Order
Harmonic Order

Defines which of the available harmonic orders of the LO is used to cover the frequency range.

By default, the lowest order of the specified harmonic type is selected that allows conversion of input signals in the whole band. If due to the LO frequency the conversion is not possible using one harmonic, the band is split.

For the band "USER", the order of harmonic is defined by the user. The order of harmonic can be between 2 and 61, the lowest usable frequency being 26.5 GHz.

See also "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic[:​LOW]

[SENSe:​]MIXer:​HARMonic:​HIGH[:​VALue]


Conversion loss

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Conversion loss
Conversion loss

Defines how the conversion loss is handled. The following methods are available:

"Average"

Defines the average conversion loss for the entire range in dB.

"Table"

Defines the conversion loss via the table selected from the list. Predefined conversion loss tables are often provided with the external mixer and can be imported to the R&S FSW. Alternatively, you can define your own conversion loss tables. Imported tables are checked for compatibility with the current settings before being assigned.

Conversion loss tables are configured and managed in the "Managing Conversion Loss Tables" tab.

For details on conversion loss tables, see "Conversion Loss Tables" .

For details on importing tables, see "Import Table".

Remote command:

Average for range 1:

[SENSe:​]MIXer:​LOSS[:​LOW]

Table for range 1:

[SENSe:​]MIXer:​LOSS:​TABLe[:​LOW]

Average for range 2:

[SENSe:​]MIXer:​LOSS:​HIGH

Table for range 2:

[SENSe:​]MIXer:​LOSS:​TABLe:​HIGH


Basic Settings

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Basic Settings
Basic Settings

The basic settings concern general use of an external mixer. They are only available if the "External Mixer State" is "On".

└ External Mixer State
└ LO Level
└ Signal ID
└ Auto ID
└ Auto ID Threshold
└ Bias Settings
└ Write to <CVL table name>


External Mixer State

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Basic Settings > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


LO Level

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Basic Settings > LO Level
LO Level

Defines the LO level of the external mixer's LO port. Possible values are from 13.0 dBm to 17.0 dBm in 0.1 dB steps. Default value is 15.5 dB.

Remote command:

[SENSe:​]MIXer:​LOPower


Signal ID

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Basic Settings > Signal ID
Signal ID

Activates or deactivates visual signal identification. Two sweeps are performed alternately. Trace 1 shows the trace measured on the upper side band (USB) of the LO (the test sweep), trace 2 shows the trace measured on the lower side band (LSB), i.e. the reference sweep.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

(See also "Automatic Signal Identification" ).

Mathematical functions with traces and trace copy cannot be used with the Signal ID function.

Remote command:

[SENSe:​]MIXer:​SIGNal


Auto ID

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Basic Settings > Auto ID
Auto ID

Activates or deactivates automatic signal identification.

Auto ID basically functions like "Signal ID". However, the test and reference sweeps are converted into a single trace by a comparison of maximum peak values of each sweep point. The result of this comparison is displayed in trace 3 if "Signal ID" is active at the same time. If "Signal ID" is not active, the result can be displayed in any of the traces 1 to 3. Unwanted mixer products are suppressed in this calculated trace.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

See also "Automatic Signal Identification" .

Remote command:

[SENSe:​]MIXer:​SIGNal


Auto ID Threshold

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Basic Settings > Auto ID Threshold
Auto ID Threshold

Defines the maximum permissible level difference between test sweep and reference sweep to be corrected during automatic comparison ("Auto ID" function). The input range is between 0.1 dB and 100 dB. Values of about 10 dB (i.e. default setting) generally yield satisfactory results.

See also "Automatic Signal Identification" .

Remote command:

[SENSe:​]MIXer:​THReshold


Bias Settings

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Basic Settings > Bias Settings
Bias Settings

Define the bias current for each range, which is required to set the mixer to its optimum operating point. It corresponds to the short-circuit current. The bias current can range from -10 mA to 10 mA. The actual bias current is lower because of the forward voltage of the mixer diode(s).

The trace is adapted to the settings immediately so you can check the results. To store the bias setting in the currently selected conversion loss table, select the "Write to <CVL table name>" button.

Remote command:

[SENSe:​]MIXer:​BIAS[:​LOW]

[SENSe:​]MIXer:​BIAS:​HIGH

└ Write to <CVL table name>


Write to <CVL table name>

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Basic Settings > Bias Settings > Write to <CVL table name>
Write to <CVL table name>

Stores the bias setting in the currently selected "Conversion loss table" for the range (see "Managing Conversion Loss Tables"). If no conversion loss table is selected yet, this function is not available ("CVL Table not selected").

Remote command:

[SENSe:​]CORRection:​CVL:​BIAS


Managing Conversion Loss Tables

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Managing Conversion Loss Tables
Managing Conversion Loss Tables

In this tab you configure and manage conversion loss tables. Conversion loss tables consist of value pairs that describe the correction values for conversion loss at certain frequencies. The correction values for frequencies between the reference points are obtained via interpolation.

The currently selected table for each range is displayed at the top of the dialog box. All conversion loss tables found in the instrument's C:\r_s\instr\user\cvl\ directory are listed in the "Modify Tables" list.

└ External Mixer State
└ New Table
└ Edit Table
└ Delete Table
└ Import Table


External Mixer State

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Managing Conversion Loss Tables > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


New Table

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Managing Conversion Loss Tables > New Table
New Table

Opens the "Edit Conversion loss table" dialog box to configure a new conversion loss table. For details on table configuration see "Creating and Editing Conversion Loss Tables".

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Edit Table

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Managing Conversion Loss Tables > Edit Table
Edit Table

Opens the "Edit Conversion loss table" dialog box to edit the selected conversion loss table. For details on table configuration see "Creating and Editing Conversion Loss Tables".

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Delete Table

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Managing Conversion Loss Tables > Delete Table
Delete Table

Deletes the currently selected conversion loss table after you confirm the action.

Remote command:

[SENSe:​]CORRection:​CVL:​CLEAr


Import Table

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Managing Conversion Loss Tables > Import Table
Import Table

Imports a stored conversion loss table from any directory and copies it to the instrument's C:\r_s\instr\user\cvl\ directory. It can then be assigned for use for a specific frequency range (see "Conversion loss").

For details see "Conversion Loss Tables" .


Creating and Editing Conversion Loss Tables

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Creating and Editing Conversion Loss Tables
Creating and Editing Conversion Loss Tables

Conversion loss tables can be defined and edited in the "Edit conversion loss table" dialog box which is displayed when you select the "New Table" button in the "External Mixer > Conversion loss table" settings.

A preview pane displays the current configuration of the conversion loss function as described by the position/value entries.

└ File Name
└ Comment
└ Band
└ Harmonic Order
└ Bias
└ Mixer Name
└ Mixer S/N
└ Mixer Type
└ Position/Value
└ Insert Value
└ Delete Value
└ Shift x
└ Shift y
└ Save


File Name

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Creating and Editing Conversion Loss Tables > File Name
File Name

Defines the name under which the table is stored in the C:\r_s\instr\user\cvl\ directory on the instrument. The name of the table is identical with the name of the file (without extension) in which the table is stored. This setting is mandatory. The .ACL extension is automatically appended during storage.

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Comment

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Creating and Editing Conversion Loss Tables > Comment
Comment

An optional comment that describes the conversion loss table. The comment can be freely defined by the user.

Remote command:

[SENSe:​]CORRection:​CVL:​COMMent


Band

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Creating and Editing Conversion Loss Tables > Band
Band

The waveguide or user-defined band for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

Remote command:

[SENSe:​]CORRection:​CVL:​BAND


Harmonic Order

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Creating and Editing Conversion Loss Tables > Harmonic Order
Harmonic Order

The harmonic order of the range for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​HARMonic


Bias

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Creating and Editing Conversion Loss Tables > Bias
Bias

The bias current which is required to set the mixer to its optimum operating point. It corresponds to the short-circuit current. The bias current can range from -10 mA to 10 mA. The actual bias current is lower because of the forward voltage of the mixer diode(s).

Tip: You can also define the bias interactively while a preview of the trace with the changed setting is displayed, see "Bias Settings".

Remote command:

[SENSe:​]CORRection:​CVL:​BIAS


Mixer Name

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer Name
Mixer Name

Specifies the name of the external mixer for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​MIXer


Mixer S/N

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer S/N
Mixer S/N

Specifies the serial number of the external mixer for which the table is to be applied.

This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​SNUMber


Mixer Type

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer Type
Mixer Type

Specifies whether the external mixer for which the table is to be applied is a two-port or three-port type. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​PORTs


Position/Value

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Creating and Editing Conversion Loss Tables > Position/Value
Position/Value

Each position/value pair defines the correction value for conversion loss for a specific frequency. The reference values must be entered in order of increasing frequencies. A maximum of 50 reference values can be entered. To enter a new value pair, select the "Position/Value" table, or select the "Insert Value" button.

Correction values for frequencies between the reference values are obtained by interpolation. Linear interpolation is performed if the table contains only two values. If it contains more than two reference values, spline interpolation is carried out. Outside the frequency range covered by the table the conversion loss is assumed to be the same as that for the first and last reference value.

(See "Conversion Loss Tables" .)

The current configuration of the conversion loss function as described by the position/value entries is displayed in the preview pane to the right of the table.

Remote command:

[SENSe:​]CORRection:​CVL:​DATA


Insert Value

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Creating and Editing Conversion Loss Tables > Insert Value
Insert Value

Inserts a new position/value entry in the table.

If the table is empty, a new entry at 0 Hz is inserted.

If entries already exist, a new entry is inserted above the selected entry. The position of the new entry is selected such that it divides the span to the previous entry in half.


Delete Value

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Creating and Editing Conversion Loss Tables > Delete Value
Delete Value

Deletes the currently selected position/value entry.


Shift x

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Creating and Editing Conversion Loss Tables > Shift x
Shift x

Shifts all positions in the table by a specific value. The value can be entered in the edit dialog box. The conversion loss function in the preview pane is shifted along the x-axis.


Shift y

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Creating and Editing Conversion Loss Tables > Shift y
Shift y

Shifts all conversion loss values by a specific value. The value can be entered in the edit dialog box. The conversion loss function in the preview pane is shifted along the y-axis.


Save

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Mixer Settings > Creating and Editing Conversion Loss Tables > Save
Save

The conversion loss table is stored under the specified name in the C:\r_s\instr\user\cvl\ directory of the instrument.


External Generator

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Generator
External Generator
Contents
  • Interface Configuration Settings
  • Measurement Configuration


Interface Configuration Settings

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Generator > Interface Configuration Settings
Interface Configuration Settings

The interface settings for the connection to the external generator are defined in the "Interface Configuration" subtab of the "External Generator" tab.

To display this dialog box, press the INPUT/OUPUT key and then select "External Generator Config".

└ Generator Type
└ Interface
└ TTL Handshake
└ GPIB Address / TCP/IP Address
└ Reference
└ Edit Generator Setup File
└ Frequency Min. / Frequency Max.
└ Level Min. / Level Max.


Generator Type

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Generator > Interface Configuration Settings > Generator Type
Generator Type

Selects the generator type and thus defines the generator setup file to use.

Remote command:

SYSTem:​COMMunicate:​RDEVice:​GENerator:​TYPE


Interface

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Generator > Interface Configuration Settings > Interface
Interface

Type of interface connection used. The following interfaces are currently supported:

  • GPIB
  • TCP/IP (not by all generators)

For details on which signal generators support which interfaces, see the documentation of the corresponding signal generator.

Remote command:

SYSTem:​COMMunicate:​RDEVice:​GENerator:​INTerface


TTL Handshake

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Generator > Interface Configuration Settings > TTL Handshake
TTL Handshake

Turning the TTL handshake on and off has no effect for Noise Figure measurements.


GPIB Address / TCP/IP Address

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Generator > Interface Configuration Settings > GPIB Address / TCP/IP Address
GPIB Address / TCP/IP Address

For LAN connections: TCP/IP address of the signal generator

For GPIB connections: GPIB address of the signal generator.

For details on interfaces see "Remote Control Interfaces and Protocols" .

Remote command:

SYSTem:​COMMunicate:​GPIB:​RDEVice:​GENerator:​ADDRess

SYSTem:​COMMunicate:​TCPip:​RDEVice:​GENerator:​ADDRess


Reference

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Generator > Interface Configuration Settings > Reference
Reference

Selects the internal R&S FSW or an external frequency reference to synchronize the R&S FSW with the generator (default: internal).

Remote command:

SOURce:​EXTernal:​ROSCillator[:​SOURce]


Edit Generator Setup File

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Generator > Interface Configuration Settings > Edit Generator Setup File
Edit Generator Setup File

Displays the setup file for the currently selected "Generator Type" in read-only mode in an editor.

Although the existing setup files are displayed in read-only mode in the editor, they can be saved under a different name (using "File > SaveAs").

For more information see "External Generator Control".


Frequency Min. / Frequency Max.

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Generator > Interface Configuration Settings > Frequency Min. / Frequency Max.
Frequency Min. / Frequency Max.

For reference only: Lower and upper frequency limit for the generator.


Level Min. / Level Max.

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Generator > Interface Configuration Settings > Level Min. / Level Max.
Level Min. / Level Max.

For reference only: Lower and upper power limit for the generator.


Measurement Configuration

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Generator > Measurement Configuration
Measurement Configuration
└ Automatic Control
└ Init Before Meas
└ Auto Switch Off
└ Source Power
└ Frequency Coupling
└ Init External Generator


Automatic Control

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Generator > Measurement Configuration > Automatic Control
Automatic Control

Turns automatic control of the external generator on and off.

If on, the application controls the configuration of the external generator during measurements by transmitting the required remote commands. The connection is established automatically before a measurement if Init Before Meas is on. To establish the connection manually at any time, use the Init External Generator function.

Otherwise, you have to control the generator manually. The application assumes that the generator is configured correctly for the measurement. The remote connection to the generator is automatically terminated.

Note that you have to turn automatic control on if you want to perform Fixed IF measurements in order to keep the LO frequency tuned to the current measurement (RF) frequency. Manual control is recommended only for measurements whose generator settings remain the same during the measurement.

Remote command:

SYSTem:​CONFigure:​GENerator:​CONTrol:​STATe


Init Before Meas

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Generator > Measurement Configuration > Init Before Meas
Init Before Meas

Turns automatic transmission of the external generator configuration on and off.

If on, the application transmits a sequence of remote commands that configures the generator and turns on its RF output before each measurement. Configuring the generator this way allows you to make sure that the generator runs with the configuration you need and is in a state to receive remote control commands during a measurement. Using automatic initialization of the generator results in a slightly longer measurement time because of the time required to transmit the commands and configure the generator.

If off, you have to initialize the generator manually with Init External Generator.

Note that you have to establish the connection in order to be able to perform a measurement with the external generator.

Remote command:

SYSTem:​CONFigure:​GENerator:​INITialise:​AUTO


Auto Switch Off

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Generator > Measurement Configuration > Auto Switch Off
Auto Switch Off

Turns automatic deactivation of the generator's RF output on and off.

If on, the application transmits a sequence of remote commands to turn off the RF output of the generator when a measurement is over. A measurement is over after a single sweep or if the measurement is aborted. The sequence of commands also ends the remote control session.

If off, you have to turn the RF output and remote control session off manually.

Note that exiting the Noise Figure Measurement application always turns off the generator's RF output and terminates the remote session.

Remote command:

SYSTem:​CONFigure:​GENerator:​SWITch:​AUTO


Source Power

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Generator > Measurement Configuration > Source Power
Source Power

Defines the output power of the external generator.

The range depends on the generator you are using and is defined in its data sheet.

Remote command:

SOURce:​EXTernal:​POWer[:​LEVel]


Frequency Coupling

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Generator > Measurement Configuration > Frequency Coupling
Frequency Coupling

Defines frequency correction characteristics.

The generator frequency is calculated as follows.

You can use the factors and offsets to compensate one or more components in the test setup that may change the frequency between the generator and the DUT. Make sure, however, that the result does not exceed the frequency range of the generator.

The application calculates the resulting start and stop frequency based on the values you apply and displays them below the equation.

Remote command:

SOURce:​EXTernal:​FREQuency[:​FACTor]:​DENominator

SOURce:​EXTernal:​FREQuency[:​FACTor]:​NUMerator

SOURce:​EXTernal:​FREQuency:​OFFSet<offset>


Init External Generator

Noise Figure Measurements (R&S FSW-K30) > Configuration > Configuring Inputs and Outputs of the R&S FSW > External Generator > Measurement Configuration > Init External Generator
Init External Generator

Establishes a connection to generator and turns on its RF output.

You can establish the connection automatically before a measurement if Init Before Meas is on.

Note that you have to establish the connection in order to be able to perform a measurement with the external generator.

Remote command:

SYSTem:​CONFigure:​GENerator:​INITialise:​IMMediate


Analysis

Noise Figure Measurements (R&S FSW-K30) > Analysis
Analysis

This chapter contains all settings and parameters that the application provides to analyze and evaluate measurement results.

Contents
  • Configuring the Display
  • Working with Traces
  • Using Markers
  • Limit Line Settings and Functions


Configuring the Display

Noise Figure Measurements (R&S FSW-K30) > Analysis > Configuring the Display
Configuring the Display

The "Display Configuration" button or the "Result Config" softkey open a dialog box to configure the way the results are displayed in the diagram.

The contents depend on whether you want to configure a graphical result display or a numerical result display.

Specifics for

The settings you make apply to the results you have selected in the "Specifics for" dropdown menu. If more than one window is on, "Specifics for" also puts the focus on the corresponding window.

Contents
  • Configuring Graphical Results
  • Configuring Numerical Results


Configuring Graphical Results

Noise Figure Measurements (R&S FSW-K30) > Analysis > Configuring the Display > Configuring Graphical Results
Configuring Graphical Results

When configuring graphical results, the dialog box contains functionality to scale and set up the diagram axes.

└ Y-Axis
└ Auto Scale / Min / Max
└ Symbols
└ X-Axis


Y-Axis

Noise Figure Measurements (R&S FSW-K30) > Analysis > Configuring the Display > Configuring Graphical Results > Y-Axis
Y-Axis

Selects the result display and thus the scaling of the vertical axis.

For more information see "Measurements and Result Displays".


Auto Scale / Min / Max

Noise Figure Measurements (R&S FSW-K30) > Analysis > Configuring the Display > Configuring Graphical Results > Auto Scale / Min / Max
Auto Scale / Min / Max

Turns automatic scaling of the vertical axis on and off.

If on, the application optimizes the scaling of the vertical axis after each measurement for ideal viewing of the results.

If off, you can define the scaling manually. The "Min" and "Max" input fields become available. These two input fields define the values at the top and bottom of the vertical axis.

Remote command:

Automatic scaling:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO

Manual minimum value:

DISPlay[:​WINDow<n>]:​TRACe<t>:​Y[:​SCALe]:​BOTTom

Manual maximum value

DISPlay[:​WINDow<n>]:​TRACe<t>:​Y[:​SCALe]:​TOP


Symbols

Noise Figure Measurements (R&S FSW-K30) > Analysis > Configuring the Display > Configuring Graphical Results > Symbols
Symbols

Turns symbols that represent a measurement point on the trace on and off.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​SYMBols


X-Axis

Noise Figure Measurements (R&S FSW-K30) > Analysis > Configuring the Display > Configuring Graphical Results > X-Axis
X-Axis

Selects the frequency data that is displayed on the x-axis.

For measurements on frequency converting DUTs with a variable intermediary frequency, you can display either the RF frequency or the IF frequency.

Note that a change of the x-axis scale applies to all result displays.

The "Frequency Axis" scale is also available via the FREQ key.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​X[:​SCALe]


Configuring Numerical Results

Noise Figure Measurements (R&S FSW-K30) > Analysis > Configuring the Display > Configuring Numerical Results
Configuring Numerical Results

When configuring numerical results, the dialog box selects the type of results you want to display in the result table. The results in the table are based on a particular trace that you can select in the corresponding input field.

You can add an aspect of the measurement by placing a checkmark in front of the corresponding result on and remove it by removing the checkmark.

For more information on each result see "Measurements and Result Displays".


Working with Traces

Noise Figure Measurements (R&S FSW-K30) > Analysis > Working with Traces
Working with Traces

A trace is the graphical representation of a set of measurement results in a diagram. Each measurement window that contains graphical results supports up to four individual traces. Each trace has a different color. Trace settings determine how the measured data is analyzed and displayed on the screen. The trace information, including a color map and trace mode is summarized in the diagram header.

The trace settings are combined in the "Trace Configuration" dialog box. You can access this dialog box with the "Trace Config" softkey or directly access one of the tabs via one of the softkeys in the "Trace" menu.

└ Traces
└ Copy Trace
└ Preset Traces
└ Trace Config
└ Trace Export


Traces

Noise Figure Measurements (R&S FSW-K30) > Analysis > Working with Traces > Traces
Traces

The "Traces" tab contains functionality to configure a trace.

"Trace Selection" | The "Trace 1" to "Trace 4" buttons select a trace. If a trace is selected, it is highlighted orange. Note that you cannot select a trace if its trace mode is "Blank".
"Trace Mode" | Selects the trace mode for the corresponding trace. For more information see "Measurement Basics".
Remote command:

Trace mode:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE


Copy Trace

Noise Figure Measurements (R&S FSW-K30) > Analysis > Working with Traces > Copy Trace
Copy Trace

The "Copy Trace" softkey opens the "Copy Trace" tab of the "Trace Configuration" dialog box.

The "Copy Trace" tab contains functionality to copy trace data to another trace.

The first group of buttons (labelled "Trace 1" to "Trace 4") select the source trace. The second group of buttons (labelled "Copy to Trace 1" to "Copy to Trace 4") select the destination.

Remote command:

TRACe<n>:​COPY


Preset Traces

Noise Figure Measurements (R&S FSW-K30) > Analysis > Working with Traces > Preset Traces
Preset Traces

Restores the default configuration for all traces in a window.


Trace Config

Noise Figure Measurements (R&S FSW-K30) > Analysis > Working with Traces > Trace Config
Trace Config

Opens a dialog box made up out of three tabs to configure traces.

The first tab contains functionality to configure a trace. For more information see "Traces".

The second tab contains functionality to export trace data. For more information see "Trace Export".

The third tab contains functionality to copy traces. For more information see "Copy Trace".


Trace Export

Noise Figure Measurements (R&S FSW-K30) > Analysis > Working with Traces > Trace Export
Trace Export

The "Trace Export" tab contains functionality to export trace data.

"Export all traces and all table results" | Turns the export of all measurement results (traces and numerical results) on and off. If on, selecting a particular trace to export in the "Trace to Export" dropdown menu is unavailable.
"Include Instrument Measurement Settings" | Includes or excludes the measurement configuration as shown in the channel bar from the export.
"Trace to Export" | Selects the trace that will be exported to a file.
"Decimal Separator" | Selects the decimal separator for floating-point numerals for the ASCII Trace export. Evaluation programs require different separators in different languages.
"Export Trace to ASCII File" | Opens a file selection dialog box and saves the selected trace in ASCII format to the specified file and directory.
Remote command:

Decimal separator:

FORMat:​DEXPort:​DSEParator

Export trace to ASCII file:

MMEMory:​STORe<n>:​TRACe

Selecting a trace:

FORMat:​DEXPort:​TRACes

Export the header:

FORMat:​DEXPort:​HEADer


Using Markers

Noise Figure Measurements (R&S FSW-K30) > Analysis > Using Markers
Using Markers

Markers help you to read out measurement results for particular frequencies or mark a particular point on a trace. The noise figure application features four markers. Markers in the noise figure application are linked. If you use more than one measurement window and activate a marker in one window, it also appears in all other measurement windows on the same horizontal position.

Contents
  • Marker Configuration
  • Marker Positioning


Marker Configuration

Noise Figure Measurements (R&S FSW-K30) > Analysis > Using Markers > Marker Configuration
Marker Configuration
└ Marker (1...4)
└ Marker Type
└ Marker to Trace
└ All Markers Off
└ Marker Config


Marker (1...4)

Noise Figure Measurements (R&S FSW-K30) > Analysis > Using Markers > Marker Configuration > Marker (1...4)
Marker (1...4)

Selects or turns the corresponding marker on and off.

Turning on a marker also opens an input field to define the horizontal position of the marker.

By default, the first marker you turn on is a normal marker, all others are delta markers.


Marker Type

Noise Figure Measurements (R&S FSW-K30) > Analysis > Using Markers > Marker Configuration > Marker Type
Marker Type

Toggles the marker type.

The type for marker 1 is always "Normal", the type for delta marker 1 is always "Delta". These types cannot be changed.

Note: If normal marker 1 is the active marker, switching the "Mkr Type" activates an additional delta marker 1. For any other marker, switching the marker type does not activate an additional marker, it only switches the type of the selected marker.

"Normal" | A normal marker indicates the absolute value at the defined position in the diagram.
"Delta" | A delta marker defines the value of the marker relative to the specified reference marker (marker 1 by default).
Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Marker to Trace

Noise Figure Measurements (R&S FSW-K30) > Analysis > Using Markers > Marker Configuration > Marker to Trace
Marker to Trace

Opens an input field to assign the marker to a particular trace if you are using more than one trace.


All Markers Off

Noise Figure Measurements (R&S FSW-K30) > Analysis > Using Markers > Marker Configuration > All Markers Off
All Markers Off

Deactivates all markers in one step.

Remote command:

CALCulate<n>:​MARKer<m>:​AOFF


Marker Config

Noise Figure Measurements (R&S FSW-K30) > Analysis > Using Markers > Marker Configuration > Marker Config
Marker Config

Opens the "Marker Configuration" dialog box.

The "Marker Configuration" dialog box contains all marker functions necessary to set up the four markers supported by the application.

  • Selected
    Highlights the currently selected marker.
  • State
    Turns a marker on and off.
  • X-value
    Defines the marker position on the horizontal axis.
  • Type
    Selects the marker type. For more information see "Marker Type".
  • Trace
    Selects the trace the marker is positioned on.


Marker Positioning

Noise Figure Measurements (R&S FSW-K30) > Analysis > Using Markers > Marker Positioning
Marker Positioning

If you are using more thn one measurement window, the application performs the peak search in the currently selected measurement window. The currently selected measurement window has a blue border. Because the markers are linked in the noise figure application, the frequency position of the marker in the other window is updated accordingly, even if it means that the marker is on a peak in one window only.

└ Select Marker <x>
└ Peak Search
└ Search Next Peak
└ Search Minimum
└ Search Next Minimum
└ Marker to Single Frequency


Select Marker <x>

Noise Figure Measurements (R&S FSW-K30) > Analysis > Using Markers > Marker Positioning > Select Marker <x>
Select Marker <x>

Opens a dialog box to select and activate or deactivate one or more markers.

The number in the softkey label (<x>) shows the number of the currently selected marker.

Remote command:

Marker selected via suffix <m> in remote commands.


Peak Search

Noise Figure Measurements (R&S FSW-K30) > Analysis > Using Markers > Marker Positioning > Peak Search
Peak Search

Sets the selected marker/delta marker to the maximum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MAXimum[:​PEAK]


Search Next Peak

Noise Figure Measurements (R&S FSW-K30) > Analysis > Using Markers > Marker Positioning > Search Next Peak
Search Next Peak

Sets the selected marker/delta marker to the next (lower) maximum of the assigned trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT


Search Minimum

Noise Figure Measurements (R&S FSW-K30) > Analysis > Using Markers > Marker Positioning > Search Minimum
Search Minimum

Sets the selected marker/delta marker to the minimum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MINimum[:​PEAK]


Search Next Minimum

Noise Figure Measurements (R&S FSW-K30) > Analysis > Using Markers > Marker Positioning > Search Next Minimum
Search Next Minimum

Sets the selected marker/delta marker to the next (higher) minimum of the selected trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT


Marker to Single Frequency

Noise Figure Measurements (R&S FSW-K30) > Analysis > Using Markers > Marker Positioning > Marker to Single Frequency
Marker to Single Frequency

Starts a single frequency measurement on the current marker position.

When you use this function, the application changes the tuning mode and automatically adjusts the single frequency to that of the current marker position.

For more information see "Single Frequency Measurements".


Limit Line Settings and Functions

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions
Limit Line Settings and Functions

The noise figure measurement application supports up to eight active limit lines in each active measurement window.

Contents
  • Limit Line Management
  • Limit Line Details


Limit Line Management

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Management
Limit Line Management

Limit lines are managed in the "Line Config" dialog box which is displayed when you press the LINES key and then "Lines Config" softkey.

For the limit line overview, the R&S FSW searches for all stored limit lines with the file extension .LIN in the limits subfolder of the main installation folder. The overview allows you to determine which limit lines are available and can be used for the current measurement.

For details on settings for individual lines see "Limit Line Details".

For more basic information on limit lines see "Basics on Limit Lines" .

For instructions on configuring and working with limit lines see "Defining Limit Lines" .

└ Name
└ Unit
└ Compatibility
└ Visibility
└ Traces to be Checked
└ Comment
└ Show compatible limit lines
└ Show lines for noise
└ Create New Line
└ Edit Line
└ Copy Line
└ Delete Line
└ Disable All Lines


Name

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Management > Name
Name

The name of the stored limit line.


Unit

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Management > Unit
Unit

The unit in which the y-values of the data points of the limit line are defined.


Compatibility

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Management > Compatibility
Compatibility

Indicates whether the limit line definition is compatible with the current measurement settings.

For more information on which conditions a limit line must fulfill to be compatible, see "Basics on Limit Lines" .


Visibility

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Management > Visibility
Visibility

Displays or hides the limit line in the diagram. Up to 8 limit lines can be visible at the same time. Inactive limit lines can also be displayed in the diagram.

Remote command:

CALCulate:​LIMit<k>:​LOWer:​STATe

CALCulate:​LIMit<k>:​UPPer:​STATe

CALCulate:​LIMit:​ACTive?


Traces to be Checked

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Management > Traces to be Checked
Traces to be Checked

Defines which traces are automatically checked for conformance with the limit lines. As soon as a trace to be checked is defined, the assigned limit line is active. One limit line can be activated for several traces simultaneously. If any of the "Traces to be Checked" violate any of the active limit lines, a message is indicated in the diagram.

Remote command:

CALCulate:​LIMit<k>:​TRACe<t>:​CHECk


Comment

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Management > Comment
Comment

An optional description of the limit line.


Show compatible limit lines

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Management > Show compatible limit lines
Show compatible limit lines

Defines which of the stored limit lines are included in the overview.

If active, only limit lines that are compatible to the result display currently in focus are displayed.


Show lines for noise

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Management > Show lines for noise
Show lines for noise

If activated (default), only limit lines created for noise figure measurements are displayed. Otherwise, all limit lines are displayed.


Create New Line

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Management > Create New Line
Create New Line

Creates a new limit line.

For instructions see "How to configure a new limit line" .


Edit Line

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Management > Edit Line
Edit Line

Edit an existing limit line configuration.

For instructions see "How to edit existing limit lines" .


Copy Line

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Management > Copy Line
Copy Line

Copy the selected limit line configuration to create a new line.

For instructions see "How to edit existing limit lines" .

Remote command:

CALCulate:​LIMit<k>:​COPY


Delete Line

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Management > Delete Line
Delete Line

Delete the selected limit line configuration.

For instructions see "How to edit existing limit lines" .

Remote command:

CALCulate:​LIMit<k>:​DELete


Disable All Lines

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Management > Disable All Lines
Disable All Lines

Disable all limit lines in one step.

Remote command:

CALCulate:​LIMit<k>:​STATe


Limit Line Details

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Details
Limit Line Details

Limit lines details are configured in the "Edit Line Line" dialog box which is displayed when you select the "New", "Edit" or "Copy To" buttons in the "Line Config" dialog box.

└ Name
└ Comment
└ Y-Axis
└ Data points
└ Insert Value
└ Delete Value
└ Shift x
└ Shift y
└ Save


Name

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Details > Name
Name

Defines the limit line name. All names must be compatible with Windows conventions for file names. The limit line data is stored under this name (with a .LIN extension).

Remote command:

CALCulate:​LIMit<k>:​NAME


Comment

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Details > Comment
Comment

Defines an optional comment for the limit line. The text may contain up to 40 characters.

Remote command:

CALCulate:​LIMit:​COMMent


Y-Axis

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Details > Y-Axis
Y-Axis

Describes the vertical axis on which the data points of the limit line are defined.

You can select the type of limit line (upper or lower) for each type of result. From that information, the application sets the level unit and y-axis scaling. Both are then fix parameters because the unit depends on the result and the scaling is always absolute in case of noise figure measurements.


Data points

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Details > Data points
Data points

Each limit line is defined by a minimum of 2 and a maximum of 200 data points. Each data point is defined by its position (x-axis) and value (y-value). Data points must be defined in ascending order. The same position can have two different values.

Remote command:

CALCulate:​LIMit<k>:​CONTrol[:​DATA]

CALCulate:​LIMit<k>:​LOWer[:​DATA]

CALCulate:​LIMit<k>:​UPPer[:​DATA]


Insert Value

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Details > Insert Value
Insert Value

Inserts a data point in the limit line above the selected one in the "Edit Limit Line" dialog box.


Delete Value

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Details > Delete Value
Delete Value

Deletes the selected data point in the "Edit Limit Line" dialog box.


Shift x

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Details > Shift x
Shift x

Shifts the x-value of each data point horizontally by the defined shift width.

Remote command:

CALCulate:​LIMit<k>:​CONTrol:​SHIFt


Shift y

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Details > Shift y
Shift y

Shifts the y-value of each data point vertically by the defined shift width.

Remote command:

CALCulate:​LIMit<k>:​LOWer:​SHIFt

CALCulate:​LIMit<k>:​UPPer:​SHIFt


Save

Noise Figure Measurements (R&S FSW-K30) > Analysis > Limit Line Settings and Functions > Limit Line Details > Save
Save

Saves the currently edited limit line under the name defined in the "Name" field.


Remote Control Commands for Noise Measurements

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements
Remote Control Commands for Noise Measurements

The following remote control commands are required to configure and perform noise figure measurements in a remote environment. The R&S FSW must already be set up for remote operation in a network as described in the base unit manual.

Universal functionality

Note that basic tasks that are also performed in the base unit in the same way are not described here. For a description of such tasks, see the R&S FSW User Manual.

In particular, this includes:

  • Managing Settings and Results, i.e. storing and loading settings and result data.
  • Basic instrument configuration, e.g. checking the system configuration, customizing the screen layout, or configuring networks and remote operation.
  • Using the common status registers (specific status registers for Pulse measurements are not used).
Contents
  • Overview of Remote Command Suffixes
  • Introduction
  • Controlling the Noise Figure Measurement Channel
  • Working with Windows in the Display
  • Measurement Results
  • Defining the Measurement Frequency
  • Selecting DUT Characteristics
  • Configuring the Noise Source
  • Configuring Additional Loss
  • Configuring the Analyzer
  • Using the Uncertainty Calculator
  • Performing Measurements
  • Configuring the Inputs and Outputs
  • Configuring the Display
  • Working with Traces
  • Working with Limit Lines
  • Working with Markers
  • Using the Status Register
  • Deprecated Remote Commands for Noise Figure Measurements


Overview of Remote Command Suffixes

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Overview of Remote Command Suffixes
Overview of Remote Command Suffixes

The remote commands for the Noise Figure Measurement application support the following suffixes.

Suffix | Value range | Description
<k> | 1...8 | Selects a limit line.
<m> | 1...4 | Selects a marker or delta marker.
<n> | 1...16 | Selects a measurement window.
<t> | 1...4 | Selects a trace.


Introduction

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Introduction
Introduction

Commands are program messages that a controller (e.g. a PC) sends to the instrument or software. They operate its functions ('setting commands' or 'events') and request information ('query commands'). Some commands can only be used in one way, others work in two ways (setting and query). If not indicated otherwise, the commands can be used for settings and queries.

The syntax of a SCPI command consists of a header and, in most cases, one or more parameters. To use a command as a query, you have to append a question mark after the last header element, even if the command contains a parameter.

A header contains one or more keywords, separated by a colon. Header and parameters are separated by a "white space" (ASCII code 0 to 9, 11 to 32 decimal, e.g. blank). If there is more than one parameter for a command, these are separated by a comma from one another.

Only the most important characteristics that you need to know when working with SCPI commands are described here. For a more complete description, refer to the User Manual of the R&S FSW.

Remote command examples

Note that some remote command examples mentioned in this general introduction may not be supported by this particular application.

Contents
  • Long and Short Form
  • Numeric Suffixes
  • Optional Keywords
  • Alternative Keywords
  • SCPI Parameters


Long and Short Form

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Introduction > Long and Short Form
Long and Short Form

The keywords have a long and a short form. You can use either the long or the short form, but no other abbreviations of the keywords.

The short form is emphasized in upper case letters. Note however, that this emphasis only serves the purpose to distinguish the short from the long form in the manual. For the instrument, the case does not matter.

Example:

SENSe:FREQuency:CENTer is the same as SENS:FREQ:CENT.


Numeric Suffixes

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Introduction > Numeric Suffixes
Numeric Suffixes

Some keywords have a numeric suffix if the command can be applied to multiple instances of an object. In that case, the suffix selects a particular instance (e.g. a measurement window).

Numeric suffixes are indicated by angular brackets (<n>) next to the keyword.

If you don't quote a suffix for keywords that support one, a 1 is assumed.

Example:

DISPlay[:WINDow<1...4>]:ZOOM:STATe enables the zoom in a particular measurement window, selected by the suffix at WINDow.

DISPlay:WINDow4:ZOOM:STATe ON refers to window 4.


Optional Keywords

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Introduction > Optional Keywords
Optional Keywords

Some keywords are optional and are only part of the syntax because of SCPI compliance. You can include them in the header or not.

Note that if an optional keyword has a numeric suffix and you need to use the suffix, you have to include the optional keyword. Otherwise, the suffix of the missing keyword is assumed to be the value 1.

Optional keywords are emphasized with square brackets.

Example:

Without a numeric suffix in the optional keyword:

[SENSe:]FREQuency:CENTer is the same as FREQuency:CENTer

With a numeric suffix in the optional keyword:

DISPlay[:WINDow<1...4>]:ZOOM:STATe

DISPlay:ZOOM:STATe ON enables the zoom in window 1 (no suffix).

DISPlay:WINDow4:ZOOM:STATe ON enables the zoom in window 4.


Alternative Keywords

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Introduction > Alternative Keywords
Alternative Keywords

A vertical stroke indicates alternatives for a specific keyword. You can use both keywords to the same effect.

Example:

[SENSe:]BANDwidth|BWIDth[:RESolution]

In the short form without optional keywords, BAND 1MHZ would have the same effect as BWID 1MHZ.


SCPI Parameters

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Introduction > SCPI Parameters
SCPI Parameters

Many commands feature one or more parameters.

If a command supports more than one parameter, these are separated by a comma.

Example:

LAYout:ADD:WINDow Spectrum,LEFT,MTABle

Parameters may have different forms of values.

Contents
  • Numeric Values
  • Boolean
  • Character Data
  • Character Strings
  • Block Data


Numeric Values

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Introduction > SCPI Parameters > Numeric Values
Numeric Values

Numeric values can be entered in any form, i.e. with sign, decimal point or exponent. In case of physical quantities, you can also add the unit. If the unit is missing, the command uses the basic unit.

Example:

with unit: SENSe:FREQuency:CENTer 1GHZ

without unit: SENSe:FREQuency:CENTer 1E9 would also set a frequency of 1 GHz.

Values exceeding the resolution of the instrument are rounded up or down.

If the number you have entered is not supported (e.g. in case of discrete steps), the command returns an error.

Instead of a number, you can also set numeric values with a text parameter in special cases.

  • MIN/MAX
    Defines the minimum or maximum numeric value that is supported.
  • DEF
    Defines the default value.
  • UP/DOWN
    Increases or decreases the numeric value by one step. The step size depends on the setting. In some cases you can customize the step size with a corresponding command.
Querying numeric values

When you query numeric values, the system returns a number. In case of physical quantities, it applies the basic unit (e.g. Hz in case of frequencies). The number of digits after the decimal point depends on the type of numeric value.

Example:

Setting: SENSe:FREQuency:CENTer 1GHZ

Query: SENSe:FREQuency:CENTer? would return 1E9

In some cases, numeric values may be returned as text.

  • INF/NINF
    Infinity or negative infinity. Represents the numeric values 9.9E37 or -9.9E37.
  • NAN
    Not a number. Represents the numeric value 9.91E37. NAN is returned in case of errors.


Boolean

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Introduction > SCPI Parameters > Boolean
Boolean

Boolean parameters represent two states. The "ON" state (logically true) is represented by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by "OFF" or the numeric value 0.

Querying boolean parameters

When you query boolean parameters, the system returns either the value 1 ("ON") or the value 0 ("OFF").

Example:

Setting: DISPlay:WINDow:ZOOM:STATe ON

Query: DISPlay:WINDow:ZOOM:STATe? would return 1


Character Data

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Introduction > SCPI Parameters > Character Data
Character Data

Character data follows the syntactic rules of keywords. You can enter text using a short or a long form. For more information see "Long and Short Form".

Querying text parameters

When you query text parameters, the system returns its short form.

Example:

Setting: SENSe:BANDwidth:RESolution:TYPE NORMal

Query: SENSe:BANDwidth:RESolution:TYPE? would return NORM


Character Strings

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Introduction > SCPI Parameters > Character Strings
Character Strings

Strings are alphanumeric characters. They have to be in straight quotation marks. You can use a single quotation mark ( ' ) or a double quotation mark ( " ).

Example:

INSTRument:DELete 'Spectrum'


Block Data

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Introduction > SCPI Parameters > Block Data
Block Data

Block data is a format which is suitable for the transmission of large amounts of data.

The ASCII character # introduces the data block. The next number indicates how many of the following digits describe the length of the data block. In the example the 4 following digits indicate the length to be 5168 bytes. The data bytes follow. During the transmission of these data bytes all end or other control signs are ignored until all bytes are transmitted. #0 specifies a data block of indefinite length. The use of the indefinite format requires a NL^END message to terminate the data block. This format is useful when the length of the transmission is not known or if speed or other considerations prevent segmentation of the data into blocks of definite length.


Controlling the Noise Figure Measurement Channel

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Controlling the Noise Figure Measurement Channel
Controlling the Noise Figure Measurement Channel

The following commands are necessary to control the measurement channel.

List of Commands
INSTrument:CREate:DUPLicate
INSTrument:CREate[:NEW]
INSTrument:CREate:REPLace
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
SYSTem:PRESet:CHANnel[:EXECute]


INSTrument:CREate:DUPLicate

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Controlling the Noise Figure Measurement Channel > INSTrument:CREate:DUPLicate
INSTrument:CREate:DUPLicate

This command duplicates the currently selected measurement channel, i.e starts a new measurement channel of the same type and with the identical measurement settings. The name of the new channel is the same as the copied channel, extended by a consecutive number (e.g. "Spectrum" -> "Spectrum 2").

The channel to be duplicated must be selected first using the INST:SEL command.

(See INSTrument[:​SELect] ).

Example: | INST:SEL 'Spectrum' INST:CRE:DUPL Duplicates the channel named 'Spectrum' and creates a new measurement channel named 'Spectrum 2'.
Usage: | Event


INSTrument:CREate[:NEW]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Controlling the Noise Figure Measurement Channel > INSTrument:CREate[:NEW]
INSTrument:CREate[:NEW] <ChannelType>, <ChannelName>

This command adds an additional measurement channel. The number of measurement channels you can configure at the same time depends on available memory.

Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel. The channel name is displayed as the tab label for the measurement channel.

Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).

Example: INST:CRE SAN, 'Spectrum 2'

Adds an additional spectrum display named "Spectrum 2".

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Programming Example: Performing a Sequence of Measurements" .


INSTrument:CREate:REPLace

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Controlling the Noise Figure Measurement Channel > INSTrument:CREate:REPLace
INSTrument:CREate:REPLace <ChannelName1>,<ChannelType>,<ChannelName2>

This command replaces a measurement channel with another one.

Parameters:
<ChannelName1> | String containing the name of the measurement channel you want to replace.
<ChannelType> | Channel type of the new channel. For a list of available channel types see INSTrument:​LIST?.
<ChannelName2> | String containing the name of the new channel. Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).
Example: | INST:CRE:REPL 'Spectrum2',IQ,'IQAnalyzer' Replaces the channel named 'Spectrum2' by a new measurement channel of type 'IQ Analyzer' named 'IQAnalyzer'.


INSTrument:DELete

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Controlling the Noise Figure Measurement Channel > INSTrument:DELete
INSTrument:DELete <ChannelName>

This command deletes a measurement channel. If you delete the last measurement channel, the default "Spectrum" channel is activated.

Parameters:
<ChannelName> | String containing the name of the channel you want to delete. A measurement channel must exist in order to be able delete it.
Example: | INST:DEL 'Spectrum4' Deletes the spectrum channel with the name 'Spectrum4'.


INSTrument:LIST?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Controlling the Noise Figure Measurement Channel > INSTrument:LIST?
INSTrument:LIST?

This command queries all active measurement channels. This is useful in order to obtain the names of the existing measurement channels, which are required in order to replace or delete the channels.

Return values:
<ChannelType>, <ChannelName> | For each channel, the command returns the channel type and channel name (see tables below). Tip: to change the channel name, use the INSTrument:​REName command.
Example: | INST:LIST? Result for 3 measurement channels: 'ADEM','Analog Demod','IQ','IQ Analyzer','SANALYZER','Spectrum'
Usage: | Query only
Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode
Application | <ChannelType> Parameter | Default Channel Name*)
Spectrum | SANALYZER | Spectrum
I/Q Analyzer | IQ | IQ Analyzer
Pulse (R&S FSW-K6) | PULSE | Pulse
Analog Demodulation (R&S FSW-K7) | ADEM | Analog Demod
GSM (R&S FSW-K10) | GSM | GSM
Multi-Carrier Group Delay (R&S FSW-K17) | MCGD | MC Group Delay
Noise (R&S FSW-K30) | NOISE | Noise
Phase Noise (R&S FSW-K40) | PNOISE | Phase Noise
Transient Analysis (R&S FSW-K60) | TA | Transient Analysis
VSA (R&S FSW-K70) | DDEM | VSA
3GPP FDD BTS (R&S FSW-K72) | BWCD | 3G FDD BTS
3GPP FDD UE (R&S FSW-K73) | MWCD | 3G FDD UE
TD-SCDMA BTS (R&S FSW-K76) | BTDS | TD-SCDMA BTS
TD-SCDMA UE (R&S FSW-K77) | MTDS | TD-SCDMA UE
cdma2000 BTS (R&S FSW-K82) | BC2K | CDMA2000 BTS
cdma2000 MS (R&S FSW-K83) | MC2K | CDMA2000 MS
1xEV-DO BTS (R&S FSW-K84) | BDO | 1xEV-DO BTS
1xEV-DO MS (R&S FSW-K85) | MDO | 1xEV-DO MS
WLAN (R&S FSW-K91) | WLAN | WLAN
LTE (R&S FSW-K10x) | LTE | LTE
Realtime Spectrum (R&S FSW-K160R) | RTIM | Realtime Spectrum
Note: the default channel name is also listed in the table. If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel.


INSTrument:REName

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Controlling the Noise Figure Measurement Channel > INSTrument:REName
INSTrument:REName <ChannelName1>, <ChannelName2>

This command renames a measurement channel.

Parameters:
<ChannelName1> | String containing the name of the channel you want to rename.
<ChannelName2> | String containing the new channel name. Note that you can not assign an existing channel name to a new channel; this will cause an error.
Example: | INST:REN 'Spectrum2','Spectrum3' Renames the channel with the name 'Spectrum2' to 'Spectrum3'.


INSTrument[:SELect]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Controlling the Noise Figure Measurement Channel > INSTrument[:SELect]
INSTrument[:SELect] <Application>

Selects the application (channel type) for the current channel.

See also INSTrument:​CREate[:​NEW].

For a list of available channel types see table "Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode".

Parameters:
<Application>
NOISe

Noise figure measurements, R&S FSW–K30


SYSTem:PRESet:CHANnel[:EXECute]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Controlling the Noise Figure Measurement Channel > SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:CHANnel[:EXECute]

This command restores the default instrument settings in the current channel.

Use INST:SEL to select the channel.

For details see "Factory Default Configuration" .

Example: | INST 'Spectrum2' Selects the channel for "Spectrum2". SYST:PRES:CHAN:EXEC Restores the factory default settings to the "Spectrum2" channel.
Usage: | Event
Manual operation: | See "Preset Channel"


Working with Windows in the Display

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Windows in the Display
Working with Windows in the Display

The following commands are necessary to change the evaluation type and rearrange the screen layout as you do using the SmartGrid in manual operation.

List of Commands
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace


LAYout:ADD[:WINDow]?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Windows in the Display > LAYout:ADD[:WINDow]?
LAYout:ADD[:WINDow]? <WindowName>,<Direction>,<WindowType>

This command adds a window to the display.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

To replace an existing window, use the LAYout:​REPLace[:​WINDow] command.

Parameters:
<WindowName>

String containing the name of the existing window the new window is inserted next to.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<Direction>
LEFT | RIGHt | ABOVe | BELow

Direction the new window is added relative to the existing window.

<WindowType>
text value

Type of result display (evaluation method) you want to add.

See the table below for available parameter values.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:ADD? '1',LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

For a detailed example see "Example 1: Adding and Arranging Windows" and "Example 2: Replacing and Removing Windows" .

Example:

See "Programming Example" .

Usage: Query only
<WindowType> parameter values for Noise Figure application
Parameter value | Window type
GAIN | Gain result display
MTABle | Marker table
NOISe | Noise figure result display
PCOLd | Power cold result display
PHOT | Power hot result display
RESults | Result table
TEMPerature | Noise temperature result display
YFACtor | Y-Factor result display


LAYout:CATalog[:WINDow]?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Windows in the Display > LAYout:CATalog[:WINDow]?
LAYout:CATalog[:WINDow]?

This command queries the name and index of all active windows from top left to bottom right. The result is a comma-separated list of values for each window, with the syntax:

<WindowName_1>,<WindowIndex_1>..<WindowName_n>,<WindowIndex_n>

Return values:
<WindowName>
string

Name of the window.

In the default state, the name of the window is its index.

<WindowIndex>
numeric value

Index of the window.

Example: LAY:CAT?

Result:

'2',2,'1',1

Two windows are displayed, named '2' (at the top or left), and '1' (at the bottom or right).

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:IDENtify[:WINDow]?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Windows in the Display > LAYout:IDENtify[:WINDow]?
LAYout:IDENtify[:WINDow]? <WindowName>

This command queries the index of a particular display window.

Note: to query the name of a particular window, use the LAYout:​WINDow<n>:​IDENtify? query.

Query parameters:
<WindowName> | String containing the name of a window.
Return values:
<WindowIndex> | Index number of the window.
Usage: | Query only


LAYout:REMove[:WINDow]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Windows in the Display > LAYout:REMove[:WINDow]
LAYout:REMove[:WINDow] <WindowName>

This command removes a window from the display.

Parameters:
<WindowName>

String containing the name of the window.

In the default state, the name of the window is its index.

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Event


LAYout:REPLace[:WINDow]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Windows in the Display > LAYout:REPLace[:WINDow]
LAYout:REPLace[:WINDow] <WindowName>,<WindowType>

This command replaces the window type (for example from "Diagram" to "Result Summary") of an already existing window while keeping its position, index and window name.

To add a new window, use the LAYout:​ADD[:​WINDow]? command.

Parameters:
<WindowName>

String containing the name of the existing window.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<WindowType>

Type of result display you want to use in the existing window.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Example: LAY:REPL:WIND '1',MTAB

Replaces the result display in window 1 with a marker table.

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:WINDow<n>:ADD?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Windows in the Display > LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:ADD? <Direction>,<WindowType>

This command adds a measurement window to the display. Note that with this command, the suffix <n> determines the existing window next to which the new window is added, as opposed to LAYout:​ADD[:​WINDow]?, for which the existing window is defined by a parameter.

To replace an existing window, use the LAYout:​WINDow<n>:​REPLace command.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

Parameters:
<Direction>
LEFT | RIGHt | ABOVe | BELow
<WindowType>

Type of measurement window you want to add.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:WIND1:ADD? LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:WINDow<n>:IDENtify?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Windows in the Display > LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:IDENtify?

This command queries the name of a particular display window (indicated by the <n> suffix).

Note: to query the index of a particular window, use the LAYout:​IDENtify[:​WINDow]? command.

Return values:
<WindowName> | String containing the name of a window. In the default state, the name of the window is its index.
Usage: | Query only


LAYout:WINDow<n>:REMove

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Windows in the Display > LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REMove

This command removes the window specified by the suffix <n> from the display.

The result of this command is identical to the LAYout:​REMove[:​WINDow] command.

Usage: Event


LAYout:WINDow<n>:REPLace

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Windows in the Display > LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:REPLace <WindowType>

This command changes the window type of an existing window (specified by the suffix <n>).

The result of this command is identical to the LAYout:​REPLace[:​WINDow] command.

To add a new window, use the LAYout:​WINDow<n>:​ADD? command.

Parameters:
<WindowType>

Type of measurement window you want to replace another one with.

See LAYout:​ADD[:​WINDow]? for a list of available window types.


Measurement Results

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Measurement Results
Measurement Results

The following commands are necessary to query measurement results.

List of Commands
TRACe<n>[:DATA]?


TRACe<n>[:DATA]?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Measurement Results > TRACe<n>[:DATA]?
TRACe<n>[:DATA]? <Trace>, <Result>

This command queries the noise measurement results.

Query parameters:
<Trace> | Selects the trace to be read out. TRACE1 TRACE2 TRACE3 TRACE4
<Result> | Selects the result display to be read out. GAIN Queries gain reuslts. NOISe Queries noise figure results. NUNCertainty Queries noise figure uncertainty results. PCOLd Queries power (cold) results. PHOT Queries power (hot) results. TEMPerature Queries noise temperature results. YFACtor Queries y-factor results.
Return values:
<TraceData> | For any graphical result display, the command returns one result for each measurement point. The unit depends on the result you are querying.
Example: | TRAC? TRACE1,GAIN Queries the gain results for the first trace.
Usage: | Query only
Manual operation: | See "Noise Figure" See "Gain" See "Noise Temperature" See "Y-Factor" See "Power (Hot)" See "Power (Cold)" See "Result Table"


Defining the Measurement Frequency

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Defining the Measurement Frequency
Defining the Measurement Frequency

The following commands are necessary to define the frequency characteristics of the noise figure measurement.

List of Commands
CONFigure:FREQuency:CONTinuous
CONFigure:FREQuency:SINGle
CONFigure:LIST:CONTinuous
CONFigure:LIST:SINGLe
[SENSe:]FREQuency:CENter
[SENSe:]FREQuency:LIST:DATA
[SENSe:]SWEep:POINts
[SENSe:]FREQuency:SINGle
[SENSe:]FREQuency:SINGle:COUPling
[SENSe:]FREQuency:SPAN
[SENSe:]FREQuency:STARt
[SENSe:]FREQuency:STEP
[SENSe:]FREQuency:STOP


CONFigure:FREQuency:CONTinuous

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Defining the Measurement Frequency > CONFigure:FREQuency:CONTinuous
CONFigure:FREQuency:CONTinuous

This command configures the software to perform a single frequency measurement in continuous sweep mode.

Example: | FREQ:SING 20MHz Defines a measurement frequency of 20 MHz. CONF:FREQ:CONT INIT Selects and initiates a single frequency measurement.
Usage: | Event
Manual operation: | See "Tuning Mode"


CONFigure:FREQuency:SINGle

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Defining the Measurement Frequency > CONFigure:FREQuency:SINGle
CONFigure:FREQuency:SINGle

This command configures the software to perform a single frequency measurement in single sweep mode.

Example: | FREQ:SING 20MHz Defines a measurement frequency of 20 MHz. CONF:FREQ:SING INIT Selects and initiates a single frequency measurement.
Usage: | Event
Manual operation: | See "Tuning Mode"


CONFigure:LIST:CONTinuous

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Defining the Measurement Frequency > CONFigure:LIST:CONTinuous
CONFigure:LIST:CONTinuous

This command configures the software to perform a frequency list measurement in continuous sweep mode.

Example: | CONF:LIST:CONT INIT Selects and initiates a frequency list measurement.
Usage: | Event
Manual operation: | See "Tuning Mode"


CONFigure:LIST:SINGLe

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Defining the Measurement Frequency > CONFigure:LIST:SINGLe
CONFigure:LIST:SINGLe

This command configures the software to perform a frequency list measurement in single sweep mode.

Example: | CONF:LIST:SING INIT Selects and initiates a single frequency list measurement.
Usage: | Event
Manual operation: | See "Tuning Mode"


[SENSe:]FREQuency:CENter

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Defining the Measurement Frequency > [SENSe:]FREQuency:CENter
[SENSe:]FREQuency:CENter <Frequency>

This command defines the center frequency.

Parameters:
<Frequency>
Range: | see datasheet
*RST: | fmax/2
Default unit: | Hz
Example: FREQ:CENT 1GHZ

Defines a center frequency of 1 GHz.

Manual operation: See "Center"


[SENSe:]FREQuency:LIST:DATA

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Defining the Measurement Frequency > [SENSe:]FREQuency:LIST:DATA
[SENSe:]FREQuency:LIST:DATA <Frequency>

This command defines the contents of a frequency list.

The command overwrites the current contents of the frequency list. The frequency list remains the same until you generate or create a new list.

Parameters:
<Frequency>

Defines a frequency for each entry in the frequency list. A frequency list can contain up to 500 entries.

Range: 0 Hz to fmax
Example: FREQ:LIST:DATA 100MHZ,200MHZ,300MHZ,400MHZ,500MHZ

Creates a frequency list with five entries.

Manual operation: See "Populate Table"


[SENSe:]SWEep:POINts

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Defining the Measurement Frequency > [SENSe:]SWEep:POINts
[SENSe:]SWEep:POINts <SweepPoints>

This command defines the number of measurement points analyzed during a sweep.

Parameters:
<SweepPoints>
Range: | 1 to 500
*RST: | 20
Example: SWE:POIN 100

Defines 100 measurement points.

Manual operation: See "(Measurement) Points"
See "(Measurement) Points"


[SENSe:]FREQuency:SINGle

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Defining the Measurement Frequency > [SENSe:]FREQuency:SINGle
[SENSe:]FREQuency:SINGle <Frequency>

This command defines the frequency for single frequency measurements.

Parameters:
<Frequency>

The minimum and maximum frequency depend on the hardware. Refer to the datasheet for details.

*RST: 100 MHz
Example: FREQ:SING 200MHZ

Defines a measurement frequency of 200 MHz.

Manual operation: See "Center"
See "Single (Frequency)"


[SENSe:]FREQuency:SINGle:COUPling

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Defining the Measurement Frequency > [SENSe:]FREQuency:SINGle:COUPling
[SENSe:]FREQuency:SINGle:COUPling <State>

This command couples or decouples the frequency to the contents of the sweep list.

Parameters:
<State>
ON

Only frequencies in the frequency list can be selected for single frequency measurements.

OFF

Any frequency can be defined for single frequency measurements.

*RST: OFF
Example: FREQ:SING:COUP ON

Couples single frequency measurements to the frequency list.

Manual operation: See "Coupled to Sweep List"


[SENSe:]FREQuency:SPAN

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Defining the Measurement Frequency > [SENSe:]FREQuency:SPAN
[SENSe:]FREQuency:SPAN <Span>

This command defines the frequency span.

If you change the span, the application creates a new frequency list.

Parameters:
<Span>

This parameter is ....

*RST: RST value
Example: FREQ:SPAN 500MHZ

Defines a span of 500 MHz.

Manual operation: See "Span"


[SENSe:]FREQuency:STARt

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Defining the Measurement Frequency > [SENSe:]FREQuency:STARt
[SENSe:]FREQuency:STARt <Frequency>

This command defines the start frequency.

If you change the start frequency, the application creates a new frequency list.

Parameters:
<Frequency>
*RST: RST value
Example: FREQ:STAR 900MHZ

Defines a start frequency of 900 MHz.

Manual operation: See "Start and Stop Frequency"


[SENSe:]FREQuency:STEP

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Defining the Measurement Frequency > [SENSe:]FREQuency:STEP
[SENSe:]FREQuency:STEP <Stepsize>

This command defines the frequency stepsize in the frequency table.

The stepsize corresponds to the distance from one measurement point to another.

If you change the stepsize, the application creates a new frequency list.

Parameters:
<Stepsize>
Range: | 0 Hz to span
*RST: | 100 MHz
Example: FREQ:STEP 100MHZ

Defines a stepsize of 100 MHz.

Manual operation: See "Step"


[SENSe:]FREQuency:STOP

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Defining the Measurement Frequency > [SENSe:]FREQuency:STOP
[SENSe:]FREQuency:STOP <Frequency>

This command defines the stop frequency.

If you change the stop frequency, the application creates a new frequency list.

Parameters:
<Frequency>
*RST: RST value
Example: FREQ:STOP 900MHZ

Defines a stop frequency of 900 MHz.

Manual operation: See "Start and Stop Frequency"


Selecting DUT Characteristics

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Selecting DUT Characteristics
Selecting DUT Characteristics

The following commands are necessary to define DUT characteristics.

List of Commands
[SENSe:]CONFigure:MODE:SYSTem:IF:FREQuency
[SENSe:]CONFigure:MODE:SYSTem:LO:FREQuency
[SENSe:]CONFigure:MODE:DUT
[SENSe:]CORRection:IREJection


[SENSe:]CONFigure:MODE:SYSTem:IF:FREQuency

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Selecting DUT Characteristics > [SENSe:]CONFigure:MODE:SYSTem:IF:FREQuency
[SENSe:]CONFigure:MODE:SYSTem:IF:FREQuency <Frequency>

This command defines the frequency for DUTs with a fixed IF.

Parameters:
<Frequency>
Range: | 0 Hz to 100 GHz
*RST: | 10 MHz, if frequency converting mode has been selected
Example: CONF:MODE:SYST:IF:FREQ 1GHZ

Defines a fixed IF of 1 GHz.

Manual operation: See "IF Fixed"


[SENSe:]CONFigure:MODE:SYSTem:LO:FREQuency

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Selecting DUT Characteristics > [SENSe:]CONFigure:MODE:SYSTem:LO:FREQuency
[SENSe:]CONFigure:MODE:SYSTem:LO:FREQuency <LOFrequency>

This command defines the frequency for DUTs with a fixed LO.

Parameters:
<LOFrequency>
Range: | 0 Hz to 100 GHz
*RST: | 10 MHz, if frequency converting mode has been selected
Example: CONF:MODE:SYST:LO:FREQ 1GHZ

Defines afixed LO frequency of 1 GHz.

Manual operation: See "LO Fixed"


[SENSe:]CONFigure:MODE:DUT

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Selecting DUT Characteristics > [SENSe:]CONFigure:MODE:DUT
[SENSe:]CONFigure:MODE:DUT <DUTType>

This command selects the type of DUT you are testing.

Parameters:
<DUTType>
AMPLifier

Measurements on fixed frequency DUTs.

DOWNconv

Measurements on down-converting DUTs.

UPConv

Measurements on up-converting DUTs.

*RST: AMPLifier
Example: CONF:MODE:DUT DOWN

Selects the measurement mode for a down-converting DUT.

Manual operation: See "Mode"


[SENSe:]CORRection:IREJection

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Selecting DUT Characteristics > [SENSe:]CORRection:IREJection
[SENSe:]CORRection:IREJection <ImageRejection>

This command defines the image frequency rejection for the DUT.

Parameters:
<ImageRejection>
Range: | 0 to 999.99
*RST: | 999.99
Default unit: | dB
Example:

CORR:IREJ 0

Turns image rejection off.

Manual operation: See "Image Rejection"


Configuring the Noise Source

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Noise Source
Configuring the Noise Source

The following commands are necessary to define the noise source characteristics.

List of Commands
[SENSe:]CORRection:ENR:CALibration:MODE
[SENSe:]CORRection:ENR:CALibration:SPOT
[SENSe:]CORRection:ENR:CALibration:TABLe:SELect
[SENSe:]CORRection:ENR:COMMon
[SENSe:]CORRection:ENR[:MEASurement]:TABLe:DATA
[SENSe:]CORRection:ENR[:MEASurement]:TABLe:DELete
[SENSe:]CORRection:ENR[:MEASurement]:TABLe:SELect
[SENSe:]CORRection:ENR[:MEASurement]:MODE
[SENSe:]CORRection:ENR[:MEASurement]:SPOT
[SENSe:]CORRection:TEMPerature


[SENSe:]CORRection:ENR:CALibration:MODE

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Noise Source > [SENSe:]CORRection:ENR:CALibration:MODE
[SENSe:]CORRection:ENR:CALibration:MODE <Mode>

This command selects the ENR mode for the calibration.

This command is available when you use different noise sources for calibration and measurement ([SENSe:]CORRection:ENR:COMMon OFF).

Parameters:
<Mode>
SPOT

Uses a constant ENR value for all measurement points (see [SENSe:]CORRection:ENR:CALibration:SPOT).

TABLe

Uses the contents of the ENR table.

*RST: SPOT
Example:

CORR:ENR:CAL:MODE SPOT

Uses a constant ENR value for all measurement points.


[SENSe:]CORRection:ENR:CALibration:SPOT

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Noise Source > [SENSe:]CORRection:ENR:CALibration:SPOT
[SENSe:]CORRection:ENR:CALibration:SPOT <ENR>

This command defines the constant ENR for all measurement points during calibration.

This command is available when you use different noise sources for calibration and measurement ([SENSe:]CORRection:ENR:COMMon OFF).

Parameters:
<ENR>
Range: | -999.99 to 999.99
*RST: | 15
Default unit: | dB
Example: CORR:ENR:CAL:MODE SPOT
CORR:ENR:CAL:SPOT 30

Selects constant ENR value mode and defines an ENR of 30 dB for all measurement points.


[SENSe:]CORRection:ENR:CALibration:TABLe:SELect

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Noise Source > [SENSe:]CORRection:ENR:CALibration:TABLe:SELect
[SENSe:]CORRection:ENR:CALibration:TABLe:SELect <TableName>

This command selects an ENR table for calibration.

Note that the contents of the table are independent of whether you use it for calibration or the actual measurement. Thus, use [SENSe:]CORRection:ENR[:MEASurement]:TABLe:DATA to define the contents of an ENR table.

This command is available when you use different noise sources for calibration and measurement ([SENSe:]CORRection:ENR:COMMon OFF).

Parameters:
<TableName> | String containing the table name.
Example: | CORR:ENR:MEAS:TABL:SEL 'ENRTable' Selects a table called 'ENRTable'.


[SENSe:]CORRection:ENR:COMMon

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Noise Source > [SENSe:]CORRection:ENR:COMMon
[SENSe:]CORRection:ENR:COMMon <State>

This command turns the use of a common ENR on or off.

For more information see "Common ENR".

Parameters:
<State> | ON | OFF
Example: | CORR:ENR:COMM ON Turns the use of a common ENR on.
Manual operation: | See "Common ENR"


[SENSe:]CORRection:ENR[:MEASurement]:TABLe:DATA

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Noise Source > [SENSe:]CORRection:ENR[:MEASurement]:TABLe:DATA
[SENSe:]CORRection:ENR[:MEASurement]:TABLe:DATA <Frequency>, <ENR>

This command defines the contents of the currently selected ENR table.

The ENR table should contain an ENR for all measurement points.

If you create a new table with this command, it will overwrite the current entries of the frequency list.

Parameters:
<Frequency>, <ENR> | Each entry of the ENR table consists of one measurement point and the corresponding ENR. The table can contain up to 500 entries. <Frequency> Frequency of the measurement point. The range is from 0 Hz to 999.99 GHz. <ENR> ENR of the measurement point. The range is from -999.99 dB to 999.99 dB.
Example: | CORR:ENR:MEAS:TABL:DATA 1MHZ,10,2MHZ,12 Defines a new ENR table with two measurement points.
Manual operation: | See "New" See "Edit" See "Edit Table"


[SENSe:]CORRection:ENR[:MEASurement]:TABLe:DELete

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Noise Source > [SENSe:]CORRection:ENR[:MEASurement]:TABLe:DELete
[SENSe:]CORRection:ENR[:MEASurement]:TABLe:DELete <TableName>

This command deletes an ENR table.

Parameters:
<TableName> | String containing the name of the table.
Example: | CORR:ENR:MEAS:TABL:DEL 'ENRTable' Deletes the table with the name 'ENRTable'.
Usage: | Event
Manual operation: | See "Delete"


[SENSe:]CORRection:ENR[:MEASurement]:TABLe:SELect

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Noise Source > [SENSe:]CORRection:ENR[:MEASurement]:TABLe:SELect
[SENSe:]CORRection:ENR[:MEASurement]:TABLe:SELect <TableName>

This command selects an ENR table for the actual measurement.

Parameters:
<TableName> | String containing the table name.
Example: | CORR:ENR:MEAS:TABL:SEL 'ENRTable' Selects a table called 'ENRTable'.
Manual operation: | See "Measurement"


[SENSe:]CORRection:ENR[:MEASurement]:MODE

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Noise Source > [SENSe:]CORRection:ENR[:MEASurement]:MODE
[SENSe:]CORRection:ENR[:MEASurement]:MODE <Mode>

This command selects the ENR mode for the actual measurement.

Parameters:
<Mode>
SPOT

Uses a constant ENR value for all measurement points (see [SENSe:]CORRection:ENR[:MEASurement]:SPOT).

TABLe

Uses the contents of the ENR table.

*RST: SPOT
Example:

CORR:ENR:MODE SPOT

Uses a constant ENR value for all measurement points.

Manual operation: See "Measurement"


[SENSe:]CORRection:ENR[:MEASurement]:SPOT

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Noise Source > [SENSe:]CORRection:ENR[:MEASurement]:SPOT
[SENSe:]CORRection:ENR[:MEASurement]:SPOT <ENR>

This command defines the constant ENR for all measurement points during the actual measurement.

Parameters:
<ENR>
Range: | -999.99 to 999.99
*RST: | 15
Default unit: | dB
Example: CORR:ENR:MODE SPOT
CORR:ENR:SPOT 30

Selects constant ENR value mode and defines an ENR of 30 dB for all measurement points.

Manual operation: See "Measurement"


[SENSe:]CORRection:TEMPerature

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Noise Source > [SENSe:]CORRection:TEMPerature
[SENSe:]CORRection:TEMPerature <Temperature>

This command defines the room temperature of the measurement environment. The temperature is taken into account when calculating noise results.

Parameters:
<Temperature>
Range: | 278.15 to 318.15
*RST: | 293
Default unit: | K
Example: CORR:TEMP 291.50

Specifies a room temperature of 291.50 Kelvin (18.5 C).

Manual operation: See "Temperature"


Configuring Additional Loss

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring Additional Loss
Configuring Additional Loss

The following commands are necessary to define loss resulting from equipment in the measurement setup.

List of Commands
[SENSe:]CORRection:LOSS:INPut:MODE
[SENSe:]CORRection:LOSS:INPut:SPOT
[SENSe:]CORRection:LOSS:INPut:TABLe
[SENSe:]CORRection:LOSS:INPut:TABLe:DELete
[SENSe:]CORRection:LOSS:INPut:TABLe:SELect
[SENSe:]CORRection:LOSS:OUTPut:MODE
[SENSe:]CORRection:LOSS:OUTPut:SPOT
[SENSe:]CORRection:LOSS:OUTPut:TABLe
[SENSe:]CORRection:LOSS:OUTPut:TABLe:DELete
[SENSe:]CORRection:LOSS:OUTPut:TABLe:SELect


[SENSe:]CORRection:LOSS:INPut:MODE

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring Additional Loss > [SENSe:]CORRection:LOSS:INPut:MODE
[SENSe:]CORRection:LOSS:INPut:MODE <Mode>

This command selects the input loss mode.

Parameters:
<Mode>
SPOT

Uses a constant input loss value for all measurement points (see [SENSe:​]CORRection:​LOSS:​INPut:​SPOT).

TABLe

Uses the contents of the input loss table.

*RST: SPOT
Example:

CORR:LOSS:INP:MODE SPOT

Selects constant input loss.

Manual operation: See "Input Loss"


[SENSe:]CORRection:LOSS:INPut:SPOT

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring Additional Loss > [SENSe:]CORRection:LOSS:INPut:SPOT
[SENSe:]CORRection:LOSS:INPut:SPOT <Loss>

This command defines a constant input loss for all measurement points.

Parameters:
<Loss>
Range: | -999.99 to 999.99
*RST: | 0 dB
Default unit: | dB
Example: CORR:LOSS:INP:MODE SPOT
CORR:LOSS:INP:SPOT 10

Selects constant input loss mode and defines an input loss of 10 dB for all measurement points.

Manual operation: See "Input Loss"


[SENSe:]CORRection:LOSS:INPut:TABLe

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring Additional Loss > [SENSe:]CORRection:LOSS:INPut:TABLe
[SENSe:]CORRection:LOSS:INPut:TABLe <Frequency>, <Loss>

This command defines the contents of the currently selected input loss table.

The table should contain an input loss for all measurement points.

If you create a new table with this command, it will overwrite the current entries of the loss table.

Parameters:
<Frequency>, <ENR> | Each entry of the loss table consists of one measurement point and the corresponding loss. The table can contain up to 500 entries. <Frequency> Frequency of the measurement point. The range is from 0 Hz to 999.99 GHz. <Loss> Loss of the measurement point. The range is from -999.99 dB to 999.99 dB.
Example: | CORR:LOSS:INP:TABL 1MHz,10,2MHz,12 Defines a new input loss table with two measurement points.
Manual operation: | See "Edit Table" See "New" See "Edit"


[SENSe:]CORRection:LOSS:INPut:TABLe:DELete

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring Additional Loss > [SENSe:]CORRection:LOSS:INPut:TABLe:DELete
[SENSe:]CORRection:LOSS:INPut:TABLe:DELete <TableName>

This command deletes an input loss table.

Parameters:
<TableName> | String containing the name of the table.
Example: | CORR:LOSS:INP:TABL:DEL 'InputLoss' Deletes the table with the name 'InputLoss'.
Manual operation: | See "Delete"


[SENSe:]CORRection:LOSS:INPut:TABLe:SELect

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring Additional Loss > [SENSe:]CORRection:LOSS:INPut:TABLe:SELect
[SENSe:]CORRection:LOSS:INPut:TABLe:SELect <TableName>

This command selects an input loss table.

Parameters:
<TableName> | String containing the table name.
Example: | CORR:LOSS:INP:TABL:SEL 'InputLoss' Selects a table called 'InputLoss'.
Manual operation: | See "Input Loss"


[SENSe:]CORRection:LOSS:OUTPut:MODE

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring Additional Loss > [SENSe:]CORRection:LOSS:OUTPut:MODE
[SENSe:]CORRection:LOSS:OUTPut:MODE <Mode>

This command selects the output loss mode.

Parameters:
<Mode>
SPOT

Uses a constant output loss value for all measurement points (see [SENSe:​]CORRection:​LOSS:​OUTPut:​SPOT).

TABLe

Uses the contents of the output loss table.

*RST: SPOT
Example:

CORR:LOSS:OUTP:MODE SPOT

Selects constant output loss.

Manual operation: See "Output Loss"


[SENSe:]CORRection:LOSS:OUTPut:SPOT

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring Additional Loss > [SENSe:]CORRection:LOSS:OUTPut:SPOT
[SENSe:]CORRection:LOSS:OUTPut:SPOT <Loss>

This command defines a constant output loss for all measurement points.

Parameters:
<Loss>
Range: | -999.99 to 999.99
*RST: | 0 dB
Default unit: | dB
Example: CORR:LOSS:OUTP:MODE SPOT
CORR:LOSS:OUTP:SPOT 10

Selects constant output loss mode and defines an output loss of 10 dB for all measurement points.

Manual operation: See "Output Loss"


[SENSe:]CORRection:LOSS:OUTPut:TABLe

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring Additional Loss > [SENSe:]CORRection:LOSS:OUTPut:TABLe
[SENSe:]CORRection:LOSS:OUTPut:TABLe <Frequency>, <Loss>

This command defines the contents of the currently selected output loss table.

The table should contain an output loss for all measurement points.

If you create a new table with this command, it will overwrite the current entries of the frequency list.

Parameters:
<Frequency>, <ENR> | Each entry of the loss table consists of one measurement point and the corresponding loss. The table can contain up to 500 entries. <Frequency> Frequency of the measurement point. The range is from 0 Hz to 999.99 GHz. <Loss> Loss of the measurement point. The range is from -999.99 dB to 999.99 dB.
Example: | CORR:LOSS:OUTP:TABL 1MHz,10,2MHz,12 Defines a new output loss table with two measurement points.
Manual operation: | See "Edit Table" See "New" See "Edit"


[SENSe:]CORRection:LOSS:OUTPut:TABLe:DELete

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring Additional Loss > [SENSe:]CORRection:LOSS:OUTPut:TABLe:DELete
[SENSe:]CORRection:LOSS:OUTPut:TABLe:DELete <TableName>

This command deletes an output loss table.

Parameters:
<TableName> | String containing the name of the table.
Example: | CORR:LOSS:OUTP:TABL:DEL 'OutputLoss' Deletes the table with the name 'OutputLoss'.
Manual operation: | See "Delete"


[SENSe:]CORRection:LOSS:OUTPut:TABLe:SELect

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring Additional Loss > [SENSe:]CORRection:LOSS:OUTPut:TABLe:SELect
[SENSe:]CORRection:LOSS:OUTPut:TABLe:SELect <TableName>

This command selects an output loss table.

Parameters:
<TableName> | String containing the table name.
Example: | CORR:LOSS:OUTP:TABL:SEL 'OutputLoss' Selects a table called 'OutputLoss'.
Manual operation: | See "Output Loss"


Configuring the Analyzer

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Analyzer
Configuring the Analyzer

The following commands are necessary to configure the analyzer.

List of Commands
CONFigure:CORRection
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:RLEVel:AUTO
INPut:ATTenuation
INPut:GAIN[:VALue]
INPut:GAIN:STATe
[SENSe:]BANDwidth|BWIDth[:RESolution]
[SENSe:]CORRection[:STATe]
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:TIME
SYSTem:CONFigure:DUT:GAIN
SYSTem:CONFigure:DUT:STIMe


CONFigure:CORRection

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Analyzer > CONFigure:CORRection
CONFigure:CORRection

This command configures the software to perform a calibration measurement.

If you initate a measurement with INITiate[:​IMMediate], the software initates a calibration instead of the actual measurement.

Example: | CONF:CORR Configures to run calibration. INIT Initiates the calibration.
Usage: | Event
Manual operation: | See "2nd Stage Correction" See "Calibrate"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Analyzer > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel <ReferenceLevel>

This command defines the reference level.

Parameters:
<ReferenceLevel>
Range: | see datasheet
*RST: | -30 dBm
Default unit: | dBm
Example: DISP:TRAC:Y:RLEV -60dBm
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Ref Level"


DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:RLEVel:AUTO

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Analyzer > DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:RLEVel:AUTO
DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:RLEVel:AUTO <State>

This command turns automatic determination of the reference level on and off.

Parameters:
<State> | ON | OFF
Example: | DISP:TRAC:Y:RLEV:AUTO ON Turns on automatic level detection.
Usage: | SCPI confirmed
Manual operation: | See "Ref Level"


INPut:ATTenuation

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Analyzer > INPut:ATTenuation
INPut:ATTenuation <Attenuation>

This command defines the total attenuation for RF input.

If you set the attenuation manually, it is no longer coupled to the reference level, but the reference level is coupled to the attenuation. Thus, if the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

Parameters:
<Attenuation>
Range: | see data sheet
Increment: | 5 dB
*RST: | 10 dB (AUTO is set to ON)
Example: INP:ATT 30dB

Defines a 30 dB attenuation and decouples the attenuation from the reference level.

Usage: SCPI confirmed
Manual operation: See "RF Attenuation"


INPut:GAIN[:VALue]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Analyzer > INPut:GAIN[:VALue]
INPut:GAIN[:VALue] <Gain>

This command selects the preamplification level if the preamplifier is activated (INP:GAIN:STAT ON, see INPut:​GAIN:​STATe).

The command requires option R&S FSW-B24.

Parameters:
<Gain>
15 dB | 30 dB

The availability of preamplification levels depends on the R&S FSW model.

R&S FSW8/13: 15dB and 30 dB

R&S FSW26 or higher: 30 dB

All other values are rounded to the nearest of these two.

*RST: OFF
Example: INP:GAIN:VAL 30

Switches on 30 dB preamplification.

Usage: SCPI confirmed


INPut:GAIN:STATe

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Analyzer > INPut:GAIN:STATe
INPut:GAIN:STATe <State>

This command turns the preamplifier on and off.

The command requires option R&S FSW-B24.

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the preamplification is defined by INPut:​GAIN[:​VALue].

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:GAIN:STAT ON

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier"


[SENSe:]BANDwidth|BWIDth[:RESolution]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Analyzer > [SENSe:]BANDwidth|BWIDth[:RESolution]
[SENSe:]BANDwidth|BWIDth[:RESolution] <Bandwidth>

This command defines the resolution bandwidth and decouples the resolution bandwidth from the span.

Example: BAND 1 MHz

Sets the resolution bandwidth to 1 MHz

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Resolution Bandwidth (RBW)"


[SENSe:]CORRection[:STATe]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Analyzer > [SENSe:]CORRection[:STATe]
[SENSe:]CORRection[:STATe] <State>

This command includes or excludes calibration data in the actual measurement.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

CORR ON

Includes calibration data in the measurement.


[SENSe:]SWEep:COUNt

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Analyzer > [SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt <Averages>

This command defines the number of measurements that are used to average the results.

Parameters:
<Averages>

Number of measurements that are performed at a single frequency before average results are displayed.

If you set an average of 0 or 1, the application performs a single measurement at each frequency.

Range: | 0 to 32767
*RST: | 1
Example: SWE:COUN 10

The application averages 10 measurements before it displays the results.

Manual operation: See "Average"


[SENSe:]SWEep:TIME

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Analyzer > [SENSe:]SWEep:TIME
[SENSe:]SWEep:TIME <Time>

This command defines the sweep (or: data capture) time.

Parameters:
<Time>
refer to data sheet
*RST: depends on current settings (determined automatically)
Example: SWE:TIME 10s
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Sweep Time"


SYSTem:CONFigure:DUT:GAIN

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Analyzer > SYSTem:CONFigure:DUT:GAIN
SYSTem:CONFigure:DUT:GAIN <Gain>

This command defines the expected gain of the DUT.

The application uses the gain for automatic reference level detection.

Parameters:
<Gain>
Range: | 10 to 1000
*RST: | 30
Default unit: | dB
Example: SYST:CONF:DUT:GAIN 25

Defines gain of 25 dB.

Manual operation: See "Auto Level Range"


SYSTem:CONFigure:DUT:STIMe

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Analyzer > SYSTem:CONFigure:DUT:STIMe
SYSTem:CONFigure:DUT:STIMe <SettlingTime>

This command defines the settling time of the noise source.

Parameters:
<SettlingTime>
Range: | 0 s to 20 s
*RST: | 50 ms
Example: SYST:CONF:DUT:STIM 1 s

Defines a settling time of 1 second.

Manual operation: See "Settling Time"


Using the Uncertainty Calculator

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator
Using the Uncertainty Calculator

The following commands are necessary to work with the measurement uncertainty calculator.

List of Commands
CALCulate:UNCertainty:COMMon
CALCulate:UNCertainty:DATA:FREQuency
CALCulate:UNCertainty:DATA:GAIN
CALCulate:UNCertainty:DATA:NOISe
CALCulate:UNCertainty:DATA:RESults
CALCulate:UNCertainty:ENR:CALibration:UNCertainty
CALCulate:UNCertainty:ENR:UNCertainty
CALCulate:UNCertainty:MATCh:DUT:IN:RL
CALCulate:UNCertainty:MATCh:DUT:IN:[VSWR]
CALCulate:UNCertainty:MATCh:DUT:OUT:RL
CALCulate:UNCertainty:MATCh:DUT:OUT:[VSWR]
CALCulate:UNCertainty:MATCh:PREamp:RL
CALCulate:UNCertainty:MATCh:PREamp[:VSWR]
CALCulate:UNCertainty:MATCh:SOURce:CALibration[:VSWR]
CALCulate:UNCertainty:MATCh:SOURce:CALibration:RL
CALCulate:UNCertainty:MATCh:SOURce:RL
CALCulate:UNCertainty:MATCh:SOURce[:VSWR]
CALCulate:UNCertainty:PREamp:GAIN
CALCulate:UNCertainty:PREamp:NOISe
CALCulate:UNCertainty:PREamp:STATe
CALCulate:UNCertainty[:RESult]?
CALCulate:UNCertainty:SANalyzer:GAIN:UNCertainty?
CALCulate:UNCertainty:SANalyzer:NOISe:UNCertainty?


CALCulate:UNCertainty:COMMon

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:COMMon
CALCulate:UNCertainty:COMMon <State>

This command turns matching of the noise source characteristics used during calibration and measurement on and off.

This command is available when you use different noise sources for calibration and measurement ([SENSe:]CORRection:ENR:COMMon OFF).

Parameters:
<State>
ON | OFF
*RST: unavailable
Example: CALC:UNC:COMM ON

Applies the values of the calibration noise source to those of the measurement noise source.

Manual operation: See "Common Source for Meas and Cal"


CALCulate:UNCertainty:DATA:FREQuency

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:DATA:FREQuency
CALCulate:UNCertainty:DATA:FREQuency <Frequency>

This command defines the frequency for which the uncertainty should be calculated.

This command is available if you have turned automatic determination of the DUT characteristics off with CALCulate:​UNCertainty:​DATA:​RESults.

Parameters:
<Frequency>

Frequency of the DUT.

*RST: 1 GHz
Example: CALC:UNC:DATA:FREQ 100MHZ

Defines a frequency of 100 MHz.

Manual operation: See "Use Measurement Values"


CALCulate:UNCertainty:DATA:GAIN

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:DATA:GAIN
CALCulate:UNCertainty:DATA:GAIN <Gain>

This command defines the gain of the DUT.

This command is available if you have turned automatic determination of the DUT characteristics off with CALCulate:​UNCertainty:​DATA:​RESults.

Parameters:
<Gain>

Gain of the DUT.

*RST: 0 dB
Example: CALC:UNC:DATA:GAIN -5DB

Defines a DUT gain of -5 dB.

Manual operation: See "Use Measurement Values"


CALCulate:UNCertainty:DATA:NOISe

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:DATA:NOISe
CALCulate:UNCertainty:DATA:NOISe <NoiseLevel>

This command defines the noise level of the DUT.

This command is available if you have turned automatic determination of the DUT characteristics off with CALCulate:​UNCertainty:​DATA:​RESults.

Parameters:
<NoiseLevel>

Noise level of the DUT.

*RST: 0 dB
Example: CALC:UNC:DATA:NOIS 10DB

Defines a DUT noise level of 10 dB.

Manual operation: See "Use Measurement Values"


CALCulate:UNCertainty:DATA:RESults

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:DATA:RESults
CALCulate:UNCertainty:DATA:RESults <State>

This command turns automatic determination of the DUT characteristics for the calculation of the uncertainty on and off.

Parameters:
<State>
ON

The application calculates the uncertainty with the DUT characteristics (noise figure, gain and frequency) resulting from the noise figure measurement.

OFF

The application calculates the uncertainty with the DUT characteristics (noise figure, gain and frequency) based on the values you have defined manually.

Example: CALC:UNC:DATA:RES ON

Includes the uncertainty in the results displays.

Manual operation: See "Use Measurement Values"


CALCulate:UNCertainty:ENR:CALibration:UNCertainty

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:ENR:CALibration:UNCertainty
CALCulate:UNCertainty:ENR:CALibration:UNCertainty <Uncertainty>

This command defines the uncertainty of a calibration noise source.

This command is available when [SENSe:]CORRection:ENR:COMMon and CALCulate:UNCertainty:COMMon are off.

Parameters:
<Uncertainty>

Uncertainty value of the noise source.

Refer to the data sheet of the noise source to determine its uncertainty.

*RST: 0.1 dB
Example: CALC:UNC:ENR:CAL:UNC 0.05

Defines an uncertainty of 0.05 dB.

Manual operation: See "ENR Uncert(ainty)"


CALCulate:UNCertainty:ENR:UNCertainty

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:ENR:UNCertainty
CALCulate:UNCertainty:ENR:UNCertainty <Uncertainty>

This command defines the uncertainty of a noise source.

If the noise sources during calibration and measurement are different, the command defines the uncertainty of the measurement noise source.

Parameters:
<Uncertainty>

Uncertainty value of the noise source.

Refer to the data sheet of the noise source to determine its uncertainty.

*RST: 0.1 dB
Example: CALC:UNC:ENR:UNC 0.05

Defines an uncertainty of 0.05 dB.

Manual operation: See "ENR Uncert(ainty)"


CALCulate:UNCertainty:MATCh:DUT:IN:RL

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:MATCh:DUT:IN:RL
CALCulate:UNCertainty:MATCh:DUT:IN:RL <ReturnLoss>

This command defines the return loss at the DUT input.

Parameters:
<ReturnLoss>
*RST: 50.0 dB
Example: CALC:UNC:MATC:DUT:IN:RL 25DB

Defines a return loss of 25 dB.

Manual operation: See "Input / Output Match"


CALCulate:UNCertainty:MATCh:DUT:IN:[VSWR]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:MATCh:DUT:IN:[VSWR]
CALCulate:UNCertainty:MATCh:DUT:IN:[VSWR] <VSWR>

This command defines the VSWR at the DUT input.

Parameters:
<VSWR>
*RST: 1.0
Example: CALC:UNC:MATC:DUT:IN 1.1

Defines a VSWR of 1.1 at the DUT input.

Manual operation: See "Input / Output Match"


CALCulate:UNCertainty:MATCh:DUT:OUT:RL

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:MATCh:DUT:OUT:RL
CALCulate:UNCertainty:MATCh:DUT:OUT:RL <ReturnLoss>

This command defines the returns loss at the DUT output.

Parameters:
<ReturnLoss>
*RST: 50.0 dB
Example: CALC:UNC:MATC:DUT:OUT:RL 40DB

Defines a return loss of 40 dB at the DUT output.

Manual operation: See "Input / Output Match"


CALCulate:UNCertainty:MATCh:DUT:OUT:[VSWR]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:MATCh:DUT:OUT:[VSWR]
CALCulate:UNCertainty:MATCh:DUT:OUT:[VSWR] <VSWR>

This command defines the VSWR at the DUT output.

Parameters:
<VSWR>
*RST: 1.0
Example: CALC:UNC:MATC:DUT:OUT 2.0

Defines a VSWR of 2.0 at the DUT output.

Manual operation: See "Input / Output Match"


CALCulate:UNCertainty:MATCh:PREamp:RL

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:MATCh:PREamp:RL
CALCulate:UNCertainty:MATCh:PREamp:RL <ReturnLoss>

This command defines the return loss at the input of the preamplifier.

Parameters:
<ReturnLoss>
*RST: 13.98 dB
Example: CALC:UNC:MATC:PRE:RL 14.5DB

Defines a return loss of 14.5 dB.


CALCulate:UNCertainty:MATCh:PREamp[:VSWR]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:MATCh:PREamp[:VSWR]
CALCulate:UNCertainty:MATCh:PREamp[:VSWR] <VSWR>

This command defines the VSWR at the input of the preamplifier.

The command is available if you have turned on the preamplifier with CALCulate:​UNCertainty:​PREamp:​STATe.

Parameters:
<VSWR>
*RST: 1.5
Example: CALC:UNC:MATC:PRE 1.8

Defines a VSWR of 1.8.


CALCulate:UNCertainty:MATCh:SOURce:CALibration[:VSWR]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:MATCh:SOURce:CALibration[:VSWR]
CALCulate:UNCertainty:MATCh:SOURce:CALibration[:VSWR] <VSWR>

This command defines the VSWR at the calibration noise source output.

This command is available when [SENSe:]CORRection:ENR:COMMon and CALCulate:UNCertainty:COMMon are off.

Parameters:
<VSWR>
*RST: 1.15
Example: CALC:UNC:MATC:SOUR:CAL 1.4

Defines a VSWR of 1.4.

Manual operation: See "Output Match"


CALCulate:UNCertainty:MATCh:SOURce:CALibration:RL

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:MATCh:SOURce:CALibration:RL
CALCulate:UNCertainty:MATCh:SOURce:CALibration:RL <ReturnLoss>

This command defines the return loss at the calibration noise source output.

This command is available when [SENSe:]CORRection:ENR:COMMon and CALCulate:UNCertainty:COMMon are off.

Parameters:
<ReturnLoss>
*RST: 23.13 dB
Example: CALC:UNC:MATC:SOUR:CAL:RL 20DB

Defines a return loss of 20 dB.

Manual operation: See "Output Match"


CALCulate:UNCertainty:MATCh:SOURce:RL

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:MATCh:SOURce:RL
CALCulate:UNCertainty:MATCh:SOURce:RL <ReturnLoss>

This command defines the return loss at the noise source output.

If the noise sources during calibration and measurement are different, the command defines the uncertainty of the measurement noise source.

Parameters:
<ReturnLoss>
*RST: 23.13 dB
Example: CALC:UNC:MATC:SOUR:RL 20DB

Defines a return loss of 20 dB.

Manual operation: See "Output Match"


CALCulate:UNCertainty:MATCh:SOURce[:VSWR]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:MATCh:SOURce[:VSWR]
CALCulate:UNCertainty:MATCh:SOURce[:VSWR] <VSWR>

This command defines the VSWR at the noise source output.

If the noise sources during calibration and measurement are different, the command defines the uncertainty of the measurement noise source.

Parameters:
<VSWR>
*RST: 1.15
Example: CALC:UNC:MATC:SOUR 1.4

Defines a VSWR of 1.4.

Manual operation: See "Output Match"


CALCulate:UNCertainty:PREamp:GAIN

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:PREamp:GAIN
CALCulate:UNCertainty:PREamp:GAIN <Gain>

This command define the gain of an external preamplifier that may be part of the test setup.

Parameters:
<Gain>
Gain of the preamplifier.

Refer to the data sheet of the preamplifier to determine its gain.

*RST: 20 dB
Example: CALC:UNC:PRE:GAIN 15DB

Defines a gain of 15 dB.


CALCulate:UNCertainty:PREamp:NOISe

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:PREamp:NOISe
CALCulate:UNCertainty:PREamp:NOISe <NoiseLevel>

This command defines the noise level of an external preamplifier that may be part of the test setup.

Parameters:
<NoiseLevel>

Noise level of the preamplifier.

Refer to the data sheet of the preamplfier to determine its noise level.

*RST: 5 dB
Example: CALC:UNC:PRE:NOIS 10DB

Defines a noise level of 10 dB.


CALCulate:UNCertainty:PREamp:STATe

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:PREamp:STATe
CALCulate:UNCertainty:PREamp:STATe <State>

This command includes or excludes an external preamplifier from the uncertainty calculation.

If the test setup uses an external preamplifier, you also have to define its noise figure and gain values.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:UNC:PRE:STAT ON

Turns the preamplifier on.


CALCulate:UNCertainty[:RESult]?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty[:RESult]?
CALCulate:UNCertainty[:RESult]?

This command queries the uncertainty of noise figure results.

Return values:
<Uncertainty> | Measurement uncertainty in dB.
Example: | CALC:UNC? Queries the uncertainty.
Usage: | Query only


CALCulate:UNCertainty:SANalyzer:GAIN:UNCertainty?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:SANalyzer:GAIN:UNCertainty?
CALCulate:UNCertainty:SANalyzer:GAIN:UNCertainty?

This command queries the uncertainty value of the spectrum analyzer's internal gain.

Return values:
<Uncertainty> | Gain uncertainty of the spectrum analyzer in dB.
Example: | CALC:UNC:SAN:GAIN:UNC? Queries the gain uncertainty.
Usage: | Query only


CALCulate:UNCertainty:SANalyzer:NOISe:UNCertainty?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Uncertainty Calculator > CALCulate:UNCertainty:SANalyzer:NOISe:UNCertainty?
CALCulate:UNCertainty:SANalyzer:NOISe:UNCertainty?

This command queries the uncertainty value of the spectrum analyzer's internal noise.

Return values:
<Uncertainty> | Noise figure uncertainty of the spectrum analyzer in dB.
Example: | CALC:UNC:SAN:NOIS:UNC? Queries the noise figure uncertainty.
Usage: | Query only


Performing Measurements

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Performing Measurements
Performing Measurements

The following commands are necessary to perform noise figure measurements.

Example: perform calibration and subsequent single sweep measurement
//Perform calibration:
CONF:CORR
INIT;*OPC?
//Perform single sweep measurement and use 2nd stage correction:
CORR:STAT ON
CONF:LIST:SING
INIT

You can also perform a sequence of measurements using the Sequencer (see "Multiple Measurement Channels and Sequencer Function").

List of Commands
ABORt
INITiate:CONTinuous
INITiate[:IMMediate]
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
SYSTem:SEQuencer


ABORt

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Performing Measurements > ABORt
ABORt

This command aborts a current measurement and resets the trigger system.

To prevent overlapping execution of the subsequent command before the measurement has been aborted successfully, use the *OPC? or *WAI command after ABOR and before the next command.

For details see "Preventing Overlapping Execution" .

To abort a sequence of measurements by the Sequencer, use the INITiate:​SEQuencer:​ABORt command.

Note on blocked remote control programs:

If a sequential command cannot be completed, for example because a triggered sweep never receives a trigger, the remote control program will never finish and the remote channel to the R&S FSW is blocked for further commands. In this case, you must interrupt processing on the remote channel first in order to abort the measurement.

To do so, send a "Device Clear" command from the control instrument to the R&S FSW on a parallel channel to clear all currently active remote channels. Depending on the used interface and protocol, send the following commands:

  • Visa: viClear()
  • GPIB: ibclr()
  • RSIB: RSDLLibclr()

Now you can send the ABORt command on the remote channel performing the measurement.

Example: | ABOR;:INIT:IMM Aborts the current measurement and immediately starts a new one.
Example: | ABOR;*WAI INIT:IMM Aborts the current measurement and starts a new one once abortion has been completed.
Usage: | SCPI confirmed


INITiate:CONTinuous

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Performing Measurements > INITiate:CONTinuous
INITiate:CONTinuous <State>

This command controls the sweep mode.

Note that in single sweep mode, you can synchronize to the end of the measurement with *OPC, *OPC? or *WAI. In continuous sweep mode, synchronization to the end of the measurement is not possible. Thus, it is not recommended that you use continuous sweep mode in remote control, as results like trace data or markers are only valid after a single sweep end synchronization.

For details on synchronization see "Command Sequence and Synchronization"

If the sweep mode is changed for a measurement channel while the Sequencer is active (see INITiate:​SEQuencer:​IMMediate) the mode is only considered the next time the measurement in that channel is activated by the Sequencer.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Continuous sweep

OFF | 0

Single sweep

*RST: 1
Example: INIT:CONT OFF

Switches the sweep mode to single sweep.

INIT:CONT ON

Switches the sweep mode to continuous sweep.

Manual operation: See "Continuous Sweep/RUN CONT"


INITiate[:IMMediate]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Performing Measurements > INITiate[:IMMediate]
INITiate[:IMMediate]

This command starts a (single) new measurement.

You can synchronize to the end of the measurement with *OPC, *OPC? or *WAI.

For details on synchronization see "Command Sequence and Synchronization"

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Single Sweep/ RUN SINGLE"
See "Calibrate"


INITiate:SEQuencer:ABORt

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Performing Measurements > INITiate:SEQuencer:ABORt
INITiate:SEQuencer:ABORt

This command stops the currently active sequence of measurements. The Sequencer itself is not deactivated, so you can start a new sequence immediately using INITiate:​SEQuencer:​IMMediate.

To deactivate the Sequencer use SYSTem:​SEQuencer.

Usage: Event


INITiate:SEQuencer:IMMediate

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Performing Measurements > INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:IMMediate

This command starts a new sequence of measurements by the Sequencer. Its effect is similar to the INITiate[:​IMMediate] command used for a single measurement.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: Event


INITiate:SEQuencer:MODE

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Performing Measurements > INITiate:SEQuencer:MODE
INITiate:SEQuencer:MODE <Mode>

This command selects the way the R&S FSW application performs measurements sequentially.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Note: In order to synchronize to the end of a sequential measurement using *OPC, *OPC? or *WAI you must use SINGle Sequence mode.

For details on the Sequencer see "The Sequencer Concept" .

For details on synchronization see "Command Sequence and Synchronization"

Parameters:
<Mode>
SINGle

Each measurement is performed once (regardless of the channel's sweep mode), considering each channels' sweep count, until all measurements in all active channels have been performed.

CONTinuous

The measurements in each active channel are performed one after the other, repeatedly (regardless of the channel's sweep mode), in the same order, until the Sequencer is stopped.

CDEFined

First, a single sequence is performed. Then, only those channels in continuous sweep mode (INIT:CONT ON) are repeated.

*RST: CONTinuous
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .


SYSTem:SEQuencer

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Performing Measurements > SYSTem:SEQuencer
SYSTem:SEQuencer <State>

This command turns the Sequencer on and off. The Sequencer must be active before any other Sequencer commands (INIT:SEQ...) are executed, otherwise an error will occur.

For details on the Sequencer see "The Sequencer Concept" .

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The Sequencer is activated and a sequential measurement is started immediately.

OFF | 0

The Sequencer is deactivated. Any running sequential measurements are stopped. Further Sequencer commands (INIT:SEQ...) are not available.

*RST: 0
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single Sequencer mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

SYST:SEQ OFF
Example:

See "Programming Example: Performing a Sequence of Measurements" .


Configuring the Inputs and Outputs

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs
Configuring the Inputs and Outputs
Contents
  • Radio Frequency (RF) Input
  • External Mixer
  • External Generator


Radio Frequency (RF) Input

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > Radio Frequency (RF) Input
Radio Frequency (RF) Input
List of Commands
INPut:COUPling
INPut:IMPedance
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]


INPut:COUPling

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > Radio Frequency (RF) Input > INPut:COUPling
INPut:COUPling <CouplingType>

This command selects the coupling type of the RF input.

Parameters:
<CouplingType>
AC

AC coupling

DC

DC coupling

*RST: AC
Example: INP:COUP DC
Usage: SCPI confirmed
Manual operation: See "Input Coupling"


INPut:IMPedance

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > Radio Frequency (RF) Input > INPut:IMPedance
INPut:IMPedance <Impedance>

This command selects the nominal input impedance of the RF input.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a matching pad of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The power loss correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

Parameters:
<Impedance>
50 | 75
*RST: 50 Ω
Example: INP:IMP 75
Usage: SCPI confirmed
Manual operation: See "Impedance"


INPut:FILTer:HPASs[:STATe]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > Radio Frequency (RF) Input > INPut:FILTer:HPASs[:STATe]
INPut:FILTer:HPASs[:STATe] <State>

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "High-Pass Filter 1...3 GHz"


INPut:FILTer:YIG[:STATe]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > Radio Frequency (RF) Input > INPut:FILTer:YIG[:STATe]
INPut:FILTer:YIG[:STATe] <State>

This command turns the YIG-preselector on and off.

Note the special conditions and restrictions for the YIG filter described in "YIG-Preselector".

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 (0 for I/Q Analyzer, GSM, VSA and MC Group Delay measurements)
Example: INP:FILT:YIG OFF

Deactivates the YIG-preselector.

Manual operation: See "YIG-Preselector"


External Mixer

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer
External Mixer
List of Commands
[SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SNUMber
[SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:LOPower
[SENSe:]MIXer:SIGNal
[SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:PORTs
[SENSe:]MIXer:RFOVerrange[:STATe]
[SENSe:]MIXer:THReshold
[SENSe:]MIXer[:STATe]


[SENSe:]CORRection:CVL:BAND

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BAND <Type>

This command defines the waveguide band for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Band>
K | A | KA | Q | U | V | E | W | F | D | G | Y | J | USER

Standard waveguide band or user-defined band.

Note: The band formerly referred to as "A" is now named "KA"; the input parameter "A" is still available and refers to the same band as "KA".

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

*RST: F (90 GHz - 140 GHz)
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:BAND KA

Sets the band to KA (26.5 GHz - 40 GHz).

Example:

See "Configuring a conversion loss table for a user-defined band" .

Manual operation: See "Band"


[SENSe:]CORRection:CVL:BIAS

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:BIAS <BiasSetting>

This command defines the bias setting to be used with the conversion loss table.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<BiasSetting>
numeric value
*RST: | 0.0 A
Default unit: | A
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:BIAS 3A
Example:

See "Configuring a conversion loss table for a user-defined band" .

Manual operation: See "Write to <CVL table name>"
See "Bias"


[SENSe:]CORRection:CVL:CATAlog?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CATAlog?

This command queries all available conversion loss tables saved in the C:\r_s\instr\user\cvl\ directory on the instrument.

This command is only available with option B21 (External Mixer) installed.

Usage: Query only


[SENSe:]CORRection:CVL:CLEAr

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:CLEAr

This command deletes the selected conversion loss table. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:CLE
Usage: | Event
Manual operation: | See "Delete Table"


[SENSe:]CORRection:CVL:COMMent

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:COMMent <Text>

This command defines a comment for the conversion loss table. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Text>
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:COMM 'Conversion loss table for FS_Z60'
Example:

See "Configuring a conversion loss table for a user-defined band" .

Manual operation: See "Comment"


[SENSe:]CORRection:CVL:DATA

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:DATA <Freq>,<Level>

This command defines the reference values of the selected conversion loss tables. The values are entered as a set of frequency/level pairs. A maximum of 50 frequency/level pairs may be entered. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Freq>
numeric value

The frequencies have to be sent in ascending order.

<Level>
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:DATA 1MHZ,-30DB,2MHZ,-40DB
Example:

See "Configuring a conversion loss table for a user-defined band" .

Manual operation: See "Position/Value"


[SENSe:]CORRection:CVL:HARMonic

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:HARMonic <HarmOrder>

This command defines the harmonic order for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<HarmOrder>
numeric value
Range: 2 to 65
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:HARM 3
Example:

See "Configuring a conversion loss table for a user-defined band" .

Manual operation: See "Harmonic Order"


[SENSe:]CORRection:CVL:MIXer

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:MIXer <Type>

This command defines the mixer name in the conversion loss table. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Type>
string

Name of mixer with a maximum of 16 characters

Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:MIX 'FS_Z60'
Example:

See "Configuring a conversion loss table for a user-defined band" .

Manual operation: See "Mixer Name"


[SENSe:]CORRection:CVL:PORTs

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:PORTs <PortNo>

This command defines the mixer type in the conversion loss table. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<PortType>
2 | 3
*RST: 2
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:PORT 3
Example:

See "Configuring a conversion loss table for a user-defined band" .

Manual operation: See "Mixer Type"


[SENSe:]CORRection:CVL:SELect

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SELect <FileName>

This command selects the conversion loss table with the specified file name. If <file_name> is not available, a new conversion loss table is created.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<FileName>
'<File name>'
Example: CORR:CVL:SEL 'LOSS_TAB_4'
Example:

See "Configuring a conversion loss table for a user-defined band" .

Manual operation: See "New Table"
See "Edit Table"
See "File Name"


[SENSe:]CORRection:CVL:SNUMber

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]CORRection:CVL:SNUMber
[SENSe:]CORRection:CVL:SNUMber <SerialNo>

This command defines the serial number of the mixer for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<SerialNo>

Serial number with a maximum of 16 characters

Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:MIX '123.4567'
Example:

See "Configuring a conversion loss table for a user-defined band" .

Manual operation: See "Mixer S/N"


[SENSe:]MIXer:BIAS:HIGH

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS:HIGH <BiasSetting>

This command defines the bias current for the high (second) range.

(See also "Bias Current" ).

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<BiasSetting>
*RST: | 0.0 A
Default unit: | A
Manual operation: See "Bias Settings"


[SENSe:]MIXer:BIAS[:LOW]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:BIAS[:LOW] <BiasSetting>

This command defines the bias current for the low (first) range.

(See also "Bias Current" ).

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<BiasSetting>
*RST: | 0.0 A
Default unit: | A
Example:

See "Programming Example: Working with an External Mixer" .

Manual operation: See "Bias Settings"


[SENSe:]MIXer:FREQuency:HANDover

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:HANDover <Frequency>

This command defines the frequency at which the mixer switches from one range to the next (if two different ranges are selected). The handover frequency for each band can be selected freely within the overlapping frequency range.

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<Frequency>
numeric value
Example: MIX ON

Activates the external mixer.

MIX:FREQ:HAND 78.0299GHz

Sets the handover frequency to 78.0299 GHz.

Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band" .

Manual operation: See "Handover Freq."


[SENSe:]MIXer:FREQuency:STARt?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STARt?

This command queries the frequency at which the external mixer band starts.

Example: MIX:FREQ:STAR?

Queries the start frequency of the band.

Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band" .

Usage: Query only
Manual operation: See "RF Start / RF Stop"


[SENSe:]MIXer:FREQuency:STOP?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:FREQuency:STOP?

This command queries the frequency at which the external mixer band stops.

Example: MIX:FREQ:STOP?

Queries the stop frequency of the band.

Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band" .

Usage: Query only
Manual operation: See "RF Start / RF Stop"


[SENSe:]MIXer:HARMonic:BAND:PRESet

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND:PRESet

This command restores the preset frequency ranges for the selected standard waveguide band.

Note:Changes to the band and mixer settings are maintained even after using the PRESET function. Use this command to restore the predefined band ranges.

Example: | MIX:HARM:BAND:PRES Presets the selected waveguide band.
Usage: | Event
Manual operation: | See "Preset Band"


[SENSe:]MIXer:HARMonic:BAND[:VALue]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:BAND[:VALue] <Band>

This command selects the external mixer band. The query returns the currently selected band.

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<Band>
KA | Q | U | V | E | W | F | D | G | Y | J | USER

Standard waveguide band or user-defined band.

Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band" .

Manual operation: See "Band"
Frequency ranges for pre-defined bands
Band | Frequency start [GHz] | Frequency stop [GHz]
KA (A) *) | 26.5 | 40.0
Q | 33.0 | 50.0
U | 40.0 | 60.0
V | 50.0 | 75.0
E | 60.0 | 90.0
W | 75.0 | 110.0
F | 90.0 | 140.0
D | 110.0 | 170.0
G | 140.0 | 220.0
J | 220.0 | 325.0
Y | 325.0 | 500.0
USER | 32.18 (default) | 68.22 (default)
*) The band formerly referred to as "A" is now named "KA".


[SENSe:]MIXer:HARMonic:HIGH:STATe

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH:STATe <State>

This command specifies whether a second (high) harmonic is to be used to cover the band's frequency range.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: MIX:HARM:HIGH:STAT ON
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band" .

Manual operation: See "Range 1/2"


[SENSe:]MIXer:HARMonic:HIGH[:VALue]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:HIGH[:VALue] <HarmOrder>

This command specifies the harmonic order to be used for the high (second) range.

Parameters:
<HarmOrder
numeric value
Range: 2 to 61 (USER band); for other bands: see band definition
Example: MIX:HARM:HIGH 2
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band" .

Manual operation: See "Harmonic Order"


[SENSe:]MIXer:HARMonic:TYPE

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic:TYPE <OddEven>

This command specifies whether the harmonic order to be used should be odd, even, or both.

Which harmonics are supported depends on the mixer type.

Parameters:
<OddEven>
ODD | EVEN | EODD
*RST: EVEN
Example: MIX:HARM:TYPE ODD
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band" .

Manual operation: See "Harmonic Type"


[SENSe:]MIXer:HARMonic[:LOW]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:HARMonic[:LOW] <HarmOrder>

This command specifies the harmonic order to be used for the low (first) range.

Parameters:
<HarmOrder>
numeric value
Range: | 2 to 61 (USER band); for other bands: see band definition
*RST: | 2 (for band F)
Example: MIX:HARM 3
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band" .

Manual operation: See "Harmonic Order"


[SENSe:]MIXer:LOPower

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:LOPower
[SENSe:]MIXer:LOPower <Level>

This command specifies the LO level of the external mixer's LO port.

Parameters:
<Level>
numeric value
Range: | 13.0 dBm to 17.0 dBm
Increment: | 0.1 dB
*RST: | 15.5 dBm
Example: MIX:LOP 16.0dBm
Example:

See "Programming Example: Working with an External Mixer" .

Manual operation: See "LO Level"


[SENSe:]MIXer:SIGNal

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:SIGNal
[SENSe:]MIXer:SIGNal <State>

This command specifies whether automatic signal detection is active or not.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

Parameters:
<State>
OFF | ON | AUTO | ALL
OFF

No automatic signal detection is active.

ON

Automatic signal detection (Signal ID) is active.

AUTO

Automatic signal detection (Auto ID) is active.

ALL

Both automatic signal detection functions (Signal ID+Auto ID) are active.

*RST: OFF
Example:

See "Programming Example: Working with an External Mixer" .

Manual operation: See "Signal ID"
See "Auto ID"


[SENSe:]MIXer:LOSS:HIGH

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:HIGH <Average>

This command defines the average conversion loss to be used for the entire high (second) range.

Parameters:
<Average>
numeric value
Range: | 0 to 100
*RST: | 24.0 dB
Default unit: | dB
Example: MIX:LOSS:HIGH 20dB
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band" .

Manual operation: See "Conversion loss"


[SENSe:]MIXer:LOSS:TABLe:HIGH

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH <FileName>

This command defines the file name of the conversion loss table to be used for the high (second) range.

Parameters:
<FileName> | string ('<file name>')
Example: | MIX:LOSS:TABL:HIGH 'MyCVLTable'
Manual operation: | See "Conversion loss"


[SENSe:]MIXer:LOSS:TABLe[:LOW]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS:TABLe[:LOW] <FileName>

This command defines the file name of the conversion loss table to be used for the low (first) range.

Parameters:
<FileName>
string ('<file name>')
Example: MIX:LOSS:TABL 'mix_1_4'

Specifies the conversion loss table mix_1_4.

Example:

See "Configuring a conversion loss table for a user-defined band"

Manual operation: See "Conversion loss"


[SENSe:]MIXer:LOSS[:LOW]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:LOSS[:LOW] <Average>

This command defines the average conversion loss to be used for the entire low (first) range.

Parameters:
<Average>
numeric value
Range: | 0 to 100
*RST: | 24.0 dB
Default unit: | dB
Example: MIX:LOSS 20dB
Example:

See "Programming Example: Working with an External Mixer" .

Manual operation: See "Conversion loss"


[SENSe:]MIXer:PORTs

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:PORTs
[SENSe:]MIXer:PORTs <PortType>

This command specifies whether the mixer is a 2-port or 3-port type.

Parameters:
<PortType>
2 | 3
*RST: 2
Example: MIX:PORT 3
Example:

See "Programming Example: Working with an External Mixer" .

Manual operation: See "Mixer Type"


[SENSe:]MIXer:RFOVerrange[:STATe]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:RFOVerrange[:STATe]
[SENSe:]MIXer:RFOVerrange[:STATe] <State>

If enabled, the band limits are extended beyond "RF Start" and "RF Stop" due to the capabilities of the used harmonics.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Programming Example: Working with an External Mixer" .

Manual operation: See "RF Overrange"


[SENSe:]MIXer:THReshold

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer:THReshold
[SENSe:]MIXer:THReshold <Value>

This command defines the maximum permissible level difference between test sweep and reference sweep to be corrected during automatic comparison (see [SENSe:​]MIXer:​SIGNal).

Parameters:
<Value>
<numeric value>
Range: | 0.1 dB to 100 dB
*RST: | 10 dB
Example: MIX:PORT 3
Example:

See "Programming Example: Working with an External Mixer"

Manual operation: See "Auto ID Threshold"


[SENSe:]MIXer[:STATe]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Mixer > [SENSe:]MIXer[:STATe]
[SENSe:]MIXer[:STATe] <State>

Activates or deactivates the use of a connected external mixer as input for the measurement. This command is only available if the R&S FSW-B21 option is installed and an external mixer is connected.

(See "How to Work with External Mixers" ).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: MIX ON
Example:

See "Programming Example: Working with an External Mixer" .

Manual operation: See "External Mixer State"


External Generator

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Generator
External Generator
List of Commands
SOURce:EXTernal:FREQuency[:FACTor]:DENominator
SOURce:EXTernal:FREQuency[:FACTor]:NUMerator
SOURce:EXTernal:FREQuency:OFFSet<offset>
SOURce:EXTernal:POWer[:LEVel]
SOURce:EXTernal:ROSCillator[:SOURce]
SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess
SYSTem:COMMunicate:RDEVice:GENerator:INTerface
SYSTem:COMMunicate:RDEVice:GENerator:TYPE
SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess
SYSTem:CONFigure:GENerator:CONTrol:STATe
SYSTem:CONFigure:GENerator:INITialise:AUTO
SYSTem:CONFigure:GENerator:INITialise:IMMediate
SYSTem:CONFigure:GENerator:SWITch:AUTO


SOURce:EXTernal:FREQuency[:FACTor]:DENominator

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Generator > SOURce:EXTernal:FREQuency[:FACTor]:DENominator
SOURce:EXTernal:FREQuency[:FACTor]:DENominator <Value>
SOURce:EXTernal:FREQuency[:FACTor]:NUMerator <Value>
SOURce:EXTernal:FREQuency:OFFSet<offset> <Value>

These commands define the frequency correction characteristics for the generator.

Frequency correction is made up out of a frequency offset and a factor (nominator / denominator) as shown in the following equation.

The command is available with option R&S FSW-B10.

Suffix:
<factor>
1...2

Frequency offset1 or Frequency offset2 as shown in the equation above.

Parameters:
<Value>

For SOURce:EXTernal:FREQuency:OFFSet, the parameter is a frequency offset.

*RST: | 0 (for both offsets)
Default unit: | Hz
<Value>

For SOURce:EXTernal:FREQuency:FACTor:DENominator and SOURce:EXTernal:FREQuency:FACTor:NUMerator, the parameter is a correction factor without unit, made up out of a numerator and a denominator.

*RST: 1 (for both numerator and denominator)
Example: SOUR:EXT:FREQ:OFFS2 100HZ

Defines 100 Hz as the second frequency offset.

SOUR:EXT:FREQ:FACT:NOM 2
SOUR:EXT:FREQ:FACT:DEN 2.5

Defines a frequency correction factor of 2/2.5.

Manual operation: See "Frequency Coupling"


SOURce:EXTernal:POWer[:LEVel]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Generator > SOURce:EXTernal:POWer[:LEVel]
SOURce:EXTernal:POWer[:LEVel] <Level>

This command sets the output power of the selected generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Parameters:
<Level>
<numeric value>
*RST: -20 dBm
Example: SOUR:EXT:POW -30dBm

Sets the generator level to -30 dBm

Example:

See "Programming Example for External Generator Control" .

Manual operation: See "Source Power"


SOURce:EXTernal:ROSCillator[:SOURce]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Generator > SOURce:EXTernal:ROSCillator[:SOURce]
SOURce:EXTernal:ROSCillator[:SOURce] <Source>

This command controls selection of the reference oscillator for the external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

If the external reference oscillator is selected, the reference signal must be connected to the rear panel of the instrument.

Parameters:
<Source>
INTernal

the internal reference is used

EXTernal

the external reference is used; if none is available, an error flag is displayed in the status bar

*RST: INT
Example: SOUR:EXT:ROSC EXT

Switches to external reference oscillator

Manual operation: See "Reference"


SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Generator > SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess
SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess <Number>

Changes the IEC/IEEE-bus address of the external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<Number>
Range: | 0 to 30
*RST: | 28
Example: SYST:COMM:GPIB:RDEV:GEN:ADDR 15
Example:

See "Programming Example for External Generator Control" .

Manual operation: See "GPIB Address / TCP/IP Address"


SYSTem:COMMunicate:RDEVice:GENerator:INTerface

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Generator > SYSTem:COMMunicate:RDEVice:GENerator:INTerface
SYSTem:COMMunicate:RDEVice:GENerator:INTerface <Type>

Defines the interface used for the connection to the external generator.

Parameters:
<Type>
GPIB | TCPip
*RST: GPIB
Example: SYST:COMM:RDEV:GEN:INT TCP
Example:

See "Programming Example for External Generator Control" .

Manual operation: See "Interface"


SYSTem:COMMunicate:RDEVice:GENerator:TYPE

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Generator > SYSTem:COMMunicate:RDEVice:GENerator:TYPE
SYSTem:COMMunicate:RDEVice:GENerator:TYPE <Type>

This command selects the type of external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<Name>
<Generator name as string value>
*RST: SMU02
Example: SYST:COMM:RDEV:GEN2:TYPE 'SME02'

Selects SME02 as generator 2

Example:

See "Programming Example for External Generator Control" .

Manual operation: See "Generator Type"


SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Generator > SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess
SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess <Address>

Configures the TCP/IP address for the external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<Address>
TCP/IP address between 0.0.0.0 and 0.255.255.255
*RST: 0.0.0.0
Example: SYST:COMM:TCP:RDEV:GEN:ADDR 130.094.122.195
Manual operation: See "GPIB Address / TCP/IP Address"


SYSTem:CONFigure:GENerator:CONTrol:STATe

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Generator > SYSTem:CONFigure:GENerator:CONTrol:STATe
SYSTem:CONFigure:GENerator:CONTrol:STATe <State>

This command turns automatic control of an external generator on and off.

The command is available with option R&S FSW-B10.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: SYST:CONF:GEN:CONT:STAT ON

Turns on automatic generator control.

Manual operation: See "Automatic Control"


SYSTem:CONFigure:GENerator:INITialise:AUTO

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Generator > SYSTem:CONFigure:GENerator:INITialise:AUTO
SYSTem:CONFigure:GENerator:INITialise:AUTO <State>

This command turns automatic connection to the generator on and off.

If on, the application automatically configures the generator before each measurement and turns on its RF output. Note that you have to establish a connection to the generator before you can perform the measurement.

The command is available with option R&S FSW-B10.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: SYST:CONF:GEN:INIT:AUTO ON

Turns automatic generator configuration on.

Manual operation: See "Init Before Meas"


SYSTem:CONFigure:GENerator:INITialise:IMMediate

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Generator > SYSTem:CONFigure:GENerator:INITialise:IMMediate
SYSTem:CONFigure:GENerator:INITialise:IMMediate

This command establishes a connection to the external generator.

When you send the command, the application configures the generator once and turns on its RF output. Note that you have to establish a connection to the generator before you can perform the measurement.

The command is available with option R&S FSW-B10.

Usage: | Event
Manual operation: | See "Init External Generator"


SYSTem:CONFigure:GENerator:SWITch:AUTO

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Inputs and Outputs > External Generator > SYSTem:CONFigure:GENerator:SWITch:AUTO
SYSTem:CONFigure:GENerator:SWITch:AUTO <State>

This command turns automatic deactivation of the generator's RF output after a measurement is done on and off.

The command is available with option R&S FSW-B10.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: SYST:CONF:GEN:SWIT:AUTO ON

Turns on automatic deactivation of the RF output.

Manual operation: See "Auto Switch Off"


Configuring the Display

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Display
Configuring the Display

The following commands are necessary to configure and scale the result displays.

List of Commands
DISPlay[:WINDow<n>]:TRACe:SYMBols
DISPlay[:WINDow<n>]:TRACe:X[:SCALe]
DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:BOTTom
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO
DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:TOP


DISPlay[:WINDow<n>]:TRACe:SYMBols

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Display > DISPlay[:WINDow<n>]:TRACe:SYMBols
DISPlay[:WINDow<n>]:TRACe:SYMBols <State>

This command turns symbols that represent the measurement points on a trace on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DISP:WIND2:TRAC:SYMB ON

Switches on the display of symbols in window 2..

Manual operation: See "Symbols"


DISPlay[:WINDow<n>]:TRACe:X[:SCALe]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Display > DISPlay[:WINDow<n>]:TRACe:X[:SCALe]
DISPlay[:WINDow<n>]:TRACe:X[:SCALe] <Frequency>

This command selects the type of frequency displayed on the x-axis.

Parameters:
<Frequency>
IF

Intermediary frequency, e.g. for measurements on frequency converting DUTs.

RF

Radio frequency.

*RST: RF
Example:

CONF:MODE:DUT DOWN

The DUT converts the input frequency to a lower output frequency.

DISP:TRAC:X RF

Shows the RF frequency on the x-axis.

Manual operation: See "X-Axis"


DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:BOTTom

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Display > DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:BOTTom
DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:BOTTom <Level>

This command defines the bottom value of the y-axis.

Parameters:
<Level> | The value ranges depend on the result display. Noise figure -75 dB to 75 dB Noise temperature -999990000 K to 999990000 K Y-factor -200 dB to 200 dB Gain -75 dB to 75 dB Power (hot) -200 dBm to 200 dBm Power (cold) -200 dBm to 200 dBm
Example: | DISP:WIND2:TRAC:Y:SCAL:AUTO OFF DISP:WIND2:TRAC:Y:BOTT
Usage: | SCPI confirmed
Manual operation: | See "Auto Scale / Min / Max"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Display > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO <State>

This command turns automatic scaling of the y-axis on and off.

Parameters:
<State>
ON | OFF
*RST: ON
Example:

DISP:WIND2:TRAC:Y:AUTO ON

Turns on automatic scaling for measurement window 2.

Usage: SCPI confirmed
Manual operation: See "Auto Scale / Min / Max"


DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:TOP

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Configuring the Display > DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:TOP
DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:TOP <Level>

This command defines the top value of the y-axis.

Parameters:
<Level> | The value ranges depend on the result display. Noise figure -75 dB to 75 dB Noise temperature -999990000 K to 999990000 K Y-factor -200 dB to 200 dB Gain -75 dB to 75 dB Power (hot) -200 dBm to 200 dBm Power (cold) -200 dBm to 200 dBm
Example: | DISP:WIND2:TRAC:Y:SCAL:AUTO OFF DISP:WIND2:TRAC:Y:TOP
Usage: | SCPI confirmed
Manual operation: | See "Auto Scale / Min / Max"


Working with Traces

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Traces
Working with Traces

The following commands are necessary to define trace characteristics.

List of Commands
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
FORMat[:DATA]
FORMat:DEXPort:DSEParator
FORMat:DEXPort:HEADer
FORMat:DEXPort:TRACes
MMEMory:STORe<n>:TRACe
TRACe<n>:COPY


DISPlay[:WINDow<n>]:TRACe<t>:MODE

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE <Mode>

This command selects the trace mode.

For more information see "Analyzing Several Traces - Trace Mode" .

Parameters:
<Mode
BLANk | VIEW | WRITe
*RST: Trace 1: WRITe, Trace 2-4: BLANk
Example: INIT:CONT OFF

Switching to single sweep mode.

SWE:COUN 16

Sets the number of measurements to 16.

DISP:TRAC3:MODE WRIT

Selects clear/write mode for trace 3.

INIT;*WAI

Starts the measurement and waits for the end of the measurement.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Traces"


DISPlay[:WINDow<n>]:TRACe<t>[:STATe]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Traces > DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:TRACe<t>[:STATe] <State>

This command turns a trace on and off.

The measurement continues in the background.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: Trace 1: 1, Trace 2-4: 0
Example: DISP:TRAC3 ON
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed


FORMat[:DATA]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Traces > FORMat[:DATA]
FORMat[:DATA] <Format>

This command selects the data format that is used for transmission of trace data from the R&S FSW to the controlling computer.

Note that the command has no effect for data that you send to the R&S FSW. The R&S FSW automatically recognizes the data it receives, regardless of the format.

Parameters:
<Format>
ASCii

ASCii format, separated by commas.

This format is almost always suitable, regardless of the actual data format. However, the data is not as compact as other formats may be.

REAL,32

32-bit IEEE 754 floating-point numbers in the "definite length block format".

In the Spectrum application, the format setting REAL is used for the binary transmission of trace data.

For I/Q data, 8 bytes per sample are returned for this format setting.

*RST: ASCII
Example: FORM REAL,32
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Usage: SCPI confirmed


FORMat:DEXPort:DSEParator

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Traces > FORMat:DEXPort:DSEParator
FORMat:DEXPort:DSEParator <Separator>

This command selects the decimal separator for data exported in ASCII format.

Parameters:
<Separator>
COMMa

Uses a comma as decimal separator, e.g. 4,05.

POINt

Uses a point as decimal separator, e.g. 4.05.

*RST: *RST has no effect on the decimal separator. Default is POINt.
Example: FORM:DEXP:DSEP POIN

Sets the decimal point as separator.

Manual operation: See "Trace Export"


FORMat:DEXPort:HEADer

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Traces > FORMat:DEXPort:HEADer
FORMat:DEXPort:HEADer <State>

If enabled, additional instrument and measurement settings are included in the header of the export file for result data. If disabled, only the pure result data from the selected traces and tables is exported.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Usage: SCPI confirmed
Manual operation: See "Trace Export"


FORMat:DEXPort:TRACes

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Traces > FORMat:DEXPort:TRACes
FORMat:DEXPort:TRACes <Selection>

This command selects the data to be included in a data export file (see MMEMory:​STORe<n>:​TRACe).

Parameters:
<Selection>
SINGle

Only a single trace is selected for export, namely the one specified by the MMEMory:​STORe<n>:​TRACe command.

ALL

Selects all active traces and result tables (e.g. Result Summary, marker peak list etc.) in the current application for export to an ASCII file.

The <trace> parameter for the MMEMory:​STORe<n>:​TRACe command is ignored.

*RST: SINGle
Usage: SCPI confirmed
Manual operation: See "Trace Export"


MMEMory:STORe<n>:TRACe

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Traces > MMEMory:STORe<n>:TRACe
MMEMory:STORe<n>:TRACe <Trace>, <FileName>

This command exports trace data from the specified window to an ASCII file.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Parameters:
<Trace> | Number of the trace to be stored
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR1:TRAC 3,'C:\TEST.ASC' Stores trace 3 from window 1 in the file TEST.ASC.
Usage: | SCPI confirmed
Manual operation: | See "Trace Export"


TRACe<n>:COPY

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Traces > TRACe<n>:COPY
TRACe<n>:COPY <TraceNumber>, <TraceNumber>

This command copies data from one trace to another.

Parameters:
<TraceNumber>, <TraceNumber>
TRACE1 | TRACE2 | TRACE3 | TRACE4

The first parameter is the destination trace, the second parameter is the source.

Example: TRAC:COPY TRACe1,TRACe2

Copies the data from trace 2 to trace 1.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Copy Trace"


Working with Limit Lines

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines
Working with Limit Lines

The following commands are necessary to set up limit lines and checks.

When configuring limit lines for the noise figure application via remote control, you have to send some commands in a defined order.

  1. Select the limit line you want to configure by name or create a new limit line name.

  2. Select the result type you want to apply the limit line to.

    The application automatically selects the unit and scale to make the line compatible to the result type.

  3. Define the horizontal data points of the limit line.

  4. Define the vertical data points of the limit line. Depending on the command syntax you are using, the shape also defines if the limit line is an upper or lower limit line (CALCulate:LIMit:UPPer:... or CALCulate:LIMit:LOWer:...).

Example: Configure an upper limit line for the Noise Figure result type
//Select or create the limit line by name.
CALC:LIM:NAME 'NoiseFigure'
//Comment on the limit line.
CALC:LIM:COMM 'Limit line to test noise figure results'
//Select the result type (here: Noise Figure) to apply the limit line to.
CALC:LIM:TYPE NOIS
//Define the horizontal data points of the limit line.
CALC:LIM:CONT 100MHZ,850MHZ
//Shift the limit line 50 MHz to the left.
CALC:LIM:CONT:SHIF -50MHZ
//Define the vertical data points of an (upper) limit line.
//The unit is fix according to the result type you have selected.
CALC:LIM:UPP 10,10
//Shift the limit line 5 dB down.
CALC:LIM:UPP:SHIF -5
//Turn the limit line on.
CALC:LIM:UPP:STAT ON
//Select the trace to check.
CALC:LIM:TRAC 1
//Turn on the limit check.
CALC:LIM:STAT ON
//Query the limit check results.
CALC:LIM:FAIL?
Contents
  • Defining General Characteristics of a Limit Line
  • Defining Horizontal Data Points
  • Controlling Lower Limit Lines
  • Controlling Upper Limit Lines
  • Managing Limit Lines
  • Controlling Limit Checks


Defining General Characteristics of a Limit Line

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Defining General Characteristics of a Limit Line
Defining General Characteristics of a Limit Line
List of Commands
CALCulate:LIMit:COMMent
CALCulate:LIMit<k>:NAME
CALCulate:LIMit<k>:TYPE


CALCulate:LIMit:COMMent

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Defining General Characteristics of a Limit Line > CALCulate:LIMit:COMMent
CALCulate:LIMit:COMMent <Comment>

This command defines a comment for a limit line.

Parameters:
<Comment> | String containing the description of the limit line. The comment may have up to 40 characters.
Manual operation: | See "Comment"


CALCulate:LIMit<k>:NAME

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Defining General Characteristics of a Limit Line > CALCulate:LIMit<k>:NAME
CALCulate:LIMit<k>:NAME <Name>

This command selects a limit line that already exists or defines a name for a new limit line.

Parameters:
<Name>

String containing the limit line name.

*RST: REM1 to REM8 for lines 1 to 8
Example:

See "Programming Example: EMI Measurement" .

Manual operation: See "Name"


CALCulate:LIMit<k>:TYPE

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Defining General Characteristics of a Limit Line > CALCulate:LIMit<k>:TYPE
CALCulate:LIMit<k>:TYPE <Result>

This command configures a limit line for a particular result type.

Parameters:
<Result> | GAIN Assigns the limit line to gain reuslts. NOISe Assigns the limit line to noise figure results. PCOLd Assigns the limit line to power (cold) results. PHOT Assigns the limit line to power (hot) results. TEMPerature Assigns the limit line to noise temperature results. YFACtor Assigns the limit line to y-factor results.
Example: | CALC:LIM2:TYPE GAIN Assigns limit line 2 to the gain result display.


Defining Horizontal Data Points

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Defining Horizontal Data Points
Defining Horizontal Data Points

Note that the number of data points on the horizontal axis should be the same as the number of data points on the vertical axis. Otherwise the limit line may take on an unintended shape.

Example: Number of vertical data points < number of horizontal data points

CALC:LIM:CONT 100MHZ,200MHZ,300MHZ,400MHZ,500MHZ

CALC:LIM:UPP 0,5,0

⇒ the application dumps 400 and 500 MHz.

Example: Number of vertical data points > number of horizontal data points

CALC:LIM:CONT 100MHZ,200MHZ,300MHZ,400MHZ,500MHZ

CALC:LIM:UPP 0,5,0,5,0,5,0

⇒ the application adds new horizontal data points (500.00000100 MHz and 500.00000200 MHz).

List of Commands
CALCulate:LIMit<k>:CONTrol[:DATA]
CALCulate:LIMit<k>:CONTrol:SHIFt


CALCulate:LIMit<k>:CONTrol[:DATA]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Defining Horizontal Data Points > CALCulate:LIMit<k>:CONTrol[:DATA]
CALCulate:LIMit<k>:CONTrol[:DATA] <LimitLinePoints>

This command defines the horizontal definition points of a limit line.

Parameters:
<LimitLinePoints>

Variable number of x-axis values.

Note that the number of horizontal values has to be the same as the number of vertical values set with CALCulate:​LIMit<k>:​LOWer[:​DATA] or CALCulate:​LIMit<k>:​UPPer[:​DATA]. If not, the R&S FSW either adds missing values or ignores surplus values.

*RST: -
Usage: SCPI confirmed
Manual operation: See "Data points"


CALCulate:LIMit<k>:CONTrol:SHIFt

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Defining Horizontal Data Points > CALCulate:LIMit<k>:CONTrol:SHIFt
CALCulate:LIMit<k>:CONTrol:SHIFt <Distance>

This command moves a complete limit line horizontally.

Compared to defining an offset, this command actually changes the limit line definition points by the value you define.

Parameters:
<Distance> | Numeric value. The unit depends on the scale of the x-axis.
Manual operation: | See "Shift x"


Controlling Lower Limit Lines

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Controlling Lower Limit Lines
Controlling Lower Limit Lines
List of Commands
CALCulate:LIMit<k>:LOWer[:DATA]
CALCulate:LIMit<k>:LOWer:SHIFt
CALCulate:LIMit<k>:LOWer:STATe


CALCulate:LIMit<k>:LOWer[:DATA]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Controlling Lower Limit Lines > CALCulate:LIMit<k>:LOWer[:DATA]
CALCulate:LIMit<k>:LOWer[:DATA] <LimitLinePoints>

This command defines the vertical definition points of a lower limit line.

Parameters:
<LimitLinePoints>

Variable number of level values.

Note that the number of vertical values has to be the same as the number of horizontal values set with CALCulate:​LIMit<k>:​CONTrol[:​DATA]. If not, the R&S FSW either adds missing values or ignores surplus values.

*RST: Limit line state is OFF
Usage: SCPI confirmed
Manual operation: See "Data points"


CALCulate:LIMit<k>:LOWer:SHIFt

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Controlling Lower Limit Lines > CALCulate:LIMit<k>:LOWer:SHIFt
CALCulate:LIMit<k>:LOWer:SHIFt <Distance>

This command moves a complete lower limit line vertically.

Compared to defining an offset, this command actually changes the limit line definition points by the value you define.

Parameters:
<Distance> | Defines the distance that the limit line moves.
Manual operation: | See "Shift y"


CALCulate:LIMit<k>:LOWer:STATe

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Controlling Lower Limit Lines > CALCulate:LIMit<k>:LOWer:STATe
CALCulate:LIMit<k>:LOWer:STATe <State>

This command turns a lower limit line on and off.

Before you can use the command, you have to select a limit line with CALCulate:​LIMit<k>:​NAME.

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "Visibility"


Controlling Upper Limit Lines

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Controlling Upper Limit Lines
Controlling Upper Limit Lines
List of Commands
CALCulate:LIMit<k>:UPPer[:DATA]
CALCulate:LIMit<k>:UPPer:SHIFt
CALCulate:LIMit<k>:UPPer:STATe


CALCulate:LIMit<k>:UPPer[:DATA]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Controlling Upper Limit Lines > CALCulate:LIMit<k>:UPPer[:DATA]
CALCulate:LIMit<k>:UPPer[:DATA] <LimitLinePoints>

This command defines the vertical definition points of an upper limit line.

Parameters:
<LimitLinePoints>

Variable number of level values.

Note that the number of vertical values has to be the same as the number of horizontal values set with CALCulate:​LIMit<k>:​CONTrol[:​DATA]. If not, the R&S FSW either adds missing values or ignores surplus values.

*RST: Limit line state is OFF
Usage: SCPI confirmed
Manual operation: See "Data points"


CALCulate:LIMit<k>:UPPer:SHIFt

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Controlling Upper Limit Lines > CALCulate:LIMit<k>:UPPer:SHIFt
CALCulate:LIMit<k>:UPPer:SHIFt <Distance>

This command moves a complete upper limit line vertically.

Compared to defining an offset, this command actually changes the limit line definition points by the value you define.

Parameters:
<Distance> | Defines the distance that the limit line moves.
Usage: | Event
Manual operation: | See "Shift y"


CALCulate:LIMit<k>:UPPer:STATe

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Controlling Upper Limit Lines > CALCulate:LIMit<k>:UPPer:STATe
CALCulate:LIMit<k>:UPPer:STATe <State>

This command turns an upper limit line on and off.

Before you can use the command, you have to select a limit line with CALCulate:​LIMit<k>:​NAME.

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "Visibility"


Managing Limit Lines

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Managing Limit Lines
Managing Limit Lines
List of Commands
CALCulate:LIMit:ACTive?
CALCulate:LIMit<k>:COPY
CALCulate:LIMit<k>:DELete


CALCulate:LIMit:ACTive?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Managing Limit Lines > CALCulate:LIMit:ACTive?
CALCulate:LIMit:ACTive?

This command queries the names of all active limit lines.

Return values:
<LimitLines> | String containing the names of all active limit lines in alphabetical order.
Example: | CALC:LIM:ACT? Queries the names of all active limit lines.
Usage: | Query only
Manual operation: | See "Visibility"


CALCulate:LIMit<k>:COPY

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Managing Limit Lines > CALCulate:LIMit<k>:COPY
CALCulate:LIMit<k>:COPY <Line>

This command copies a limit line.

Parameters:
<Line> | 1 to 8 number of the new limit line <name> String containing the name of the limit line.
Example: | CALC:LIM1:COPY 2 Copies limit line 1 to line 2. CALC:LIM1:COPY 'FM2' Copies limit line 1 to a new line named FM2.
Manual operation: | See "Copy Line"


CALCulate:LIMit<k>:DELete

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Managing Limit Lines > CALCulate:LIMit<k>:DELete
CALCulate:LIMit<k>:DELete

This command deletes a limit line.

Usage: | Event
Manual operation: | See "Delete Line"


Controlling Limit Checks

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Controlling Limit Checks
Controlling Limit Checks
List of Commands
CALCulate:LIMit:CLEar[:IMMediate]
CALCulate:LIMit<k>:FAIL?
CALCulate:LIMit<k>:STATe
CALCulate:LIMit<k>:TRACe
CALCulate:LIMit<k>:TRACe<t>:CHECk


CALCulate:LIMit:CLEar[:IMMediate]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Controlling Limit Checks > CALCulate:LIMit:CLEar[:IMMediate]
CALCulate:LIMit:CLEar[:IMMediate]

This command deletes the result of the current limit check.

The command works on all limit lines in all measurement windows at the same time.

Example: CALC:LIM:CLE

Deletes the result of the limit check.

Example:

See "Programming Example: EMI Measurement" .

Usage: SCPI confirmed


CALCulate:LIMit<k>:FAIL?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Controlling Limit Checks > CALCulate:LIMit<k>:FAIL?
CALCulate:LIMit<k>:FAIL?

This command queries the result of a limit check.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result>
0

PASS

1

FAIL

Example: INIT;*WAI

Starts a new sweep and waits for its end.

CALC:LIM3:FAIL?

Queries the result of the check for limit line 3.

Example:

See "Example: SEM Measurement" .

Usage: Query only
SCPI confirmed


CALCulate:LIMit<k>:STATe

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Controlling Limit Checks > CALCulate:LIMit<k>:STATe
CALCulate:LIMit<k>:STATe <State>

This command turns the limit check for a specific limit line on and off.

To query the limit check result, use CALCulate:​LIMit<k>:​FAIL?.

Note that a new command exists to activate the limit check and define the trace to be checked in one step (see CALCulate:​LIMit<k>:​TRACe<t>:​CHECk).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:LIM:STAT ON

Switches on the limit check for limit line 1.

Usage: SCPI confirmed
Manual operation: See "Disable All Lines"


CALCulate:LIMit<k>:TRACe

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Controlling Limit Checks > CALCulate:LIMit<k>:TRACe
CALCulate:LIMit<k>:TRACe <TraceNumber>

This command links a limit line to one or more traces.

Note that this command is maintained for compatibility reasons only. Limit lines no longer need to be assigned to a trace explicitely. The trace to be checked can be defined directly (as a suffix) in the new command to activate the limit check (see CALCulate:​LIMit<k>:​TRACe<t>:​CHECk).

Parameters:
<TraceNumber>
1 to 4
*RST: 1
Example: CALC:LIM2:TRAC 3

Assigns limit line 2 to trace 3.


CALCulate:LIMit<k>:TRACe<t>:CHECk

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Limit Lines > Controlling Limit Checks > CALCulate:LIMit<k>:TRACe<t>:CHECk
CALCulate:LIMit<k>:TRACe<t>:CHECk <State>

This command turns the limit check for a specific trace on and off.

To query the limit check result, use CALCulate:​LIMit<k>:​FAIL?.

Note that this command replaces the two commands from previous signal and spectrum analyzers (which are still supported, however):
  • CALCulate:​LIMit<k>:​TRACe
  • CALCulate:​LIMit<k>:​STATe
Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:LIM3:TRAC2:CHEC ON

Switches on the limit check for limit line 3 on trace 2.

Example:

See "Programming Example: EMI Measurement" .

Manual operation: See "Traces to be Checked"


Working with Markers

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers
Working with Markers

The following commands are necessary to work with markers.

Contents
  • Using Markers
  • Using Delta Markers
  • Positioning Markers
  • Positioning Delta Markers


Using Markers

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Using Markers
Using Markers

Note that the suffix at CALCulate has an effect only if you query the characteristics of a marker. If you set a marker, you can ignore the suffix because the markers are linked to each other over all measurement windows and will always be on the same frequency.

List of Commands
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?


CALCulate<n>:MARKer<m>:AOFF

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Using Markers > CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:AOFF

This command turns all markers off.

Example: | CALC:MARK:AOFF Switches off all markers.
Usage: | Event
Manual operation: | See "All Markers Off"


CALCulate<n>:MARKer<m>[:STATe]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Using Markers > CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>[:STATe] <State>

This command turns markers on and off. If the corresponding marker number is currently active as a deltamarker, it is turned into a normal marker.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK3 ON

Switches on marker 3.

Manual operation: See "Marker Type"


CALCulate<n>:MARKer<m>:TRACe

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Using Markers > CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:TRACe <Trace>

This command selects the trace the marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> | 1 to 4 Trace number the marker is assigned to.
Example: | CALC:MARK3:TRAC 2 Assigns marker 3 to trace 2.


CALCulate<n>:MARKer<m>:X

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Using Markers > CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:X <Position>

This command moves a marker to a particular coordinate on the x-axis.

If necessary, the command activates the marker.

If the marker has been used as a delta marker, the command turns it into a normal marker.

Note that markers have to be positioned on a discrete frequency that is part of the frequency list. If you set the marker on a frequency not included in the frequency list, the application positions the marker to the nearest frequency in the list (rounding up or down).

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

The unit is Hz.

Range: The range depends on the current x-axis range.
Example: CALC:MARK2:X 1.7MHz

Positions marker 2 to frequency 1.7 MHz.


CALCulate<n>:MARKer<m>:Y?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Using Markers > CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>:Y? <Result>

This command queries the position of a marker on the y-axis.

If necessary, the command activates the marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Parameters:
<Result> | Selects the result. GAIN Queries gain reuslts. NOISe Queries noise figure results. NUNCertainty Queries the noise figure uncertainty results. PCOLd Queries power (cold) results. PHOT Queries power (hot) results. TEMPerature Queries noise temperature results. YFACtor Queries y-factor results.
Return values:
<Result> | Result at the marker position.
Example: | INIT:CONT OFF Switches to single measurement mode. CALC:MARK2 ON Switches marker 2. INIT;*WAI Starts a measurement and waits for the end. CALC:MARK2:Y? Outputs the measured value of marker 2.
Usage: | Query only
Manual operation: | See "Marker Table"


Using Delta Markers

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Using Delta Markers
Using Delta Markers

Note that the suffix at CALCulate has an effect only if you query the characteristics of a marker. If you set a marker, you can ignore the suffix because the markers are linked to each other over all measurement windows and will always be on the same frequency.

List of Commands
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:Y?


CALCulate<n>:DELTamarker:AOFF

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Using Delta Markers > CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:AOFF

This command turns all delta markers off.

Example: | CALC:DELT:AOFF Turns all delta markers off.
Usage: | Event


CALCulate<n>:DELTamarker<m>:MREF

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Using Delta Markers > CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>:MREF <Reference>

This command selects a reference marker for a delta marker other than marker 1.

The reference may be another marker or the fixed reference.

Parameters:
<Reference> | 1 to 16 Selects markers 1 to 16 as the reference. FIXed Selects the fixed reference as the reference.
Example: | CALC:DELT3:MREF 2 Specifies that the values of delta marker 3 are relative to marker 2.


CALCulate<n>:DELTamarker<m>[:STATe]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Using Delta Markers > CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>[:STATe] <State>

This command turns delta markers on and off.

If necessary, the command activates the delta marker first.

No suffix at DELTamarker turns on delta marker 1.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2 ON

Turns on delta marker 2.

Manual operation: See "Marker Type"


CALCulate<n>:DELTamarker<m>:TRACe

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Using Delta Markers > CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:TRACe <Trace>

This command selects the trace a delta marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> | Trace number the marker is assigned to.
Example: | CALC:DELT2:TRAC 2 Positions delta marker 2 on trace 2.


CALCulate<n>:DELTamarker<m>:X

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Using Delta Markers > CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X <Position>

This command moves a delta marker to a particular coordinate on the x-axis.

If necessary, the command activates the delta marker and positions a reference marker to the peak power.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

Range: The value range and unit depend on the measurement and scale of the x-axis.
Example: CALC:DELT:X?

Outputs the absolute x-value of delta marker 1.


CALCulate<n>:DELTamarker<m>:Y?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Using Delta Markers > CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>:Y? <Result>

This command queries the relative position of a delta marker on the y-axis.

If necessary, the command activates the delta marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

The unit depends on the application of the command.

Parameters:
<Result> | Selects the result. GAIN Queries gain reuslts. NOISe Queries noise figure results. PCOLd Queries power (cold) results. PHOT Queries power (hot) results. TEMPerature Queries noise temperature results. YFACtor Queries y-factor results.
Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a sweep and waits for its end. CALC:DELT2 ON Switches on delta marker 2. CALC:DELT2:Y? Outputs measurement value of delta marker 2.
Usage: | Query only
Manual operation: | See "Marker Table"


Positioning Markers

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Positioning Markers
Positioning Markers

If you are using more than one window, the application performs the peak search in the window that you have selected with the suffix at CALCulate only. Because the markers are linked, the frequency position of the marker in the other windows is adjusted accordingly, even if it means that the marker is on a peak in the selected window only.

List of Commands
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum[:PEAK]


CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Positioning Markers > CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

This command moves a marker to the next higher value.

Usage: | Event
Manual operation: | See "Search Next Peak"


CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

This command moves a marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:MARKer<m>:MINimum:NEXT

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:NEXT

This command moves a marker to the next minimum value.

Usage: | Event
Manual operation: | See "Search Next Minimum"


CALCulate<n>:MARKer<m>:MINimum[:PEAK]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum[:PEAK]

This command moves a marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


Positioning Delta Markers

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Positioning Delta Markers
Positioning Delta Markers

If you are using more than one window, the application performs the peak search in the window that you have selected with the suffix at CALCulate only. Because the markers are linked, the frequency position of the marker in the other windows is adjusted accordingly, even if it means that the marker is on a peak in the selected window only.

List of Commands
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]


CALCulate<n>:MARKer<m>:MAXimum:NEXT

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Positioning Delta Markers > CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:NEXT

This command moves a marker to the next lower peak.

Usage: | Event
Manual operation: | See "Search Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

This command moves a delta marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:DELTamarker<m>:MINimum:NEXT

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT

This command moves a marker to the next higher minimum value.

Usage: | Event
Manual operation: | See "Search Next Minimum"


CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Working with Markers > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

This command moves a delta marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


Using the Status Register

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Status Register
Using the Status Register

The status reporting system stores information about the current state of the R&S FSW. This includes, for example, information about errors during operation or information about limit checks. The R&S FSW stores this information in the status registers and in the error queue. You can query the status register and error queue via IEC bus.

The R&S FSW-K30 features several status registers that are specific to noise figure measurements. Here is a description of those, including the corresponding remote commands.

Contents
  • Status Registers for Noise Figure Measurements


Status Registers for Noise Figure Measurements

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Status Register > Status Registers for Noise Figure Measurements
Status Registers for Noise Figure Measurements

The figure below shows the status registers of the noise figure application.

Status registers for noise figure measurements

The R&S FSW structures the information hierarchically, with the Status Byte register (STB) and the Service Request Enable mask register (SRE) being on the highest level. The STB gets its information from the standard Event Status Register (ESR) and the Event Status Enable mask register (ESE). The STB and ESR are both defined by IEEE 488.2. In addition to the ESR, the STB also gets information from the STATus:OPERation and STATus:QUEStionable registers. These are the link to the lower levels of the status register and are defined by SCPI. They contain information about the state of the instrument.

For a more comprehensive description of the status registers not mentioned here and status register functionality in general see the manual of the base unit.

Contents
  • STATus:OPERation Register
  • STATus:QUEStionable Register
  • STATus:QUEStionable:LIMit Register
  • STATus:QUEStionable:CORRection Register
  • Status Register Remote Commands


STATus:OPERation Register

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Status Register > Status Registers for Noise Figure Measurements > STATus:OPERation Register
STATus:OPERation Register

The STATus:OPERation register contains information on current activities of the R&S FSW. It also contains information on activities that have been executed since the last read out.

Bit no | Meaning
0 to 3 | Unavailable for noise figure measurements.
4 | MEASuring This bit is set if a measurement is in progress.
5 to 6 | Unavailable for noise figure measurements.
7 | CORRecting This bit is set if a 2nd stage correction is in progress.
8 | HCOPy This bit is set if a hardcopy is created.
9 - 14 | Unavailable for noise figure measurements.
15 | This bit is always 0.


STATus:QUEStionable Register

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Status Register > Status Registers for Noise Figure Measurements > STATus:QUEStionable Register
STATus:QUEStionable Register

The STATus:QUEStionable register contains information about indefinite states which may occur if the unit is operated without meeting the specifications.

Bit no | Meaning
0 to 7 | Unavailable for noise figure measurements.
8 | CALibration This bit is set if the R&S FSW is not calibrated.
9 | LIMit This bit is set if a limit line is violated.
10 | Unavailable for noise figure measurements.
11 | CORRection This bit is set if the noise figure calibration is questionable.
14 | Unavailable for noise figure measurements.
15 | This bit is always 0.


STATus:QUEStionable:LIMit Register

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Status Register > Status Registers for Noise Figure Measurements > STATus:QUEStionable:LIMit Register
STATus:QUEStionable:LIMit Register

The STATus:QUEStionable:LIMit register contains information about limit lines and the results of a limit checks.

The number of LIMit registers depends on the number of measurement windows available in any application.

Bit no | Meaning
0 | LIMit 1 FAIL This bit is set if limit line 1 is violated.
1 | LIMit 2 FAIL This bit is set if limit line 2 is violated.
2 | LIMit 3 FAIL This bit is set if limit line 3 is violated.
3 | LIMit 4 FAIL This bit is set if limit line 4 is violated.
4 | LIMit 5 FAIL This bit is set if limit line 5 is violated.
5 | LIMit 6 FAIL This bit is set if limit line 6 is violated.
6 | LIMit 7 FAIL This bit is set if limit line 7 is violated.
7 | LIMit 8 FAIL This bit is set if limit line 8 is violated.
8 to 14 | Unavailable for noise figure measurements.
15 | This bit is always 0.


STATus:QUEStionable:CORRection Register

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Status Register > Status Registers for Noise Figure Measurements > STATus:QUEStionable:CORRection Register
STATus:QUEStionable:CORRection Register

The STATus:QUEStionable:CORRection register contains information about the calibration status of noise figure measurements.

Bit no | Meaning
0 | NO CORRection This bit is set if calibration is required.
1 to 2 | Unavailable for noise figure measurements.
3 | Missing Loss or ENR values This bit is set if loss or ENR values are missing for one or more measurement frequencies.
4 to 14 | Unavailable for noise figure measurements.
15 | This bit is always 0.


Status Register Remote Commands

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Status Register > Status Registers for Noise Figure Measurements > Status Register Remote Commands
Status Register Remote Commands
List of Commands
STATus:OPERation[:EVENt]?
STATus:QUEStionable[:EVENt]?
STATus:QUEStionable:CORRection[:EVENt]?
STATus:QUEStionable:LIMit[:EVENt]?
STATus:OPERation:CONDition?
STATus:QUEStionable:CONDition?
STATus:QUEStionable:CORRection:CONDition?
STATus:QUEStionable:LIMit:CONDition?
STATus:OPERation:ENABle
STATus:QUEStionable:ENABle
STATus:QUEStionable:CORRection:ENABle
STATus:QUEStionable:LIMit:ENABle
STATus:OPERation:NTRansition
STATus:QUEStionable:NTRansition
STATus:QUEStionable:CORRection:NTRansition
STATus:QUEStionable:LIMit:NTRansition
STATus:OPERation:PTRansition
STATus:QUEStionable:PTRansition
STATus:QUEStionable:CORRection:PTRansition
STATus:QUEStionable:LIMit:PTRansition


STATus:OPERation[:EVENt]?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Status Register > Status Registers for Noise Figure Measurements > Status Register Remote Commands > STATus:OPERation[:EVENt]?
STATus:OPERation[:EVENt]?
STATus:QUEStionable[:EVENt]?
STATus:QUEStionable:CORRection[:EVENt]? <ChannelName>
STATus:QUEStionable:LIMit[:EVENt]? <ChannelName>

These commands read out the EVENt section of the status register.

The commands at the same time delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


STATus:OPERation:CONDition?

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Status Register > Status Registers for Noise Figure Measurements > Status Register Remote Commands > STATus:OPERation:CONDition?
STATus:OPERation:CONDition?
STATus:QUEStionable:CONDition?
STATus:QUEStionable:CORRection:CONDition? <ChannelName>
STATus:QUEStionable:LIMit:CONDition? <ChannelName>

These commands read out the CONDition section of the status register.

The commands do not delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


STATus:OPERation:ENABle

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Status Register > Status Registers for Noise Figure Measurements > Status Register Remote Commands > STATus:OPERation:ENABle
STATus:OPERation:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:CORRection:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:LIMit:ENABle <SumBit>,<ChannelName>

These commands control the ENABle part of a register.

The ENABle part allows true conditions in the EVENt part of the status register to bereported in the summary bit. If a bit is 1 in the enable register and its associated event bit transitions to true, a positive transition will occur in the summary bit reported to the next higher level.

Parameters:
<SumBit>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


STATus:OPERation:NTRansition

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Status Register > Status Registers for Noise Figure Measurements > Status Register Remote Commands > STATus:OPERation:NTRansition
STATus:OPERation:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:CORRection:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:LIMit:NTRansition <SumBit>,<ChannelName>

These commands control the Negative TRansition part of a register.

Setting a bit causes a 1 to 0 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<SumBit>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


STATus:OPERation:PTRansition

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Using the Status Register > Status Registers for Noise Figure Measurements > Status Register Remote Commands > STATus:OPERation:PTRansition
STATus:OPERation:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:CORRection:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:LIMit:PTRansition <SumBit>,<ChannelName>

These commands control the Positive TRansition part of a register.

Setting a bit causes a 0 to 1 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<SumBit>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


Deprecated Remote Commands for Noise Figure Measurements

Noise Figure Measurements (R&S FSW-K30) > Remote Control Commands for Noise Measurements > Deprecated Remote Commands for Noise Figure Measurements
Deprecated Remote Commands for Noise Figure Measurements

Following is a list of deprecated remote commands. The remote commands are still supported to maintain compatibility to previous versions of noise figure measurements (like the R&S FSV-K30), but it is strongly recommended to use the command system in the way it is meant to be used in the R&S FSW-K30.

Legacy command | Replaced by | Comment
CALCulate:LIMit:TRACe | CALCulate:LIMit:TYPE | Parameters NFIGure, TEFFective and GAIN were supported to assign a limit line to a result and thus the trace because trace and result type were fix. CALCulate:LIMit:TRACe now assigns the limit line to a trace (1 to 4).
CALCulate:MARKer:TRACe CALCulate:DELTamarker:TRACe |  | The parameters NOISe, GAIN, NMEM1-3 and GMEM1-3 have been replaced by 1 | 2 | 3 | 4 because no distinction is made between memory and live trace.
CONFigure:ARRay:MEMory | TRACe:COPY | No more distinction between memory and live traces.
CONFigure:SINGle | CONFigure:FREQuency:SINGle |
DISPlay:ARRay:MEMory:STATe DISPlay:CURRent:DATA:STATe | DISPlay:WINDow:TRACe:STATe | No more distinction between memory and live traces.
DISPlay:DATA:TRACe | LAYout system |
DISPlay:FORMat | --- | Functionality not supported any more.
DISPlay:WINDow:TABLe | LAYout:WINDow:REPLace / LAYout:REPLace:WINDow |
FETCh: command system | TRACE:DATA |
SENSe:SWEep:POINts | SENSe:FREQuency:POINts |
SENSe:FREQuency:CW:FIXed | SENSe:FREQuency:SINGle |


List of Remote Commands (Noise Figure)

Noise Figure Measurements (R&S FSW-K30) > List of Remote Commands (Noise Figure)
List of Remote Commands (Noise Figure)
[SENSe:]BANDwidth|BWIDth[:RESolution]
[SENSe:]CONFigure:MODE:DUT
[SENSe:]CONFigure:MODE:SYSTem:IF:FREQuency
[SENSe:]CONFigure:MODE:SYSTem:LO:FREQuency
[SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SNUMber
[SENSe:]CORRection:ENR:CALibration:MODE
[SENSe:]CORRection:ENR:CALibration:SPOT
[SENSe:]CORRection:ENR:CALibration:TABLe:SELect
[SENSe:]CORRection:ENR:COMMon
[SENSe:]CORRection:ENR[:MEASurement]:MODE
[SENSe:]CORRection:ENR[:MEASurement]:SPOT
[SENSe:]CORRection:ENR[:MEASurement]:TABLe:DATA
[SENSe:]CORRection:ENR[:MEASurement]:TABLe:DELete
[SENSe:]CORRection:ENR[:MEASurement]:TABLe:SELect
[SENSe:]CORRection:IREJection
[SENSe:]CORRection:LOSS:INPut:MODE
[SENSe:]CORRection:LOSS:INPut:SPOT
[SENSe:]CORRection:LOSS:INPut:TABLe
[SENSe:]CORRection:LOSS:INPut:TABLe:DELete
[SENSe:]CORRection:LOSS:INPut:TABLe:SELect
[SENSe:]CORRection:LOSS:OUTPut:MODE
[SENSe:]CORRection:LOSS:OUTPut:SPOT
[SENSe:]CORRection:LOSS:OUTPut:TABLe
[SENSe:]CORRection:LOSS:OUTPut:TABLe:DELete
[SENSe:]CORRection:LOSS:OUTPut:TABLe:SELect
[SENSe:]CORRection:TEMPerature
[SENSe:]CORRection[:STATe]
[SENSe:]FREQuency:CENter
[SENSe:]FREQuency:LIST:DATA
[SENSe:]FREQuency:SINGle
[SENSe:]FREQuency:SINGle:COUPling
[SENSe:]FREQuency:SPAN
[SENSe:]FREQuency:STARt
[SENSe:]FREQuency:STEP
[SENSe:]FREQuency:STOP
[SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:LOPower
[SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:PORTs
[SENSe:]MIXer:RFOVerrange[:STATe]
[SENSe:]MIXer:SIGNal
[SENSe:]MIXer:THReshold
[SENSe:]MIXer[:STATe]
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:POINts
[SENSe:]SWEep:TIME
ABORt
CALCulate:LIMit:ACTive?
CALCulate:LIMit:CLEar[:IMMediate]
CALCulate:LIMit:COMMent
CALCulate:LIMit<k>:CONTrol:SHIFt
CALCulate:LIMit<k>:CONTrol[:DATA]
CALCulate:LIMit<k>:COPY
CALCulate:LIMit<k>:DELete
CALCulate:LIMit<k>:FAIL?
CALCulate:LIMit<k>:LOWer:SHIFt
CALCulate:LIMit<k>:LOWer:STATe
CALCulate:LIMit<k>:LOWer[:DATA]
CALCulate:LIMit<k>:NAME
CALCulate:LIMit<k>:STATe
CALCulate:LIMit<k>:TRACe
CALCulate:LIMit<k>:TRACe<t>:CHECk
CALCulate:LIMit<k>:TYPE
CALCulate:LIMit<k>:UPPer:SHIFt
CALCulate:LIMit<k>:UPPer:STATe
CALCulate:LIMit<k>:UPPer[:DATA]
CALCulate:UNCertainty:COMMon
CALCulate:UNCertainty:DATA:FREQuency
CALCulate:UNCertainty:DATA:GAIN
CALCulate:UNCertainty:DATA:NOISe
CALCulate:UNCertainty:DATA:RESults
CALCulate:UNCertainty:ENR:CALibration:UNCertainty
CALCulate:UNCertainty:ENR:UNCertainty
CALCulate:UNCertainty:MATCh:DUT:IN:[VSWR]
CALCulate:UNCertainty:MATCh:DUT:IN:RL
CALCulate:UNCertainty:MATCh:DUT:OUT:[VSWR]
CALCulate:UNCertainty:MATCh:DUT:OUT:RL
CALCulate:UNCertainty:MATCh:PREamp:RL
CALCulate:UNCertainty:MATCh:PREamp[:VSWR]
CALCulate:UNCertainty:MATCh:SOURce:CALibration:RL
CALCulate:UNCertainty:MATCh:SOURce:CALibration[:VSWR]
CALCulate:UNCertainty:MATCh:SOURce:RL
CALCulate:UNCertainty:MATCh:SOURce[:VSWR]
CALCulate:UNCertainty:PREamp:GAIN
CALCulate:UNCertainty:PREamp:NOISe
CALCulate:UNCertainty:PREamp:STATe
CALCulate:UNCertainty:SANalyzer:GAIN:UNCertainty?
CALCulate:UNCertainty:SANalyzer:NOISe:UNCertainty?
CALCulate:UNCertainty[:RESult]?
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>[:STATe]
CONFigure:CORRection
CONFigure:FREQuency:CONTinuous
CONFigure:FREQuency:SINGle
CONFigure:LIST:CONTinuous
CONFigure:LIST:SINGLe
DISPlay[:WINDow<n>]:TRACe:SYMBols
DISPlay[:WINDow<n>]:TRACe:X[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:BOTTom
DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:RLEVel:AUTO
DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:TOP
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
FORMat:DEXPort:DSEParator
FORMat:DEXPort:HEADer
FORMat:DEXPort:TRACes
FORMat[:DATA]
INITiate:CONTinuous
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate[:IMMediate]
INPut:ATTenuation
INPut:COUPling
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:GAIN:STATe
INPut:GAIN[:VALue]
INPut:IMPedance
INSTrument:CREate:DUPLicate
INSTrument:CREate:REPLace
INSTrument:CREate[:NEW]
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace
MMEMory:STORe<n>:TRACe
SOURce:EXTernal:FREQuency:OFFSet<offset>
SOURce:EXTernal:FREQuency[:FACTor]:DENominator
SOURce:EXTernal:FREQuency[:FACTor]:NUMerator
SOURce:EXTernal:POWer[:LEVel]
SOURce:EXTernal:ROSCillator[:SOURce]
STATus:OPERation:CONDition?
STATus:OPERation:ENABle
STATus:OPERation:NTRansition
STATus:OPERation:PTRansition
STATus:OPERation[:EVENt]?
STATus:QUEStionable:CONDition?
STATus:QUEStionable:CORRection:CONDition?
STATus:QUEStionable:CORRection:ENABle
STATus:QUEStionable:CORRection:NTRansition
STATus:QUEStionable:CORRection:PTRansition
STATus:QUEStionable:CORRection[:EVENt]?
STATus:QUEStionable:ENABle
STATus:QUEStionable:LIMit:CONDition?
STATus:QUEStionable:LIMit:ENABle
STATus:QUEStionable:LIMit:NTRansition
STATus:QUEStionable:LIMit:PTRansition
STATus:QUEStionable:LIMit[:EVENt]?
STATus:QUEStionable:NTRansition
STATus:QUEStionable:PTRansition
STATus:QUEStionable[:EVENt]?
SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess
SYSTem:COMMunicate:RDEVice:GENerator:INTerface
SYSTem:COMMunicate:RDEVice:GENerator:TYPE
SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess
SYSTem:CONFigure:DUT:GAIN
SYSTem:CONFigure:DUT:STIMe
SYSTem:CONFigure:GENerator:CONTrol:STATe
SYSTem:CONFigure:GENerator:INITialise:AUTO
SYSTem:CONFigure:GENerator:INITialise:IMMediate
SYSTem:CONFigure:GENerator:SWITch:AUTO
SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:SEQuencer
TRACe<n>:COPY
TRACe<n>[:DATA]?


Legal Notice

R&S®FSW-K30
Noise Figure Measurements

© 2014 Rohde & Schwarz GmbH & Co. KG

Mühldorfstr. 15, 81671 München, Germany

Phone: +49 89 41 29 - 0

Fax: +49 89 41 29 12 164

E-mail: info@rohde-schwarz.com

Internet: www.rohde-schwarz.com

Subject to change – Data without tolerance limits is not binding.

R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.

Trade names are trademarks of the owners.